D?S DASSAULT

SUSTEMES

2
DS SOLIDWORKS

WHAT'S NEW
SOLIDWORKS 2019




Contents

=T = I A (] (o Y 11
1 Welcome to SOLIDWORKS 2019....ceiieiiiieee e 14
B o] o T =t F= T o= 0 0 1= o 1 £ U 15
Performance IMProVEMENTS .......cooi it e e et e e e et e e e e e naeeas 16
FOr More INfOrMatioN .........oiiiiiiie e e e e e e s et e e e e st e e e e e nnnee e e e e ennres 20

2 USEI INEITACE ... e e e e e e e e e e e eeeennnnes 22
Breadcrumbs ENhanCemENtS ... ..o 22
Customizing Task Pane Tabs ... e 22
Improved Preview for Minimized DOCUMENTS ...........cooiiiiiiiiiiiicece e 23
Keyboard ACCESSIDIIILY ........cooiiiiiiiie e 23
Markups for Collaboration ............ooi i 24
[ LS 0 = I To | PP UPPUP PP 24
Microsoft Surface Dial in SOLIDWORKS ........ .o e 24

(O] o= T B T= 1 oo [ = o ) PR PRPRPRRR 25
Opening Part Configurations in QUIiCk View MO ..........cccciiiiiiiiiiie e 25
Recent Documents IMpProvemMENtS ... ... e e e e e e 26
Rollback Bar Drag INtEraction .............eeiiiiiiiiii et e e as 27
StATUS FEEADACK ... ettt e e e e st e e e e sent e e e e e antaeeeeeannraeeeean 27
1o 10T 1 o T 1S 27

3 SOLIDWORKS Fundamentals............coooviiiiiiiiiiiiiiee e 28
Application Programming INterface...........cooo i 28
Changes to System Options and Document Properties...........cccoocuueeeeiiiiiiee i 29
Specifying a Default Save FOIAEr ..........ooo e 32

4 INSTAIIAtION ...t 33
= £ (= g I 10111/ ][ - To SRS 33

ST Yo [0 1T T 1= =1 (] o SR 34
e [ 01 o T o €= | PP UPTUP PR 34
Assign Members t0 @ ProdUCT ... 34

Filter Products @nd SErVICES........ciiiiiiiieicieeee ettt e e e e ar e e e e e e e e e s e eenreneeees 34
Comparing Geometry in the Upgrade ASSIStant ............cccoviiiiiiiiniiiiie e 35
Improved Performance with Pack and GO .........coooiiiiiiiiiiiie e 35
Improved Problem Capture in SOLIDWORKS RX ......coiiiiiiiiiiiiiiiiiee e sieeee e 35
Language Translation for Settings Administrator TOOI..........coooiiiiiii i 36



Contents

B ASSEMDIIES ... e e e e e e e anennnnas 37
Bounding Box in ASSEMDIIES Ball..... ... 37
Bounding Box PropertyManager...........ooooiiiiiiiiieeee e e e e 38
Component PrevieWw WINAOW ..........oooiiiiiiiiieeeee e e e e e 39
(@701 ¢ 1Y 1 To N 8 T Y- To LSS 40
Defeature PropertyManager - Silhouette Ball.............ccooiiiiiiiiii e 40
Defeature - DEfINE GrOUPS ... ..uuiiiiiiiee et e et e e e e e e e e e s e ee e e e e e e e e e aeaannnennaeeeeaeas 40
EXPIOAEA VIEWS Balooeoeoeoeeeeeeeeeoeeeoeoeoeoeeoeoeeeeeeeeeeeeeeeeeeeee 43
External References Ball........ ...t e e e e e e e e e e e e e eeaes 43
Large DeSIGN REVIEW ... ... i r e e e e e e e e e e e e e e e e e e et e e e e eeeeeaeresrsennnnnnnnnnan 47

Editing Assemblies in Large Design ReVIEW ... 47
Large Design ReVIEW Mark .........oouiiiiiiiiie e e 49
Limitations for Tools in Edit Assembly MOde ... 49
Magnetic Mates in Large Design ReVIEW ...........ooo i 50
LIghtWeight IMOGE .....cooieieie ettt e et e e s et e e e e nbe e e e e e nnes 50
1Y = 1= OO ST EPTPPPUPT PP 51
Automatically Lock Rotation for Concentric Mates to Toolbox Components.......................... 51
Disabling Automatic Mate Updates in TOOIDOX ........cc.uuiiiiiiiiiiii e 52
Grouping Mates and Separating Fasteners.............cccoooiiiiiiiiiiiiee e 52
Negative Values for LimitAngle Mates in Mate Controller............ccceiiiiiiiiiiiiiieeeee 54
= (=] 0 1= SRR PS 55
CIrCUIAN PatterNS ... .eiiieiiee et 55
Including Custom Properties in a Mirrored Assembly ..., 55
I TCTo T = =T o 1 PR 56
Performance EValuation............cooiiiiiiiiiii e 57
Saving an Assembly as @ Part Ball...... ... 57
Assemblies Saved as Parts EXport OplionS..........ccccvuiiiiiiiiiie e 58
Save Assembly as Part PropertyManager..........c..eeiiiiiiiiieiiiiiiee e sieee e sieee e eraeee e 58
Select Identical COMPONENTS .........coiiiiiii e e 60
TTEENOUSE ...ttt ettt e bt e e bt s bt e e eae e e e bt e ear e e e e e 61
Create Custom and Configuration-specific Properties in Treehouse kaf..................ccccooo. 61
Display iN @ LISt VIBW ..ot e e e e e e e 62
Select Multiple Files for IMPOKt..........oooii i 62
Treehouse Graphics Area ENhancements ... 63
Treehouse OpPtioNs Ball..... ... e e e e e e e e e e e e e e e 63
Warning When Inserting Complex COMPONENtS........ccooiiiiiiiiiiiiiie e 65

7 SOLIDWORKS CAM ... e e e e e e e e e e e e e e e e eeeaaeas 66
Assign Default Strategies to Maching TYPeS .......cooiuiiiiiiiiiiii e 66
CNC Compensation for Curve FEAtUIES ...........uueeiiiiiiiiii i 66
Corner Slowdown and Arc Feed Rate..........c..ueeiiiiiiii e 66
Improved Chamfer Machining ...........ooiiiiiiiii e 66



Contents

Improved Toolpath EdIfiNG ..........e e e e e e e e e eeeeas 67
Improvements to Tolerance-based Machining..........c..cooiiiiiiiiiiiii e 67
More Parameters for Tapered ShanKs.............eoeiiiiiiiiiiiiiiiiieee e 67
8 CrCUITWOIKS ...ttt e e e e e e e e e e aeeeeeeeaennnnnns 68
Recognizing Additional SOLIDWORKS Features in CircuitWorks...........ccoccoieiiiiiiiniiec e 68
O SOLIDWORKS COMPOSEN .....ccceiiieiiiiiiiiiiiineaaaaa e e e e aaeaaeeeeeeeeeeaasasnnnnasaaeaeaeaaaeeeeees 69
SOLIDWORKS COMPOSET ....ceiiiitiiieeeiiteiee e e atteee e e ettt eea e s aabeeeee s aatteeeeeaanbeeeaesabteeeeeaanbaeeeesaaneeeeesanne 69
Animation Library Workshop and Timeline Enhancements...............ooovvviiicciciiieieeeeeeee, 69
Defining Custom IMport Profiles ... 70
Importing Assembly ENVelopes Option .........c.eiiiiiiiiiiie e 70
IMPOrtiNG PMI Data.......oooviiiiiiiiiieeeee e e e e e e e e e e e e aaaaeaeaeeeeeeaees 70

Y =T U o T o (0] o 1= (= PP PERRR 71
Measurement Properties..........ooi it 71
Number of Selected Actors Appears in the Status Bar.............cccccoviieeeei i, 72
Search for Collaborative ACLOIS ........oo i i a e e e 72
Search for Commands in the RIbDDON ... 72
Select AdJACENT PaItS.........oooiiiie e e 72
SOLIDWORKS PDM INtEGration .........ceiiiiiiiiii ittt ee e 72
Undefined Color Properties in Animation Library ..........cccoooiiiiiie e 73
User Experience Enhancements for SOLIDWORKS COMPOSEr.........cveeeveeeeeeiiiiiciiiiirieeeeenenn. 73
Versioning of BaCKUP FileS ... e 74
WOTKING WIth VIBWS ... e e e e e e e e nneeas 74
SOLIDWORKS COMPOSEN SYNC....uuuitiiiiiiiieieeeeeeieiiitteeeeeeeeaeeesaesissaaaeeeesaaaesassaaaantssseeeeaaasaesaaaanns 74
Conversion Properties - Occlusion OPtioNS........oooiii i 74
Importing Assembly ENVelopes Option .........cueeiiiiiiiiiiei e 75
IMPOrtiNG PMI Data.......oooiiiiiiiiiieeeee e e e e e e e e e e e e aaaaaaeeeeeeeeanes 75
Remove Empty Groups After OCCIUSION ........coiiiiiiiiiie e 76
I 4D o 7= o USSP 77
Copying DimXpert Schemes to Derived Parts...........occuuiiiiiiiii e 77
DT a gDt o= A == | (U =T P 77
DImXpert for ASSEMDIIES ... ... et e e e e e e e e e e e e eeeeas 77
/1= I T g T= Y =] T o PSP 77
11 Detailing and DraWingS ......coooieiiiiieiee et e e e e e eerae e e aeeane 78
Automatic View Updates and EXCIUSIONS...........ccoooiiiiiiiii e e e e ee e 78
Configuring the Precision of Dimensions and Tolerances............cc.ueiiiiiiiiiiiiieie e 79
Displaying SCrOlDAIS .........cooiiiiiieii e s e e e e e e e e 80
Drawing Open Progress INdicator Ball...............ccoiiiiiiiiiiiii e 80
ISO Tolerance-Modifying SYMDOIS ........oouiiiiiiii e 81
Performance Improvements - Detailing and Drawings..........ccoeooiiiiiiciiiiiiiiieeeee e 84
REMOVEA SECHON VIBWS ....coiiiiiiiie ettt et e et e e e e e e e e st e e e e e nnste e e e e e nteeeeeennneeas 85
1= o[ S 86



Contents

Changing Cell Border ThiCknNess Ball.............coooiiiiiiiiiiiii e 86
Custom Properties in Lightweight BOMS ...........ooiiiiiiiiiii e 87
Customizing Quantity Column Headers in BOMS.........coccciiiiiiiiiie e 88

Hole Table Tags - Prefixes, Numbers, and Order..........ccccovvveeiiiiicciiiiiiieeeee e 89
Including Thumbnails in BOMs Exported to Microsoft EXCel............ceevveieeeiiiiiiiiiiiiieiieeeeeeee, 89

2= = 1T o e TSP 91
Configurations in SOLIDWORKS Parts Ball ............cooiiiiiiiiiiiiieiie e 91
Configurations in SOLIDWORKS Assemblies Ball ... 91
€Drawings PerfOrMEanCE........cooo it e e s e e 91
eDrawings Professional Features Ball ... 92
PErSPECIIVE VIBWS ...t e e e e e e e e e e e e e e e e e e e e e e e e e e eere e ar b naas 92
UsiNg AMDIENT OCCIUSION ...ttt e et e e st e e e e bbe e e e e nneeas 92
SAVE AS WED HTIML ..eeiiiiiiiiiie ettt e e ettt e e ettt e e e sttt e e e e snbte e e e e sbaeeeeesanseeeaeeann 92
Supported File Types in €Drawings .......cooooiiiiiiiiieee e e e e e e e e e 93
13 SOLIDWORKS EIECHICAl.......ceeeiieiiiiiiiieeee e e e 95
=] = o3 Q= To ) G =Ty 41 = PR 96
(07 o] [T 07 0] (1= SRR 96
Connector Graphical Representation ...............ooouimiiiiiiiiiiiiii e 96
Conversion to Mixed SCheme Drawing .........ccooiiiuiiiiiiie et 96

= Lo I =T 0 1T F= o] E PP PPP TP PPPP 96
INPUL/OULIPUL SYMDOL ...ttt e e e e e e e e e e e e e e e e e e e nnnneeeeeeas 97
LIiNKS iN REPOM DIAWINGS ..cooiieiiiieiiiiiiie ettt ettt ettt e e et e e e e b e e e e e nbe e e e e enneeas 97
Y=o o T o T | PP PPTPTT R TPPPP 98
Option for DIMENSION UNIES ....ooieiiiiiiiiceeeee e e e e e e e e e e e e e eaeeeees 98
Reach a Drawing Dialog BOX ........oiiuuiiiiiiiiiiiei ettt 98
Renumber Components FEALUIE...........oooo i e 98
ReViISIONS ManagemMENt ........ ... et e e e e e e e e e e e e e e e e eee s 98
Saving Symbols as Palettes...... ... 98
Wire Cabling Order Dialog BOX..........ccccuuiiiiiiiieie ettt e e e e e e e e e e e e s s aeeeeaaaaeas 98
Improved Performance in SOLIDWORKS Electrical 3D...........ouuviiiiiiiiiiiiiieieeeieeeeeeeeeeeeeeeeeeeaa, 98
14 SOLIDWORKS Flow Simulation............uueiiiiiiiieeeeeeeeeeeee e 100
ST Yoot (Yo I €T P 100
Customized Visualization Parameters.............ooiiiiiiiiiiiiiie e 100
Edit a Two-resistor from Component EXPIOrer............ooooeiiiiiiiiiiiiiiccieie e, 101
Flux Measure on Semitransparent SUMacCeS ..........cooouiiiiiiiiiiiie e 101
10 5 [ SRR 101
Project Parameters.. ... ..ot a e e e e e e e e anneee 101
Surface Parameters in SECHONS ........uuiiiiiiiee et e e e e e e e e aennes 101
RS T L] oTe] 74 b oo i (PRSPPI 102
Exporting to the PLY File FOrmat...........ooooii i 102



Contents

Exporting Using Extended Reality ..........occuuiiiiiiiiiii e 102
Reading Tessellation Data from Foreign CAD Files Ball.............cccciiiiiiiiiiiiee e 103
16 SOLIDWORKS INSPECLION......coiiiiiiiiiiiee e 104
SOLIDWORKS INSPECHON Add-iN......ceeiiiiieiiiiieeeeee e e e e e 104
Bill Of CharacteriStiCS.......iiieiiiiieiie e e e e e e e e e e e 104
L1015 (o] 4 T o o] o 1= 1= T SO PPUPPURT 105
Hole Table EXIraction ... e e e e e e 105

P 11 IR0 o] oo ] A PP PRR 106
SOLIDWORKS Inspection Standalone...........cc.uuviiiiiiiiiee et a e 106
SOLIDWORKS PDM INteQration ...........coicuiiiieiiiiiiee e e e eeieeee e sieee e e e s sinaeeassnnaeeee s 106
17 SOLIDWORKS MaANAQE.......cceiiiieieiiiiieiiieee e e e e e et e e e e e e e e e e e eeeeeees 107
Adding a References Folder StrUCIUe .........oouueiiiiiii e 108
Alternate Options for Mapping Properti€S..........cooocuiiiiiiiiiiee et a e 108
Bill of Materials PerfOrmMancCe .........oouviiiiiiiiiii ettt ee e e e re e e e ennees 108
BOM Tab Content INAICALON .........eeiiiiieeee e e e e e e e e e e e e e e nnreneeees 109
Changing the SOLIDWORKS PDM State Through a Process Output.............cccceccvvviiiieeeneeennn. 109
Configuration File ULty .........ooiiiiii e e e e e enrae e e e nees 109
Copying Custom Values in BOM HEMS ..o 110
DT Tod U o 0 T=T o A =T 0 0] 0] F=1 L= USRS 110
Duplicate BOM LIiNE HEMIS .........ueiiiiiiii e e e e e 110
Export Template Configuration ... 111
Field Group SEIECHON .......cco it e e e e e e e e e s e aeeeeaaaeeessesannnnnes 111
U= o T 1= o | TSR 112
Hours for Working Days iN ProjECtS ........uuuiiiiiiiieee e 112
Importing BOM Data from a Microsoft Excel File...........ceeovviiiiiiiiiieee e, 113
Inactive Configuration Handling in ProCESSES ........coicuviiiiiiiiiiiie e 113
Item Detail Pane for BOM VIEW ........ccoiiiiiiiiiiiiiiiiee ettt e et ee e e e e e e e e e snnnnreeeeees 113
Linked ReCOId ODJECES ......ciiiiiiiiieeieeee et e e e e e e e e e e e e e s ereeaaaeeeesaesnnrnnes 114
Configuring LiNKkEed RECOMAS ........cociiiiiiiiieieiiiiee ettt e e e e e s e e s annaeeens 114
Selecting a Linked Record ODJECL.........coooiiiiiiiiii e 114
Defining the Field Mapping .........c.oiiioiiiiiiiieee e e e e e e e e e rae e 115
Defining Related and Reference File Mapping........cccceeeiiiiiieeiiiiiiee e 116
210 Y =T o] o] g e @] o] 1 o] oI S PP OTURPRPPRRRN 116
Mapping the Field Groups to the Linked Record Object............cooociiiiiiiiiiiiciiieee, 116
Numbering SChemMeE OPLiONS ........ccviiiie e e e et e e e s sareeea e e 117
Creating LINKEd RECOMS ......oiueiiiiiiiiiiie et 117
Primary REFEIENCES .........coo et e e e e e e e s rr e e e e e e e e e e e e eanrenes 118
List Of RECENT DOCUMENTS ... .eiiiiiiiiiiiie ettt e e e e e e e e s et e e e e ensbeeeeeennnreeaeeennnes 119
Manual Quantity SYNChronization ............cc.ueeiiiiii e 119
ODbject TYPE HYPEIINKS .....coiiiiiiieiiee e e e e e e e e e e s e e eaaeeeeeaans 119
Performance Improvement in Synchronization...............coocciiiiiiiiiic e 120
Rich Text in MemO FIeldS .........uuiiiiieeee e e e e e e e e e 120
SOLIDWORKS PDM Records in Where Used Tab..........ccooiiiiiiiiiiiiie e 120



Contents

Splitting an Auto NUMDET ..o 121
Splitting Projects iNt0 STAgES ... .veiiieiiiiiee e 121
Support for Internal COMPONENTS ........cceiiiiii i e e e e s e e e e e e e e e e e aeannns 122
Thumbnail Images of SOLIDWORKS PDM FileS .......ccooiiiiiiiiiiiiiieeec e 122
Updating SOLIDWORKS PDM Variables.........c.uuiiiiiiiiiie et 122
18 SOLIDWORKS MBD ......uuiiiiiiiiiiiiiieeeee ettt e e e e e e e e e e e e e e e e e e aennnnes 123
BT I 0| 1RSSR 123
Publishing t0 3D PDF FilES ......cooiiiiiiiiiiiiei e 123
Adding Security fOor 3D PDF FileS.....ccoiuiiiiiiiieie e 124
Option to Edit 3D PDF TemPIates .........coooioiiiiiiieieeee et 124
CommandManager Tab ReNameEd..........oocuuiiiiiiiiiiie e 125
Copying DimXpert Schemes AcCross DOCUMENTS ..........uuiiiiiiiiiiie e 125
Display of Cosmetic Threads and Weld Beads.............c.uvveeeiiiiiiiiiiiiieeeeeeeee e 125
Displaying General TOIEraNCES .........uuiiiiiiiiii ettt e e 126
Support for Sheet Metal in MBD Rall...........oooiiiiiii e e e 126
TEXE SIZE IN 3D VIBWS ...eeiiieieiieie ettt e et e e st e e e e et e e e e e nste e e e s annsaeeeeeanssaeaeeennseeas 127
19 MOAEI DiISPIAY ... 128
ANIMation OULPUL File TYPES ...coiiiiiiiii et 128
Model Display Performance IMprovVEMENTS...........coooiuuiiiiiiiiiiie e a e 129
Rendering Performance IMprovemMENTS ..........cccuuiiiiiiiiiiie e e e 129
Transforming Textural Appearances with the 3D Texture Tool kal ..o, 129
Applying a Textural APPEAraNCE............uuiiiiiiiiee e ee e e e e e e e e e e ee e eeeeas 129
Creating 3D TEXIUIES ... ..uiiii ettt ettt e e s et e e e s e e s anneeeas 131

20 Parts and Features..... ... 135
L0108 aTo [T aTo =703 = T PPREURR 135
Cosmetic Threads IMProVEMENLS ..........cooiiiiiiiiiiiiiieee e e e e e e e e e e eaaans 135
Creating Partial Chamfers and Fillets Ball ... 136
Deleting HoleS from SUIMACES ......coiiiiiiiiiiieeeee e e 138
FeatureWorks Maintains References in Drawing VIEWS ..........occviviiiiiiiiiiiiiiiieee e 138
Inserting a Part with a Specific Configuration Ball ..............ccccoiiiiiiiii e 139
MeSh BREP BOGIES ....cooeiiiiiiiiieii ittt e e e e e e e e e e aeeeeaaaeeeeaeaannnnnee 139
More Tools for Preparing MESHhES .........c.uuiiiiiiiiii e 139
Segment Imported Mesh Body TOOI..........cc..uuiiiiiiiieeee e 140
Specifying Tolerances for Hole Wizard Holes Ball ............ ..o 143
Thumbnail Preview for Blocks in Design Library .........cooccoeiiiiiiiio e 145
Using Interference Detection for Multibody Parts Ball ... 146
21 SOLIDWORKS PCBi.....coiiiiiiiieeee ettt et 149
FIEE PCB VIBWET ...ceeeiiiii ettt ettt e e e e e e e et te et e e aaeeeeessanssnstsaaeeeeaaeeeesesnnnnnnns 149
Mechanical Oriented WOrKIIOW ...........oouiiiiiiii e 149



Contents

PCB Connector/ECAD-MCAD Collaboration ... 150
BOArd ThICKNESS ....ceeiiiiie et e et e e e e e e e e e s e neeeeeeaaeeeeeeaannnnnes 150
1070] o] o1 S U] o] o o] AU O PP UPPURTT 150
[ [To] o1 To T @7o] o ¢ o o] aT=T o1 & PR R 150
Multi-contour HOIE SKEICNES ......o.oii i 151
Silkscreen, Solder Mask, and Solder Paste SUPpOrt.........ccccoeeeeeiiiiiiiiiieeeeeeee e, 151

SOLIDWORKS PCB Miscellaneous Enhancements ..o 151

22 SOLIDWORKS PDM.... .ottt 152

Changing Default License Type in SOLIDWORKS PDM Web2 .........cocoiiiiiiiiiiiiiiieee e 153

Conditional Notifications Ball............cccuiiiiiiiiiie e e e e ee e e e e ae e e e e ennees 153
Defining Conditional NotifiCationS ...........cueiiiiiiiii e 153
Conditional Notification Dialog BOX..........cccccuuiiiiiiiieie e e e e e e e e eenenes 154

Default Search Variable in Search Cards..........c..oviiiiiiiiiiiiiiie e 156

Default Values Generation for New Sheets in Drawings Ball.............ccccoviviiiiiiiiiiiiiiieeeee e 157

Displaying History in SOLIDWORKS PDM Task Pane..........cccoccveeieiiiiiiie e 157

Editing History Comments Ball... ... e 157

File SOMCUL MENU B ..o eesee e 158

Getting Automatic Updates with Data Card EditS............ccccviiiiiiiiii e 159

Graphics Device Interface ENhancements............cooiiiiiiiiiiiiiiiiiceieeee e 159

Integrated Installation of Web APl SEIVer..... ..o 159

Mixed Authentication SUPPOIT..........eeiiiii e e 159
Authenticating Users with MiXed LOGQINS ......ccccoiiiiiiiiiie e a e 160

Naming Files with Serial NUMDbDErS ... 160

Opening a Parent File Without Referenced Files ... 160

Opening Multiple SOLIDWORKS FilES.........cccciiiiiiiiiei et a e 160

Performance Improvements - SOLIDWORKS PDM........cooommiiiiiiiiiiiiieie e, 161

Responsive Redesign in WED2...... ... 161

Selection of Referenced Drawing Nodes During Change State.............cccccvviieeeiee e, 162

SOLIDWORKS Inspection Integration ... 162

SOLIDWORKS PDM Support for Design Library ... 163

Support for Configurations of Weldment Cut LiStS..........cccooviiiiiiiiiiiiiiic e 163

Support for DXF/DWG File Format in Convert Task Bafl...........ccoooiiiiiiiiiie e 164

Support for eDrawings FUNCHONAIITY ........cooiviiiiiiii e 165

Upload and Check in File Structure and Download with References..........ccccccovvciiveiiiiiiennens 165

User COmMMENTS Bl ... ettt e e e e e e e e e s e e e e e e eaaeeesessassntesaneeeaaaeeesansnnnnsnes 166

23 SOLIDWORKS PIASHICS ... .ccceeiiiiieeeeeeee e 167

(O[T | 1F o PSRRI 167

Enhanced Cooling Channel DESIGN ...........uiiiiiiiiiiiiaiiieee e 167

Geometry-based Boundary Conditions Ball .............coooiiiiiiiiiiiiiie e 168

MeSh ENNANCEMENTS ...ttt e e e e e e e e e e e e e e e e e aaeeeeaaaannnnnes 170
Create Mesh Before Saving @ Part ... 170



Contents

Geometry-based MesSh CONMrOl...........eiiiiiiiiii e 170
MESH DBLAIIS ... ettt e e e e e e e e et e e e e e e e e e et arar e e e e aaaeeaeeannnne 171
Simplified Mesh HierarChy .............ooooiiiiii e 171
Switching Between MeESh TYPES .......uiiiiiiiiiiieie i 171

24 ROULING ..ttt e ettt bbbttt et e e e e e e e e e e e e e e e e e e 172
Configuring Routing COMPONENTS .......cooiiiiiiiieiiiee e e 172
Creating Fixed Length Coverings Ball..............cooiiiiiiiiiiiii e 173
Fixed Length Covering PropertyManager............ooii it 173
Improved Performance with Routing Library Manager............ccoooviiiiiiiiiiieee e 174
ININE COMPONENES ....coiiiiiiiiiie ettt e e e e e e et e e e e e e e e e e e e e aatbsaeeeeaaaaeeeaeaannnees 176
Adding Inline Components t0 ROULES .........ooouuiiiiiiiiii e 177

Align Components PropertyManager...........iiieeei oot e e e e e e e e e e e eas 180

25 Sheet Metal........ o 182
Linking Materials and Sheet Metal Parameters Ball ... 182
Tab @NA SIOL ..o 183
26 SOLIDWORKS Simulation...........cooiiiiiiiiiieeeeeeee e 186
Customized Numerical Format Ball ... . ... e e e 186
Enhanced Remote Load/Mass PropertyManager Ball ...............oooiiiiiiiiiiiiiiiieiee e 187
Distributed Coupling for Remote Load and Mass Ball...............ooociiiiiiiiiiii e 188
T 0o o o= o1 (o 7 R PRR 191
Simulation Performance IMprovements ..o 193
Stress Averaging at Mid-side NOGES ..........cuuiiiiiiiiiiii e 193

QI e] oo (oo 1Y 18 o |V SRR 194
Topology Constraints Ball ...........ueiiiiiiiii e e 194
Export to Mesh Body Ball ... e a e 195

Save Intermediate Topology RESUIS .........eeiiiiiiiiiiiiii e 196

27 SKEICNING .. e e e e e e e e e 197
Editing GENETIC SPIINES ...ttt e e e e e e e e e e st eeeeeaaeeesssesnnrenes 197
Generic Spline PropertyManager..... ..o i e e e e e e e e e e e e e e e 198
GeodesiC ENities Ball...... ..o 200
Pen Tool Sketching ENhanCemMENtS...........uiiiiiiiiiiie et 201
Projected Curve ENhanCements..........ooo i 202

£ 17 1T TN o o SRR 203
Slicing Mesh BREP Bodies Using Planar Entities............coociiieiiiiiiiie e 203
SIICiNG PropertyManager...........ueiii ottt 204
Slicing Standard SOLIDWORKS BREP Bodies Using Linear and Point Entities................... 206

Trim Entities Enhancements Ball ... e 208



28 SOLIDWORKS ViSUAIIZE ......oeeieiiiiieieeee e 211

Automatic Data ReCOVEry Ball............ooo i 211
Customizing Keyboard SHOMCULS ...........cciiiiiiiiiiieeece e e e e e 212
=Y T LT o K PR 212
g oo )il e T 11 PSR 216
IMPOIting MDL Materials Ball....ooooooooooeoeoeoeeeee e 216
MOAEI Tre€ BENAVION.......cci ittt e e e e et e e e e e e e s s e senenraeaeeenaaaeeesanannnnnnes 217
Modifying Decal MapPing ..........uueeeiiiiiieeiie it e e e e e e e e e e e e e e e e e e e e anaanraees 217
o T V= (T4 = SR 217
PRhYSICS SIMUIALIONS ... et e e e e e e e nneeas 218
Simulating Driving @ VENICIE .........ueeiiiiiiiii e 218
Placing Objects in Natural Arrangements..........coooiiiiiiiiiiiii e 220
ET=TaTo [T G @ o) o3 - PSPPSR 223
Rendering Solid-Transparent APPEAraNCES............cccccuirriiieieieeeeeeeeecireeee e e e e e e e e e ee s e eeaeaaeas 223
VIAEO TEXIUIES ...ttt e et e oo oottt e et e e e e e e e e e et eeeeeeeaaaeeeeaaannnneeneeeas 226
PZAe TAV =1 (o [ 1= o P PPURPPUPUPPRR 227
ConfiGUIING CUL LISES ..ottt et e e e st e e e s sbeeeeeeanes 227
SHIUCIUIE SYSIEIM ..ot e e e e e e e e s e st r e e eaaaae e s 227
Entering Structure System MOde .........oouiiiiiii e 228
Tt E= T VAV =T 0] o= ST 229
SECONAAry MEMDEIS .......ooi it e e e e e e e e e e e e e e e e e 234

Corner ManagEMENT.........uiiiiiiiiii ettt e e e e 237



Legal Notices

© 1995-2018, Dassault Systemes SolidWorks Corporation, a Dassault Systemes SE company,
175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without
notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or
manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or
copied only in accordance with the terms of the license. All warranties given by DS SolidWorks
as to the software and documentation are set forth in the license agreement, and nothing
stated in, or implied by, this document or its contents shall be considered or deemed a
modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents
6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079;
7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902;
8,817,028; 8,910,078; 9,129,083; 9,153,072; 9,262,863; 9,465,894; 9,646,412; 9,870,436;
10,055,083; 10,073,600 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and
Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo
are registered trademarks and FeatureManager is a jointly owned registered trademark of DS
SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.
FeatureWorks is a registered trademark of HCL Technologies Ltd.

SOLIDWORKS 2019, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS
Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS
Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium,
SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage, eDrawings Viewer,
eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS
Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS
Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer,
SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium,
SOLIDWORKS PCB Connector powered by Altium, and SOLIDWORKS Visualize are product
names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective
holders.
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COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995),
consisting of “commercial computer software” and “commercial software documentation” as
such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government
(a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense,
consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN
1995)

In the event that you receive a request from any agency of the U.S. Government to provide
Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope
of the request and DS SolidWorks will have five (5) business days to, in its sole discretion,
accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks
Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and
Education Products

Portions of this software © 1986-2018 Siemens Product Lifecycle Management Software Inc.
All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:
D-Cubed® 2D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® 3D DCM © 2018. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® PGM © 2018. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® CDM © 2018. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® AEM © 2018. Siemens Industry Software Limited. All Rights Reserved.
Portions of this software © 1998-2018 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2018 Luxology, LLC. All rights reserved, patents pending.
Portions of this software © 2007-2018 DriveWorks Ltd.

© 2011, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology.

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by
U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents
Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered
trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights
reserved.
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Copyright Notices for SOLIDWORKS PDM Professional Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2017 Open Design Alliance. All rights reserved.

The eDrawings® for Windows® software is based in part on the work of the Independent JPEG
Group.

Portions of eDrawings® for iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.
Portions of eDrawings® for iPad® copyright © 2003 - 2005 Apple Computer Inc.

Copyright Notices for SOLIDWORKS PCB Products

Portions of this software © 2017-2018 Altium Limited.

Copyright Notices for SOLIDWORKS Visualize Products

NVIDIA GameWorks™ Technology provided under license from NVIDIA Corporation. Copyright
© 2002-2015 NVIDIA Corporation. All rights reserved.
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Welcome to SOLIDWORKS 2019

This chapter includes the following topics:

e Top Enhancements
e Performance Improvements
e For More Information

Model courtesy of Aerovelo.

SOLIDWORKS® 2019 delivers many enhancements and improvements, most created in direct
response to customer requests.

You can tackle the most complex challenges with SOLIDWORKS 2019 end-to-end process
solutions:

e Design to manufacture. Go from concept to manufactured parts even faster.

e Modeling and drawings. Powerful enhancements to improve your design and detailing
experience.

e Performance. Faster large assembly design, rendering, and collaboration.
e New technology. Increased productivity when using the latest touch-enabled devices.
e Collaboration. Smart tools for collaborating with partners and suppliers.
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Top Enhancements

The top enhancements for SOLIDWORKS® 2019 provide improvements to existing products
and innovative new functionality.

Throughout this guide, look for the symbol in these areas:

Assemblies e Bounding Box in Assemblies on page 37

e Create Custom and Configuration-specific Properties in
Treehouse on page 61

o Defeature PropertyManager - Silhouette on page 40

e Exploded Views on page 43

¢ External References on page 43

e Use Custom Property for Document Name in Treehouse
on page 64

e Saving an Assembly as a Part on page 57

Detailing and e Changing Cell Border Thickness on page 86
Drawings e Drawing Open Progress Indicator on page 80
eDrawings ¢ Configurations in SOLIDWORKS Parts on page 91

¢ eDrawings Professional Features on page 92
e Configurations in SOLIDWORKS Assemblies on page 91

Model Display e Creating 3D Textures on page 131

Parts and Features ¢ Creating Partial Chamfers and Fillets on page 136
e Inserting a Part with a Specific Configuration on page 139
¢ Specifying Tolerances for Hole Wizard Holes on page 143
¢ Using Interference Detection for Multibody Parts

Routing e Creating Fixed Length Coverings on page 173
Sheet Metal ¢ Linking Materials and Sheet Metal Parameters on page 182
Sketching e Geodesic Entities on page 200

e Trim Entities Enhancements on page 208

SOLIDWORKS 3D Reading Tessellation Data from Foreign CAD Files on page
Interconnect 103

SOLIDWORKS MBD

Support for Sheet Metal in MBD on page 126

SOLIDWORKS PDM Conditional Notifications on page 153
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e Default Values Generation for New Sheets in Drawings
on page 157

e Editing History Comments on page 157

¢ File Shortcut Menu on page 158

e Support for DXF/DWG File Format in Convert Task on page
164

e User Comments on page 166

SOLIDWORKS e Geometry-based Boundary Conditions on page 168
Plastics
SOLIDWORKS e Customized Numerical Format on page 186
Simulation e Distributed Coupling for Remote Load and Mass on page
188
e Enhanced Remote Load/Mass PropertyManager on page
187

e Export to Mesh Body on page 195
e Pin Connector on page 191
e Topology Constraints on page 194

SOLIDWORKS e Automatic Data Recovery on page 211
Visualize e Denoiser on page 212
e Importing MDL Materials on page 216

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and
SOLIDWORKS Premium unless otherwise noted.

Performance Improvements

SOLIDWORKS 2019 includes performance and workflow changes across many areas for
increased workflow complexity and larger models.

Installation Manager

The SOLIDWORKS® 2019 Installation Manager uses new download methods that can
deliver up to twice the download speed compared to SOLIDWORKS 2018 and earlier.

The new download methods also provide a solution in cases where the Installation Manager
failed to download installation files.

Detailing and Drawings

Performance when creating, opening, and editing hole tables has improved for large
numbers of holes and for the combination of circular and noncircular holes.

The time it takes to switch from a model to its drawing under the following conditions is
improved:
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e Both the model and its drawing are open.

e You make changes in the model that do not change geometry.
e The drawing has multiple sheets.

e Automatic view update is on.

Model Display

SOLIDWORKS 2019 uses a new graphics architecture for parts and assemblies. This
architecture provides a more responsive, real-time display especially for large models. It
takes advantage of modern OpenGL (4.5) and hardware-accelerated rendering to maintain
a high level of detail and frame rate when you pan, zoom, or rotate large models. These
performance improvements scale up with the higher-end graphics cards not fully supported
in previous versions of SOLIDWORKS. These changes do not apply to drawings.

To turn on the new architecture in SOLIDWORKS 2019, select Tools > Options > System
Options > Performance and select Enable graphics performance (Beta feature,
requires SOLIDWORKS restart).

Pack and Go

When you select Include drawings, an option in System Options improves performance
by limiting the search for drawings to specific folders. In Tools > System Options >
External References, Include subfolders for drawings search in Pack and Go
searches all subfolders for drawings. If you clear this option, SOLIDWORKS limits its
search for drawings to the folders of the packaged models and folders specified in Tools
> Options > File Locations > Referenced Documents.

Routing
Improved Feature Description
Routing Component Wizard When you use the Routing Component Wizard of the

Routing Library Manager, the creation of routing library
components is more efficient. The wizard displays only
the essential tabs that you use to create routing
components for different types of routes. The wizard
responds faster when you switch tabs.

In the Routing Library Manager > Routing
Component Wizard > Design Table Check tab, all
component-specific column headers are displayed. The
design table information is locked. You can edit column
headers in the wizard and click Next to apply the
changes to the design table.

In the Routing Library Manager > Routing
Component Wizard > Component Attributes tab,
components with multiple configurations load only the
active configuration parameters. Other configuration
data is loaded only when you select the configuration
in the tab, which accelerates the tab's performance.
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Improved Feature Description

Piping and Tubing Database Removing To remove components from the
Components database, in Select Components,
select Remove Components and click
Save.

Scanning To list components not present in the

Components database, in Scan for library
components which are not in the
database, click Scan. To include
scanned components in the database,
select Add Components and click
Save.

The saving and scanning operations are faster. In
Routing Library Manager > Piping and Tubing
Database > Select Components > Scan for library
components which are not in the database, select
Scan excluded folders, and click Scan to scan
components in the excluded folders. After the scanning
process completes, the table displays components that
are not in the database. In the table, you can edit and
save Type and Sub Type for components.

When you click Save, the SOLIDWORKS software opens
and saves only selected components with modified
Type or Sub Type, and adds them to the database.

Import Data Dialog Box In Routing Library Manager > Piping and Tubing
Database > Import Data, Start and Synchronize
are not available simultaneously, to improve workflow.

Select Route and Component In the Route Component Wizard, the Select Route Type
Type and Select Component Type tabs are combined to
improve access.

Design Table Check In the Routing Component Wizard, when no Design
Library exists for a part, the Design Table Check node
is available. A message prompts you to create a new
design table.

Previously, if no design table existed for a part, the
Design Table Check node was unavailable and there
was no option to create a new design table.

Images for Connectors in the The Routing Library Manager includes images in Route

Routing Library Manager and Component Types, Routing Geometry, and Routing
Functionality Points nodes of the Routing Component
Wizard tab.

The images help you identify the components.
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Toolbox

You can temporarily disable the automatic update of mates between a Toolbox component
and a non-Toolbox component by clearing Automatic Update for Toolbox Mates. By
disabling the automatic update, you can improve performance by making it quicker to
edit mates, add mates, and manipulate components.

When you disable automatic mate updates:

e Toolbox fasteners do not move if you move the components to which they are mated.
Non-Toolbox components do move.

e Performance improves when working in assemblies with several Toolbox components
inserted and mated at the top level. For example, in assemblies with hundreds of
fastener stacks at the top level, updating these mates can impact assembly performance
when performing actions like solving mates, adding mates, and dragging components.

Performance improvements do not occur when Toolbox components are:

e In subassemblies because the option affects solving mates at the top level only.
e Patterned, because patterned instances do not use mates.

You must disable Automatic Update for Toolbox Mates each time you open an
assembly. See Disabling Automatic Mate Updates in Toolbox on page 52.

SOLIDWORKS Electrical 3D

The performance is improved for Route Cables and Route Harness tools. The
performance is faster when you use the Route Wires tool for routing of a large number
of wires in an assembly.

When you click Tools > SOLIDWORKS Electrical > Electrical Component Wizard,
Route Library Manager starts quickly and you can define components faster for
SOLIDWORKS Electrical 3D.

SOLIDWORKS PDM

SOLIDWORKS PDM has improved performance of loads for large assemblies and complex
reference structures in the Contains and Where Used tabs.

You can more quickly complete operations such as moving, dragging, browsing, renaming
files, and adding a large number of files to a folder that has many files. You can also
check in assemblies with virtual components much faster.

Browsing speed has improved while working on integrated search results.

The elimination of unnecessary interface refreshes speeds up your browsing experience,
including folders with many locally cached files.

SOLIDWORKS Manage

Performance is improved when you synchronize SOLIDWORKS PDM objects with a large
number of files and folders. The Synchronization details dialog box displays the
synchronization steps.

To open the Synchronization details dialog box:
1. Edit a SOLIDWORKS PDM object.
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2. In the dialog box, navigate to the Connection page.
3. Select Show synchronization steps.

4. Click OK.

Simulation

There are improvements in overall stability and performance while solving a simulation,
especially for linear static studies with multiple load cases.

A major driver of the performance improvements is based on the fact that the solution
formulation is restructured for optimized performance. The optimized reconfiguration is
limited to the Intel Direct Sparse solver only. Noticeable improvements in solution time
are observed for linear static studies with up to 25 load cases. Note the following:

The optimized performance of the Intel Direct Sparse solver is realized for Pressure,
Force, and Torque load types. All other load types, connectors, and non-zero prescribed
displacements cannot vary from one load case to another, or else you will not observe
any performance benefit during the solution.

There are not any performance improvements for these cases: linear static studies
with load cases defined with no-penetration contacts, virtual wall contacts, distributed
beam loads which vary across load cases, loads on beam vertices, and extension only
or compression only springs.

For linear static studies with multiple load cases, the performance benefit comes from
the factorization of the global stiffness matrix. The global stiffness matrix factorization
(which consumes the majority of the total solution time) is done only once, as the
stiffness matrix is exactly the same for every load case.

eDrawings

View manipulations and assembly component selections are faster in eDrawings®.

To improve performance, click Tools > Options > General and select Graphics boost
and Fastest speed.

For More Information

Use the following resources to learn about SOLIDWORKS:
What's New in PDF This guide is available in PDF and HTML formats. Click:

and HTML

e Help > What's New > PDF
e Help > What's New > HTML

Interactive What's In SOLIDWORKS, click the ) symbol to display the section of this

New

manual that describes an enhancement. The symbol appears next
to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New >
Interactive.

Sample files To open sample files for this book, go to

system dir:\Users\Public\Public
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Online Help

Release Notes

Documents\SOLIDWORKS\ SOLIDWORKS
2019\samples\whatsnew\chapter name\file name.

For example, C:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\sketching\Block.sldprt.

Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Provides information about late changes to our products, including
changes to the What's New book, online help, and other
documentation.
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User Interface

This chapter includes the following topics:

e Breadcrumbs Enhancements

e Customizing Task Pane Tabs

e Improved Preview for Minimized Documents
e Keyboard Accessibility

e Markups for Collaboration

e Measure Tool

e Microsoft Surface Dial in SOLIDWORKS

e Open Dialog Box

e Opening Part Configurations in Quick View Mode
e Recent Documents Improvements

e Rollback Bar Drag Interaction

e Status Feedback

e Touch Mode

Breadcrumbs Enhancements

You can select multiple mates in the selection breadcrumbs and display the breadcrumbs
in a semitransparent state at the pointer.

To access this option:

1. Click Tools > Options > System Options > Display and select Show breadcrumbs
at mouse pointer.

2. Click the part or assembly.

Customizing Task Pane Tabs

You can reorder, show, or hide tabs in the Task Pane. You can also specify the default
tab that opens when you open the Task Pane.

To customize the Task Pane:
1. Right-click any Task Pane tab or the header of the Task Pane and click Customize.

22



User Interface

2. In the Customize dialog box, do the following:

e To show or hide Task Pane tabs, select or clear check boxes.
e To reorder, drag the tab titles.
e To specify a tab as default, under Default, click the corresponding button.

3. Click anywhere in the graphics area to close the Customize dialog box.

The SOLIDWORKS software saves the new settings. When you relaunch the software,
the Task Pane tabs use the customized settings.

Improved Preview for Minimized Documents

You can hover over the title bar of a minimized document to see its name, thumbnail,
and path.

Keyboard Accessibility

You can use the keyboard to access tools in shortcut bars, shortcut menus, and context
toolbars in the graphics area.

Shortcut Bars

Arrow keys Navigates through the tools on the shortcut bar.
Alt + Down Opens the menu, if available, of the selected tool.
arrow

Enter Executes the selected tool.

Esc Dismisses the shortcut bar or the tool's menu.

Shortcut Menus and Context Toolbars

Shift +F10 or Opens the shortcut menu.

menu key

Arrow keys Navigates through the menu and toolbar items.
When a context toolbar appears on its own in the graphics area
(without a shortcut menu), the context toolbar does not support
keyboard navigation.

Enter Executes the selected menu item or tool.
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Esc Dismisses the shortcut menu, context toolbar, or a tool's menu.

Markups for Collaboration

You can use sketch tools to create, view, edit, and delete markups for parts and
assemblies. You can export markups as .pdf, .bmp, .Jjpg, .png, and .tif files for
collaboration purposes.

To access the markup tools:

1. Click Tools > Options > System Options > FeatureManager > Markups > Show
and click OK.

2. In the FeatureManager® design tree, right-click the Markups folder and click
Insert Markup View.

The Ink Markup toolbar appears.

2] ks & &

Start the Markup View @ tool from Evaluate > Markup View on the
CommandManager.

Sketch and Ink markups are limited to pen and touch-enabled devices that use
Windows 10, version 1703 or later. For all other devices, you can only add markup
notes using the keyboard.

Measure Tool

The Measure tool is available for all SOLIDWORKS tools used for part, assembly, and
drawing files. You can use the tool even while other tools are running.

Microsoft Surface Dial in SOLIDWORKS

The SOLIDWORKS software supports the Microsoft® Surface Dial. Surface Dial lets you
view model attributes and zoom, pan, or rotate models.

With the SOLIDWORKS program active, press and hold the Surface Dial on-screen or
off-screen to show the radial menu. The menu includes the system options Volume,
Scroll, and Undo and the custom ring options Pan, Zoom, and Rotate. Click a custom
option to show the custom ring.

On the custom ring, tap Pan, Zoom, or Rotate with your finger to select the tool. When
you select Pan, press the dial to activate the X or Y axis or rotate the dial to pan along
the active axis. When you select Rotate, press the dial to activate the X, Y, or Z axis.
Rotate the dial to rotate the current view along the active axis.
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When you use the off-screen dial, the custom ring appears on the lower-right corner of
the graphics area for right-hand dominance and the lower-left corner for left-hand
dominance. You can drag the custom ring anywhere on the screen.

Open Dialog Box

In the Open dialog box, if you select one or multiple files of the same type and click
Options, the System Options dialog box displays the options for the selected file type.

Opening Part Configurations in Quick View Mode

When you open a part in Quick view mode, you can specify the configuration to open.
You can also do this in eDrawings®.

Before you open a specified configuration in Quick view mode, you need to specify which
configurations are available in Quick view mode. Open the part in Resolved mode first to
determine which configurations are visible to other users.

To open part configurations in Quick view mode:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\user interface\jack parts.sldprt.

2. In the ConfigurationManager, right-click the following configurations and click Add
Display Data Mark:

e Base
e Outer

Base and Outer are marked with ® icons. The other configuration remains the same.
3. Save and close the part.

4. Click Open a7 or File > Open.
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5.

In the dialog box:
a) Select jack parts.sldprt.
b) In Mode, select Quick view.
¢) In Configurations, select Outer.
Only the Base and Outer configurations are available to select.
d) Click Open.

The part opens in the Outer configuration in Quick view mode. The Base and Outer
configurations are available in the ConfigurationManager.

Recent Documents Improvements

The SOLIDWORKS software can save more recent documents and they are easier to
manage.

The SOLIDWORKS software can store up to 100 recent documents.

You can specify the maximum number of recent documents from 1 to 100 in System
Options. The default number is 50.

You can include documents opened from other documents by selecting Include
documents opened from other documents in System Options.

You can filter recent documents by type and by name on the Recent > Documents
tab in the Welcome dialog box.

You can remove some or all recent items by clicking Remove in the Recent >
Documents or Recent > Folders tabs in the Welcome dialog box.
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Rollback Bar Drag Interaction

Handles in touch mode make it easier to interact with the freeze bar and the rollback bar.

Status Feedback

A SOLIDWORKS dialog box may appear during lengthy processes when Microsoft®
Windows® detects that the SOLIDWORKS software has stopped responding. You can wait
for the command to finish (recommended) or close the SOLIDWORKS software.

If you choose to close the SOLIDWORKS software when the dialog box appears, you can
send your comments and performance log data to DS SolidWorks Corp (also
recommended). This benefits all users and helps improve the software's performance and
stability.

Previously, a Windows Not Responding dialog box appeared when Microsoft Windows
detected that the SOLIDWORKS software was no longer responding, even when
SOLIDWORKS was working normally.

Touch Mode

When you use touch gestures, you can work in a more direct way with your content.

e When you select an entity in the graphics area, the Copy tool appears in the touch
toolbar. Turn on the Copy tool and drag the selected entity to copy and move it.

e Select + drag to move entities. You can touch the entities to select them and then
drag your finger to move them.

e While sketching an entity, if you hold your finger on the screen around an area for
some time, the Selection tool appears around your finger. To turn it off, click Tools
> Options > System Options > Touch and clear Automatically pop up Selection
tool while hunting for precise location. The Selection tool helps in precise selection
of vertices, edges, and small faces.

¢ Rotate lock turns on when you enter sketch mode and turns off when you exit sketch
mode. The Rotate lock tool locks 3D rotate and 2D roll.

e Icons around the pointer and tooltips are moved to the upper-left side of the pen for
right-handed users and upper-right side for left-handed users to solve occlusion
problems. The same applies to stylus and touch input methods.

e When you unpin the Task Pane, tap anywhere in the graphics area to collapse the Task
Pane.
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This chapter includes the following topics:

e Application Programming Interface
e Changes to System Options and Document Properties
e Specifying a Default Save Folder

Application Programming Interface

See SOLIDWORKS API Help: Release Notes for late-breaking updates.
SOLIDWORKS® 2019 API includes the ability to:

e Access Bounding Box feature data.

e Access Ground Plane feature data.

e Access Tab and Slot feature data.

e Convert an existing balloon to a stacked balloon.

o Create a geodesic sketch offset along the curvature of a surface.

¢ Create a pattern feature with a smaller subset of parameters and then extend or modify
it using a pattern-specific feature data object.

e Create an assembly mate with a smaller subset of parameters and then extend or
modify it using a mate-specific feature data object.

e Get a component's suppression state or, if an internal ID mismatch exists, an error
code.

e Get an annotation's text scale in the 3D View.
e Get data from the Hole Wizard database.

e Get or set more properties on linear, linear component, and circular component pattern
features.

e Get or set more table column types, including the equation-driven type.
e Get or set the orientation of text in table cells.

e Get or set whether an angle or distance mate is a limit mate.

e Get or set whether to bidirectionally project a curve.

e Get or set whether to enable the pushpin of an add-in's callout.

o Get or set whether to enable the Select Identical Components menu item in the
context menu of a PropertyManager page selection box.

e Get or set whether to exclude a component from the bills of materials in specified
configurations.

e Get or set whether to generate a display list for a part's configuration.
e Get or set whether to load external references in memory when opening a document.
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o Get or set whether to reverse the direction of a specified reference of a reference plane
feature.

e Get the error status of an assembly mate.
e Insert a Delete Hole feature for selected hole edges on a surface.
e Insert, open, and update models developed in other CAD packages.

e Repeatedly detect collisions among groups of components in a variety of
transformations.

e Specify whether to include a specified component when saving an assembly as a part.

Changes to System Options and Document
Properties

The following options have been added, changed, or removed in the software.

System Options

These system options are accessible at Tools > Options > System Options. The Access
column lists which subarea of System Options that the option is located.

Option Description Access
Maximum recent Specifies the maximum number of recent General
documents displayed documents displayed ranging from 1 to

100.
Include documents Includes documents opened from other General
opened from other documents in the list of recent
documents documents.

Allow cosmetic threads Specifies that all parts, assemblies, and General
for upgrade drawings that use legacy cosmetic

threads are marked for using improved

cosmetic threads.

The upgrade requires you to set this

system option first, and then you can

enable the upgrade for each model.

Allow editing of Lets you edit the templates that you use MBD
templates for 3D PDF when you create 3D PDF files for MBD.

files

Display scrollbars in (Not available if any documents are open Display
graphics view for parts in SOLIDWORKS.) Displays scrollbars in

and assemblies part and assembly document windows.

Display scrollbars in (Not available if any documents are open Display
graphics view for in SOLIDWORKS.) Displays scrollbars in
drawings drawing document windows.
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Option Description Access
Show breadcrumbs at Lets you select multiple mates in the Display
mouse pointer selection breadcrumbs and display the

breadcrumbs in a semitransparent state

at the pointer.
No preview during open Removed from the software. Performance
Include subfolders for Limits the search for drawings to specific External
drawings search in Pack subfolders. If you clear this option, the References

and Go

software limits its search to the folders
of the packaged models and folders
specified in Tools > Options > File
Locations > Referenced Documents.

Default Save Folder

Specifies the default folder where new
documents are saved. If you do not
specify this path, the default save folder
varies based on the last used folder.

File Locations

Edit name with slow Lets you click-pause-click items in the FeatureManager
double click FeatureManager® design tree to rename
them. When cleared, you can still
rename items by selecting them and
pressing F2.
Markups Creates markups for parts and FeatureManager
assemblies using sketching tools.
Automatically pop up While sketching an entity, if you hold  Touch
Selection tool while your finger on the screen around an area
hunting for precise for some time, the Selection tool
location appears around your finger.
Lock rotation of new Automatically locks rotation for new Hole

concentric mates to
Toolbox components

concentric mates to Toolbox
components.

Wizard/Toolbox

PLY

Exports SOLIDWORKS parts and
assemblies to the .ply file format.

Export > PLY

SLDPRT from assembly Specifies export options when you save

an assembly as a part.

Export >
SLDPRT from
assembly

Export SOLIDWORKS
assembly envelope

Lets you import envelopes when you
open SOLIDWORKS assemblies that
contain envelopes.

Export > SMG
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Option Description Access

Export SOLIDWORKS PMI Specifies that SOLIDWORKS Composer Export > SMG
imports Product Manufacturing
Information (PMI) data from
SOLIDWORKS models.

Document Properties

These document properties are accessible at Tools > Options > Document Properties.
The Access column lists which subarea of Document Properties that the option is located.

Option Description Access

Do not add "QTY" next to Removed from software. Replaced by = Tables > Bill of
configuration name options in the Top level Only BOM, Materials
Parts Only BOM, and Indented BOM
group boxes.

Do not copy QTY column Removed from software. Replaced by = Tables > Bill of
name from template options in the Top level Only BOM, Materials
Parts Only BOM, and Indented BOM
group boxes.

Combine cutlist items in Controls how cut list items are grouped Tables > Bill of

BOM regardless to profile in the BOM when you change their Materials
when lengths are lengths to be the same.

changed to be same e Selected: Combines those

(legacy behavior) same-length cut list items even if

they have different profiles. This is
the behavior used in SOLIDWORKS
2018 and earlier.

e Cleared: Combines only those
same-length cut list items with
identical profiles. Cut list items with
different profiles remain separate,
even if their lengths are changed to
be the same.

Turning this option on or off might
affect the behavior of existing BOMs
in the active document if you then edit
the lengths of cut list items.
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Option Description Access

Top level Only BOM, Parts For each type of bill of materials, uses Tables > Bill of
Only BOM, and Indented the following options to show or hide Materials
BOM custom text and the configuration name
independently.
¢ Show custom text in BOM header.
In the header of the Quantity
column, replaces the
template-specified text with text that
you type in Custom text. For a blank
header, select this option and leave
Custom text empty.
e Show configuration in BOM
header. Adds the configuration name
to the header of the Quantity
column.

Sheet Metal MBD New section of the Document Properties Sheet Metal
dialog box where you can specify color, MBD
line type, and other options for various
sheet metal items.

Use sheet metal Specifies whether new sheet metal Sheet Metal
parameters from material bodies inherit sheet metal parameters

defined in the material applied to the

existing sheet metal bodies.

Specifying a Default Save Folder

You can specify the default folder where new documents are saved. If you do not specify
this path, the default save folder varies based on the last used folder.

When you save a document with Save As, the file uses the path of the active document,
even if you have specified a default save folder.

To specify the default save folder:

Click Options & or Tools > Options and select File Locations.
Under Show folders for, select Default Save Folder from the list.
Click Add to select a folder location.

Click OK.

b
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This chapter includes the following topics:

e Faster Download

Faster Download

The Installation Manager uses new download methods that can deliver up to twice the
download speed compared to SOLIDWORKS 2018 and earlier.

The new download methods also provide a solution in cases where the Installation Manager
failed to download installation files.
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This chapter includes the following topics:

e Admin Portal

e Comparing Geometry in the Upgrade Assistant

e Improved Performance with Pack and Go

e Improved Problem Capture in SOLIDWORKS Rx

e Language Translation for Settings Administrator Tool

Admin Portal

Assign Members to a Product

The Product Details page includes an Available Members section that you can use to
assign new members to a product.

To find a member, you can filter the Available Members section based on:

First name
Last name
Email
Product type

Filter Products and Services

On the Products and Services tabs of the Members Detail page, you can filter the available
products and services. This reduces the time required to find the product or service you
want to assign to a member. You can filter by criteria such as:

Product or Service name
Serial nhumber
Subscription status
Assignment status
Activation type

Product or Service type
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Comparing Geometry in the Upgrade Assistant

The Upgrade Assistant reports if the center of mass or volume of the model has changed.

This data is useful when detecting if a model is rebuilding differently in a new version,
but not necessarily failing. If there are significant differences between the current version
of the software and the baseline, the center of mass and volume are highlighted in blue
in the report.

Previously, the Upgrade Assistant only identified performance changes, rebuild errors,
drawing pixel changes (color and position), and stability problems.

Improved Performance with Pack and Go

When you select Include drawings, an option in System Options improves performance
by limiting the search for drawings to specific folders. The option Include subfolders
for drawings search in Pack and Go in Tools > System Options > External
References searches all subfolders for drawings. If you clear this option, the software
limits its search for drawings to the folders of the packaged models and folders specified
in Tools > Options > File Locations > Referenced Documents.

Improved Problem Capture in SOLIDWORKS Rx

Enhancements in problem capturing with SOLIDWORKS Rx include:

e You can restart the video recording without shutting down the SOLIDWORKS software
when you cannot capture an event on the first attempt.

To restart the recording, click Restart to delete the current video and then Record
to record a new video.

e SOLIDWORKS no longer shuts down when you Finish a video capture.
e You can pause a recording.

To pause the recording, click Pause and Resume to record.
e You can record the entire screen instead of just the SOLIDWORKS window.

Previously, you could start capturing, run the SOLIDWORKS software, and place another
application window in front of the SOLIDWORKS window.

e Maximum video length has increased from 5 to 10 minutes.
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Language Translation for Settings Administrator
Tool

The Settings Administrator is translated in all languages supported by the SOLIDWORKS
software.

The Settings Administrator tool runs using the language setting of your Microsoft®
Windows® operating system or English if your language is not supported.
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This chapter includes the following topics:

e Bounding Box in Assemblies

e Bounding Box PropertyManager

e Component Preview Window

e Cosmetic Threads

e Defeature PropertyManager - Silhouette
e Defeature - Define Groups

e Exploded Views

e External References

e Large Design Review

e Lightweight Mode

e Mates

e Patterns

e Performance Evaluation

e Saving an Assembly as a Part

e Select Identical Components

e Treehouse

e Warning When Inserting Complex Components

Bounding Box in Assemblies

You can create a bounding box feature in an assembly that contains geometry. The
bounding box is calculated by using the same methods as the part-level bounding box.

An assembly can contain only one Bounding Box £ feature. In the FeatureManager®
design tree, you can right-click the bounding box, and click Hide, Show, Suppress, or
Unsuppress.

Different colors indicate the component-level bounding box sketches in the graphics area:

Top-level assembly bounding box Gray
Subassembly bounding box Blue
Part bounding box Orange
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To view a bounding box, click View > Hide/Show > Bounding Box.

To view bounding box properties, hover over Bounding Box ¢ 3 in the FeatureManager
design tree, or click File > Properties > Configuration Specific. Values are listed for
the length, width, thickness, and volume of the bounding box.

Bounding Box Calculations

Bounding box calculations include SpeedPak faces and bodies but do not include SpeedPak
ghost graphics. After creating a bounding box feature, you can insert a SpeedPak
subassembly into the assembly or change an existing component to SpeedPak in the
assembly.

In an active assembly, bounding box calculations do not update dynamically when

components change in the assembly. A Rebuild 8 icon appears next to the bounding
box feature when you need to recalculate. Right-click Bounding Box and click Update
to rebuild.

The time required to calculate the bounding box feature appears in the Assembly Rebuild
Report. To access this report, click Tools > Evaluate > Performance Evaluation and
expand the Rebuild Performance section.

Bounding Box PropertyManager

To open the Bounding Box PropertyManager:
Click Insert > Reference Geometry > Bounding Box.

Specify these options to create a bounding box.

Reference Face/Plane

Best Fit Uses the X-Y plane for the orientation of the bounding box.
Custom Plane Specifies a reference plane to use for the bounding box.
Options

Include hidden Includes hidden components in the bounding box
components calculations.

Include envelope Includes envelope components in the bounding box
components calculations.

Include hidden bodies Includes bodies that are hidden at the part level in the
bounding box calculations.

Include surfaces Includes surface bodies in the bounding box calculations.
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Show Preview Displays a preview of the bounding box in the graphics
area.

Component Preview Window

You can view multiple components in the Component Preview window. You can use

Synchronize ] to synchronize the Component Preview window with the assembly
window. You can change the display style of the selected components for the assembly
window.

Most of the assembly window tools are available with the Component Preview window.
Some tools that are not available include Isolate, Viewport, New Window, and Close
All.

You cannot select hidden, suppressed, or graphics-only components to view in the
Component Preview window.

The Component Preview window is not available in the following situations:

e Isolate is active.
e More than one viewport is open.
e Editing a component in-context.

To open the Component Preview window, select a component and click Tools >
Component > Preview Window .

Component Preview window options:

@ Visible
Q Wireframe
Transparent
Hidden
= Synchronize Aligns the Component Preview window with the assembly
window when you change the orientation or use a zoom
tool like Zoom to Fit or Zoom to Area.
Exit Preview Closes the Component Preview window.
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Cosmetic Threads

Cosmetic threads quality is improved for assemblies and parts. To use the improvements
for legacy assemblies, upgrade the cosmetic threads features.

For information about the improvements and the upgrade process, see Cosmetic Threads
Improvements on page 135.

Defeature PropertyManager - Silhouette

You can simplify a complex assembly by using the Silhouette method in the Defeature
PropertyManager. You define groups of bodies or components and then define a
simplification method for these groups.

Simplification methods include:

e Bounding Box

e Cylinder

e Polygon Outline

¢ Tight Fit Outline

¢ None (Copy Geometry)

The simplified geometry is saved in a part in the same way as the existing Simplified
geometry method in the Defeature PropertyManager. If you retain a link to the parent
assembly, changes to the parent assembly change the simplified model when you update
the model.

When you create a part after defeature, a folder for each defeature group shows in
the FeatureManager design tree. If you select Merge groups after this step, the folder

name is named Merged. The folder contains a feature Y% for each body generated by
the simplification.

Defeature - Define Groups

You can use the Silhouette method to define groups of bodies or components and then
define a simplification method for these groups.

To use the Silhouette method in the Defeature PropertyManager:

1. Click Tools > Defeature %0.

2. In the PropertyManager, under Defeature Method, click Silhouette %
3. Click Next @

Specify options for the Silhouette method:
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Groups

Groups

Lists the defeature groups.

When you add or edit a group, an asterisk (*) appears next to
the group name until you click OK or Cancel in the
PropertyManager.

When you select a group, the bodies in that group are
highlighted in the Preview window.

Merge groups after
this step

Merges groups that touch or overlap.

Highlight processed
bodies

Highlights the bodies that are included in the defeature groups.
The bodies are highlighted using the Selected Item 4 color.

Add a Group / Edit a Group

b5 Name Lists the group name.
@ Components Lists the components in the group.
@: Bodies Lists the bodies in the group.
Add Group Adds the group.
Available in Add a Group mode.
Reset Resets the options.
Available in Add a Group mode.
OK Saves changes to the group. Switches to the Add a Group
mode.
Available in Edit a Group mode.
Cancel Resets the options.
Available in Edit a Group mode.
Apply Saves changes to the group. Remains in the Edit a Group

mode.
Available in Edit a Group mode.
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Simplification Method

Simplification Method Bounding Box Creates a cuboid bounding box.

Cylinder Creates a cylinder derived from the
dimensions of a cuboid bounding box.

Polygon Outline Creates an extruded polygon that fits
around the outline of the selected bodies
and components.

Tight Fit Outline Creates an extruded body by using the
outlines of the selected bodies and

components.
None (Copy Creates an exact copy of the selected
Geometry) bodies and components.

Enclose in one body Creates a single body that includes the selected entities.
Available when you select at least one body or component, and
one of the following methods:

e Bounding Box
¢ Polygon Outline
¢ Tight Fit Outline

For Polygon Outline, the selected entities must touch or
overlap.

Ignore small bodies Ignores bodies or components based on their size in relation
(% of assembly size) to the top-level assembly.

Keep internal loops Includes internal loops in the resulting body if the silhouette
of the selected entities contains these loops.
Available for Tight Fit Outline.

Orientation

Specifies the plane to use for the group. Select a plane or

P custom Plane
click Automatic ‘@, Front {&1‘, Top ﬁ‘, or Right i,

Use multiple directions Specifies a plane or face to use for a second direction.
Available for Polygon Outline and Tight Fit Outline.
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Exploded Views

You can go through an exploded view step-by-step. You can roll back an exploded view
to see the results of each step.

To open the Explode PropertyManager for an existing exploded view:

1. On the ConfigurationManager 2 tab, expand the configuration.
2. Right-click Exploded View & and click Edit Feature @2,
You can use the following functionality in the PropertyManager:

¢ Modify the name for a new or existing step.
e Insert a step above the rollback bar.

e Drag an active step to reorder the steps.

¢ Resize the height of the Explode Steps box.
e Click Add Step to add a step.

e Click Reset to reset options.

« Click Roll Back ® and Roll Forward & to roll back or roll forward steps.

e Suppress a step. Suppressed steps are not shown in the graphics area for Explode
Steps or Smart Explode Lines. Suppressed steps remain suppressed regardless of the
rollback bar position.

e Specifies the default name to Explode Step + number. When you select Auto-space
components on drag, the default explode step name is Chain + number.

In the Exploded Steps PropertyManager and ConfigurationManager, you can roll back or
roll forward steps by dragging the rollback bar.

Right-click a step located above the rollback bar to access the following tools:

e Roll Back
e Suppress

Right-click a step located below the rollback bar to access the following tools:

¢ Roll Forward
¢ Roll to Previous
e Roll to End

For the Animation Controller, the following controls changed:

e Fast forward '™ renamed to Next step.
e Rewind “ renamed to Previous step.
e Stop ® has been removed.

e Play ® and Pause !l are shared in one control.

External References

The External References dialog box for parts and features, and the External References
dialog box for assemblies are combined into one dialog box. You can break, unlock, or
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lock individual references for features and sketches, sort references by status, and isolate
selected components.

While the External References dialog box is open, you can interact with the FeatureManager
design tree and the model in the graphics area. You can enable Dynamic Reference
Visualization to view feature dependencies. You cannot drag files into the SOLIDWORKS
software.

To open the External References dialog box:

In the FeatureManager design tree, right-click the top-level assembly or a subassembly,
and click External References.

B ' External References: pillow_block Iiléj

-

Assembly: Chsmartcomponentsipillow_block.sldasm

Configuration:

@) Mested () Flat Filter by status:  Broken, Dangling, In context, Locked... *

Name Status Referenced Entity Type -
A % bearing_trainer sldprt In context =
In context Face of bearing=1= Offset Face
In context Edge of bearing=1= Offset Edge
In context Edge of bearing=1> Offset Edge
In context Edge of bearing=1> Offset Edge e
4 1] 3
Isolate
Lockall | |  Breakan
Unlock All TlrenE

|:|Ir1clude original features [derived parts only)
Replace broken sketch relations with fixed relations

OK ] [ Cancel

h

Functionality in the External References dialog box:

Nested Lists all components and features with external references
hierarchically based on the assembly structure. Components
and features are indented. You can expand and collapse
nodes.

Flat Lists all components with external references in a
nonhierarchical list.

Expand All Right-click in the table section of the dialog box to use
these tools.

Collapse All Expand All and Collapse All are available when you select

Clear Selections Nested.
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Filter by status Filters the components and features with the following
statuses:
e Broken

e Dangling

e In context

e Locked

¢ Out of context

Undo Reverses a change made in the dialog box.
When you select Include original features (derived
parts only), you cannot undo a break operation.

Redo ™ Reverses Undo ™ in the dialog box.

Isolate Isolates components from the selected external reference.
Available when the active document is an assembly and
you select one or more components.

Lock Selected Locks external references for selected features and
sketches.
If you lock external references for a feature or sketch, you
can create external references to the component. If you
lock external references for a component, all external
references in the component are locked and you cannot
create external references to that component.

Equations that have an external reference are not affected

by a lock.

Unlock Selected Unlocks external references for selected features and
sketches.

Break Selected Breaks external references for selected features and

sketches. If you break external references for a component,
all external references in the component are broken.
When you select Include original features (derived
parts only), you cannot undo a break operation.

Equations that have an external reference are not affected
by a break.

When you select a referenced entity, the entity along with the other entities that reference
it are highlighted in the FeatureManager design tree and in the graphics area. The selected
entity is highlighted using the Selected Item 1 color. The corresponding reference entities
are highlighted using the Selected Item 3 color.

Renamed tools and options:

¢ List External Refs is renamed to External References.

o Insert the feature(s) of original parts if references are broken is renamed to
Include original features (derived parts only).
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o List Broken References is replaced by Broken in Filter by Status.
¢ Components and Feature columns are renamed to Name.
e Data is renamed to Type.

External References is not available for lightweight components. The External References
dialog box for a top-level assembly does not list lightweight components.

FeatureManager Design Tree Conventions for External References

If a feature contains a sketch with external references, the feature displays {->} to the
right of the feature name in the FeatureManager design tree. A sketch with external
references displays -> to the right of the sketch name.

~ §]) Boss-Extrudel{ ->}

[ Sketchl ->

If a feature has an external reference and a sketch with an external reference, the feature
displays =>{->} to the right of the feature name.

+ ([ Cut-Bxtrudel ->{ ->}
[ Sketch3 ->

For features that contain sketches with external references in multiple states, all applicable
symbols display to the right of the feature name. For example, a feature with a locked
external reference and a broken external reference displays {-> *x3} to the right of the
name.

+ [ Cut-Loftl{-> =}
[ Sketch3-> x
[€] Sketch2-> *

Managing External References by using Dynamic Reference
Visualization

With Dynamic Reference Visualization enabled, you can use the following tools to
manage external references:

o %5 Break Reference
. [% Lock Reference

. E% Unlock Reference

When you break a reference, the break is permanent. You cannot activate an external
reference after it is broken.

When you break a parent reference of a sketch, you are prompted to replace the broken
relation with a fixed sketch relation or keep the broken relation.

To break a reference by using Dynamic Reference Visualization:

1. Open an assembly that has external references.
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2. In the FeatureManager design tree, right-click the top-level assembly, and click one
or both of the Dynamic Reference Visualization (Parent) 29 and Dynamic

Reference Visualization (Child) =2 options.
3. Select a component that has external references.

4. Click the circle and then click Break Reference ‘5

L4 {\L_ij (-] bearing<1=> (NPD-24<Display Stal'l— Base-Extrude ———.

v () flatwasher<1> (5 Flatwasher<Dis| ~ Bolt Slots

r |{\OE'J (f) bearing_trainer<1> -» [Default<[-----=--=--=-=---~ Q@

b f\% (-] flatwasher=2> (.5 Flatwasher<Dis .S:S' Break Reference
3 f\% (-] lockwasher<1l> (.5 Lock Washer= @ Lock Reference
4 E-\l%j (-1 lockwasher<2> (5 Lock Washer= Custormize Menu
» f-\l-:'fj (-) socket head cap screw<1> (5-16

5. In the dialog box, review the external reference to break and then click OK to break
the reference.

Large Design Review

Editing Assemblies in Large Design Review

You can use Edit Assembly to edit assemblies in Large Design Review mode. You can
add and edit mates, and insert components when you edit an assembly.

To use this functionality, open the assembly and component files individually and then
save in SOLIDWORKS 2019. Click File > Save All to save all the open files at the same
time.

In the FeatureManager design tree, the following features appear for top-level assemblies:

e Standard planes

¢ Origin

e Mates folder

o Reference geometry, read-only
e Sketches, read-only

e Component Patterns, read-only

On the Large Design Review tab of CommandManager, these tools are available:

e Insert Components
e Mate

You can use Move with Triad. To access this tool, right-click a movable component and
click Move with Triad J"

You cannot insert a component by dragging it from the Task Pane or File Explorer. You
cannot copy a component using CTRL + drag or CTRL + C. You cannot paste a component
into the assembly.
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You cannot edit an assembly in Large Design Review mode if the top-level assembly
contains at least one of these features:

Belt/Chain Chamfer Circular Pattern (feature)
Extruded Cut Fillet Hole Series
Hole Wizard Linear Pattern (feature) Mirror (feature)
Revolved Cut Simple Hole Sketch Driven Pattern
(feature)
Swept Cut Table Driven Pattern Weld Bead
(feature)

To edit assemblies in Large Design Review mode:

1. Click Open (a4} (Standard toolbar) or File > Open.

2. In the dialog box, select an assembly, and then in Mode, select Large Design
Review.

Select Edit Assembly.
4. Click Open.

w

An eye overlay b appears on the icons of all components indicating that the assembly
is in Large Design Review mode.

To edit an assembly that is open in Large Design Review mode, right-click the top-level
assembly, and click Edit Assembly.

Creating Mates in Large Design Review

When you edit assemblies in Large Design Review mode, you can create mates between
components and use geometry types as mate references. These mates and mate references
are available when you open the assembly in lightweight or resolved mode.

Supported mate types:

L5 Angle & Lock

A Coincident X Parallel

© Concentric 1 Perpendicular
I Distance O Tangent

You can use the following geometry types as mate references for any component in the
assembly:
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Arc edges Conical faces Cylindrical faces

Linear edges Planar faces Vertices

Temporarily Fixed Components

For existing mates or mate references that are not supported in Large Design Review
mode, the mates and mate references appear as temporarily fixed %.

Flexible subassemblies perform like rigid subassemblies in Large Design Review mode.

Large Design Review Mark

The name of the Large Designh Review Mark option is changed to Display Data Mark.

Limitations for Tools in Edit Assembly Mode

Some tools are limited when you edit an assembly that is in Large Design Review mode.

Insert Component

Insert Component adds components as graphics-only in the top-level assembly.
The Make virtual and Envelope options are not available.

For a top-level assembly that has multiple configurations, Suppress new components
in the Configuration Properties PropertyManager controls the suppression state of the
inserted component.

You cannot add Toolbox components to the assembly.
You cannot insert multiple components at the same time.

You cannot insert components by using copy and paste, drag, or CTRL + drag.

Configurations

You cannot change the configuration of the top-level assembly.

Component Patterns

You cannot create or edit component patterns.

Mates

You cannot create mates to reference geometry. Existing mates to reference geometry
are solved.
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Delete

You can delete only top-level components.

Suppress Components

Available for graphics-only components in the top-level assembly. Components are
suppressed only in the active configuration.

Save and Save As

Use Save to save an edited assembly in Large Design Review mode. You cannot use
Save As.

Move with Triad

Move with Triad is available when you right-click a component and click ¥ to expand the
shortcut menu.

Magnetic Mates in Large Design Review

You can assemble components by using magnetic mates while editing an assembly in
Large Design Review mode. Also, you can view the Ground Plane £l and the Published
Reference ﬁ’? folders.

You can create, edit, and delete Ground Plane g features.

You cannot edit published references in the Published Reference i folder and you
cannot define new connection points by using Asset Publisher.

Lightweight Mode

Rebuild Component Patterns

When you edit a feature, you can change the pattern parameters. For a component pattern
that is driven by an unavailable entity, **Lightweight** shows as a prefix to the entity
name. The SOLIDWORKS software rebuilds the pattern in lightweight mode by using the
last-used definition.

To use this functionality, save the assembly and the component that contains the driving
feature in resolved mode before you open the assembly in lightweight mode.

This rebuild works for the following assembly patterns:

Chain patterns Circular Curve Driven

Linear Pattern Driven Sketch Driven

50



Assemblies

This rebuild works for the following derived component patterns:

Advanced Hole Wizard Advanced Pattern Circular
Curve Hole Series Hole Wizard
Linear pattern Sketch Pattern Table Pattern

Unable to Move or Delete Files in Lightweight Mode

Files opened in lightweight mode are locked and you cannot move or delete them. In
Microsoft® File Explorer, you receive a warning message when you delete a file.

To move or delete files in lightweight mode:

A=

In the SOLIDWORKS software, click Open a7} (Standard toolbar) or File > Open.
In the dialog box, select the assembly, and then in Mode, select Lightweight.
Click Open.

Switch to Microsoft File Explorer and delete one of the components.

You receive a message that the action cannot be completed.

Mates

Automatically Lock Rotation for Concentric Mates to Toolbox
Components

You can use Lock rotation of new concentric mates to Toolbox components to
automatically lock rotation for new concentric mates to Toolbox components. You can
lock this option in the Settings Administrator Tool.

This option applies when you create concentric mates by:

Inserting a Toolbox component into another component.

Creating a SmartMate by using ALT + drag on a cylindrical face or a circular edge of
a Toolbox component that is in the assembly.

Using the Smart Fasteners tool.
Defining Smart Fasteners in a new Hole Series.
Manually creating a concentric mate to a Toolbox component.

When you clear this option, you can select Lock Concentric Rotation for the Mates 0y
folder or Lock Rotation for each unlocked concentric mate.

To enable automatic lock rotation for concentric mates:

1.
2.

Click Tools > Options > System Options > Hole Wizard/Toolbox.
Under Toolbox Mates, select Lock rotation of new concentric mates to Toolbox
components.
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The @' icon indicates locked concentric mates. The @ icon indicates unlocked concentric
mates.

Disabling Automatic Mate Updates in Toolbox

You can temporarily disable the automatic update of mates between a Toolbox component
and a non-Toolbox component by clearing Automatic Update for Toolbox Mates. By
disabling the automatic update, you can improve performance by making it quicker to
edit mates, add mates, and manipulate components.

When you disable automatic mate updates:

e Toolbox fasteners do not move if you move the components to which they are mated.
Non-Toolbox components do move.

e Performance improves when working in assemblies with several Toolbox components
inserted and mated at the top level. For example, in assemblies with hundreds of
fastener stacks at the top level, updating these mates can impact assembly performance
when performing actions like solving mates, adding mates, and dragging components.

Performance improvements do not occur when Toolbox components are:

e In subassemblies because the option affects solving mates at the top level only.
e Patterned, because patterned instances do not use mates.

You must disable Automatic Update for Toolbox Mates each time you open an
assembly.

To disable automatic mate updates:

In an assembly with Toolbox components, in the FeatureManager design tree, right-click
the Mates g folder and clear Automatic Update for Toolbox Mates.

The Mates folder and the mates inside it appear with this icon: Eﬁ.

To update the mates:

In the FeatureManager design tree, right-click one of the following and click Automatic
Update for Toolbox Mates:

e Mates @@ folder
¢ Fasteners subfolder in the Mates @@ folder

¢ Individual mates in the Mates @@ folder

All mates in the assembly are updated.

Grouping Mates and Separating Fasteners

You can group mates by status and separate fasteners into folders.

By Status groups mates by the following statuses:

Folder Name Description

Solved Mates that are solved without errors.
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Folder Name Description

Mates with mate errors.

O Errors
A over Defined Mates with over defined warnings.
Suppressed Mates that you suppressed.
Suppressed (Missing) Suppressed mates that reference missing components.
Inactive (Fixed) Inactive mates that reference fixed components.

The status folders appear in the Mates 0 folder.
Separate Fasteners separates mates that reference a Toolbox component into a

Fasteners folder. The Fasteners folder includes suppressed mates that reference a
Toolbox component. If you edit a mate to include a Toolbox component, the mate moves
to the Fasteners folder after you save the changes.

If you select By Status and Separate Fasteners, the Fasteners folders are nested
under the status folders.

The status and fastener folders automatically update when you change the assembly.
The number of mates contained in each folder displays to the right of the folder name.
If you select both grouping options, the number for the status folder includes the number
for the Fasteners subfolder.

Grouping mates does not modify the solve order for mates. You cannot move mates to
different status or fastener folders.

Add to New Folder is not available for mates in the status or fastener folders. To create
a folder, you must clear By Status and Separate Fasteners. For mates in user-created
mate folders, the mates move to the appropriate grouping folder when you group by
status or separate fasteners. When you clear these grouping options, the mates return
to their original mate folders. If you delete a user-created mate folder while a grouping
option is selected, the mates from the deleted mate folder move to a folder that is up
one level.

To group mates and separate fasteners:

1. In the FeatureManager design tree of an assembly, right-click Mates (] and click
Group Mates.

2. Click By Status to sort mates by status.
3. Click Separate Fasteners to show fasteners in separate folders.
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Negative Values for LimitAngle Mates in Mate Controller

You can use negative angle values in Mate Controller and Animation for LimitAngle Fa
mates.

Mate Controller

To use negative values for LimitAngle mates in Mate Controller:

Open an assembly that contains a LimitAngle Pa mate.

Click Insert > Mate Controller &*.

In the PropertyManager, click Collect All Supported Mates %
In Collect All Supported Mates, select a LimitAngle Pa mate.

oA W

For Position 1 iﬁ, enter a dimension for the LimitAngle Fa mate and click Update
Position )

For example, enter 100 for dimension.

6. Under Mates Positions, click Add Position %ﬂ

7. For Position 2 @*, enter 0 for the dimension and click Update Position Eg.

8. Under Mates Positions, click Add Position %ﬂ

9. For Position 3 ﬁﬁ, enter -100 for the dimension and click Update Position o,
10. Optional: Expand Animation and click Calculate 8 to view the animation.

11. Click ¥

Animation

To view the animation that you created in Mate Controller:
Click the Motion Study 1 tab.
For Type of Study, select Animation.

Click Animation Wizard 5t (MotionManager toolbar).
In the dialog box, select Mate Controller.
Specify options in the dialog box.

Click Calculate Eb.

o AW M=
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Patterns

Circular Patterns

You can include a second direction with the option to make the spacing and instance
count symmetric to the first pattern direction.

To specify a second direction for circular patterns:

1.

In an assembly, click Linear Component Pattern > Circular Component Pattern

o (Assembly toolbar) or Insert > Component Pattern > Circular Pattern.
In the PropertyManager, specify options for Direction 2:

Direction 2 Enables Direction 2 options.

Creates a symmetrical pattern from the seed

Symmetric feature.
Equal Spacing Sets Angle ¥ 0 360°.
e’y Angle Specifies the angle between each instance.
5 Number of Specifies the number of instances of the seed
instances feature.

Including Custom Properties in a Mirrored Assembly

You can include custom properties when you create an opposite-hand mirror assembly
or subassembly. Custom properties include global properties and configuration-specific
properties.

A link is established between the mirrored assembly and the original assembly. Changes
to the custom properties in the original assembly are included in the mirrored assembly.
You cannot edit custom properties in the mirrored assembly.

To include custom properties in a mirrored assembly:

1.

2.
3.

Open an assembly that has a custom property.

Click Mirror Components [ak] (Assembly toolbar) or Insert > Mirror Components.
In the PropertyManager, create a mirror pattern.

Click Create opposite hand version in Step 2: Set Orientation to continue
through the PropertyManager.

In Step 4: Import Features, under Transfer, select Custom Properties.

If you select Break link to original part under Link, changes made in the original

assembly are not included in the mirrored assembly.
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5. Click ¥ to create the mirrored component.

Linear Patterns

You can pattern components up to a selected reference. You can specify options for
spacing or the number of instances.

For Direction 1, clear Fixed axis of rotation to specify the rotation axis in any direction.
When you select this option, you can rotate patterned instances around a common axis,
which is the same behavior as the previous SOLIDWORKS release.

In the Linear Pattern PropertyManager, specify the following options for spacing or the
number of instances for Direction 1 and Direction 2:

Spacing and instances Independently specifies the spacing and the number of
instances.

Defines the spacing between pattern

@ .
Spacing instances.

Defines the number of pattern instances.
This number includes the original
features or selections.

o Number of
Instances

Up to reference Specifies the spacing and the number of instances based on
the selected reference geometry.

Specifies the reference geometry that

©
Reference controls the pattern.

Geometry

7 Reverse offset Reverses the direction that the pattern

direction is offset from the reference geometry.

Offset distance Specifies the distance of the last pattern
instance from the reference geometry.

Component Calculates the offset distance from the

Centroid reference geometry to the centroid of

the patterned feature.

Selected reference Calculates the offset distance from the
reference geometry to a selected seed
feature geometry reference.

Specifies which seed feature geometry

T
Reference to calculate the offset distance from.

Geometry

Fixed axis of rotation Direction 1 option. Patterned instances rotate around a
common axis.

Available when you select Rotate instances.

When cleared, the rotation axis for each instance of a
component is translated along Direction 1 and then rotated
following the axis of rotation for that component.
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Performance Evaluation

In the Performance Evaluation report, you can click Open I, to open a file in a new
window from the Details of the Open Document File and Graphics Triangles sections.
You must close the Performance Evaluation dialog box before you can switch to the opened
file.

For the Open Time and Total Triangles columns, the values are overlaid on the bar for
each row.

Component and configuration names are not truncated. For names that do not display
completely, an ellipse appears at the end of their name.

In Assembly Rebuild Report, you can expand or collapse nodes. Components that are
rebuilt more than one time appear in red. Components that take 10 milliseconds or less
to rebuild are omitted from the list.

To run Performance Evaluation for an open assembly, click Performance Evaluation
& (Assembly toolbar) or Tools > Evaluate > Performance Evaluation.

Saving an Assembly as a Part

When saving an assembly as a part, you can include or remove components based on
specified criteria to simplify the saved part.

You can use the following criteria to save an assembly as a simplified part:

e Visibility of the component from outside the model.
e Size (volume) of the component.
e If the component is a Toolbox component.

You can specify a component property to include or exclude the component when saving
an assembly as a part.

To open the Component Properties dialog box:
1. Inan assembly document, right-click a component and click Component Properties
=.

2. In the dialog box, under Save assembly as part, select an option:

Use system settings Uses the System Options to include or exclude a component.

Always include Includes a component in the resulting part when saving an
assembly as a part.
This option overrides conditions that are defined in the System
Options and the Save Assembly as Part PropertyManager.

Always exclude Excludes a component in the resulting part when saving an
assembly as a part.
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Assemblies Saved as Parts Export Options

To specify the export options:

1.
2.

Click Tools > Options > System Options > Export.
For File Format, select SLDPRT from assembly.
3. Specify the following options, and click OK.

Specified components

Remove

Visibility
threshold
(internal
components)

Bounding box
volume less than

Fastener
Components

Removes components that are below the
visibility threshold.

Move the slider to the right to decrease
the threshold for the internal components
to be visible.

Removes components that are below the
volume threshold.

This bounding box is a cuboid that aligns
to the component origin and fits around
the geometry of the component. This
bounding box is different from a bounding
box created by the Bounding Box
PropertyManager.

Removes components that have the
IsFastener property specified as 1.

Include

Mass properties

Overrides the mass properties of the part
with the mass properties from the
assembly.

Save Assembly as Part PropertyManager

To open the Save Assembly as Part PropertyManager:

1
2.
3.
4
5

In an assembly, click File > Save As.

Select Part (*.prt;*.sldprt) for the file type.

Select Include specified components.
Select Override defaults.
Click Save.

Specify the following options in the PropertyManager:

58



Assemblies

Remove Components

Visibility threshold (internal
components)

Removes components that are below the visibility
threshold.

Move the slider to the right to increase the threshold
for the internal component to be visible.

Bounding box volume less
than

Removes components that are below the volume
threshold.

This bounding box is a cuboid that aligns to the
component origin and fits around the geometry of the
component. This bounding box is different from a
bounding box created by the Bounding Box
PropertyManager.

Fastener components

Removes components that have the IsFastener
property set to 1.

Display Controls the display of components. Select an option:
Display All Shows all components.
Display Included Shows included
Components components.
Display Removed Shows removed
Components components.

Include

Mass Properties Overrides the mass properties of the part with the mass

properties from the assembly.
Results

Use these settings in System Applies the selections made in this PropertyManager

Options to the System Options.
This option is not available if the Systems Options are
locked by an administrator.

Reset Restores the PropertyManager default options.
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Select Identical Components

You can use Select Identical Components tool with the following options:

Option PropertyManager

Components to Pattern Circular Component
Curve Driven Component
Linear Component
Pattern Driven Component

Sketch Driven Component

Components to Mirror Mirror Components

These components Move Component

Available when you select Collision Detection or Rotate Component
Physical Dynamics.

All components in the Feature Scope section Extruded Cut
Hole Series
Hole Wizard
Revolved Cut
Simple Hole
Swept Cut

Component Selection Defeature

Exploded View

Access Select Identical Component by right-clicking:

e A component in the graphics area.
e A selected component in a PropertyManager.
e A component in the flyout FeatureManager design tree.
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Treehouse

Create Custom and Configuration-specific Properties in
Treehouse

You can add custom and configuration-specific properties to a Treehouse node. This
functionality is identical to the functionality available in the SOLIDWORKS software.

Custom Properties

To create custom properties:

1. In Treehouse, right-click a node and click Properties .
2. In the dialog box, click the Custom tab.

If you select more than one node, you see Multiple Values as the value in the Value
/ Text Expression and Evaluated Value columns when there is more than one
value for these fields.

3. For new nodes or for nodes that you created by using Saved as New Document,
enter values for File Name and File Location.

You cannot change File Name and File Location for existing nodes.

4. Populate the following columns:

Property Name Enter or select a value.

Type Select a value.

Value / Text Expression Enter or select a value.

Evaluated Value Calculated value based on Value / Text Expression.

5. Optional: To link the property value for a part to the BOM quantity, select the property
from BOM quantity.

6. Optional: To add, delete, or move a property up or down in the list, click Edit List.

7. Optional: To delete a property, select the row to the left of Property Name and click
Delete.

8. Click OK.

Configuration-Specific Properties

You cannot add configuration-specific properties if you select two or more nodes.

To create configuration-specific properties:

1. In Treehouse, right-click a node and click Properties .
2. In the dialog box, click the Configuration Specific tab.

61



Assemblies

If you select more than one node, the Configuration Specific tab is not available.

For new nodes or for nodes that you created by using Saved as New Document,
enter values for File Name and File Location.

You cannot change File Name and File Location for existing nodes.

To add the property to a configuration, select the configuration from Apply To.
Populate the following columns:

Property Name Enter or select a value.

Type Select a value.

Value / Text Expression Enter or select a value.

Evaluated Value Calculated value based on Value / Text Expression.

Optional: To link the property value for a part to the BOM quantity, select the property
from BOM quantity.

Optional: To add, delete, or move a property up or down in the list, click Edit List.

Optional: To delete a property, select the row to the left of Property Name and click
Delete.

Click OK.

Display in a List View

You can access the Properties dialog box in the Display in a List view "E by selecting a

row and then clicking Show Document Properties E.

In the Display in a List view 8= dialog box, column titles for configuration-specific
properties appear in blue. Properties with a white background are associated with the
selected file. Properties with a gray background are not associated with the selected file.

To specify the file path for new documents, click Browse and select a folder for the
Default Destination. After selecting a folder, click Apply.

Select Multiple Files for Import

You can select multiple part and assembly files to add to an existing assembly file in the
Treehouse graphics area.

To import multiple files:

1.

In Treehouse, open an existing assembly file.
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—

N

2. Click Existing File and select multiple files in one of the following ways:

e Ctrl + select to select individual files.
o Shift + select to select a group of files.

If you select files that are not part (. sldprt) or assembly (.sldasm) files, a message
warns that you cannot import these files.

3. Drag the selected files to the assembly in the graphics area.

Treehouse Graphics Area Enhancements

¢ Node size increased horizontally.

e Links for the Configuration dialog box and the Properties dialog box moved to the top
of the node.

e Subassemblies display in a more vertical format.

Treehouse Options

File Extensions

You can use Display file extensions to display file extensions in the list view and the
node view. This option is selected by default. Clearing this option allows more space to
show the document name.

To clear Display file extensions:

1. In Treehouse, open an assembly.

)

¥
2. Click Treehouse Options .
3. In the dialog box, under View, clear Display file extensions.

Display file extensions applies when you select Use the File name under Name
to Display.

4. Click Apply and then click OK.

File Images on Nodes

You can use Display file images on the nodes to display images on the nodes. This
option is selected by default. Clearing this option allows more space to show the document
name.

To clear Display file images on the nodes:

1. In Treehouse, open an assembly.
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2.
3.
4.

)

¥

Click Treehouse Options .

In the dialog box, under View, clear Display file images on the nodes.
Click Apply and then click OK.

Include Images in Microsoft Excel

You can view file images in Microsoft® Excel®.

To include file images:

1.

In Treehouse, open an assembly.

O

¥
Click Treehouse Options .

In the Options dialog box, under View, select Include file images when saving
to Excel.

Click Apply and then click OK.

Click Open in Excel @

In the Open in Excel dialog box, select Open Structure or Open Parts Only, and
click OK.

In the spreadsheet, file images appear in the first column.

Use Custom Property for Document Name in Treehouse

You can display a custom property as the document name.

To select a custom property for the document name:

1.

In Treehouse, open an assembly.

()

¥
Click Treehouse Options .

In the dialog box, under Name to Display, select Use the Custom Property named
and then select a property.

Click Apply and then click OK.

The property displays on the nodes. The document name appears blank for files that
do not have a value for the property.

64



Assemblies

Warning When Inserting Complex Components

When you insert a part into an assembly, you are warned when the SOLIDWORKS software
detects a high number of faces or graphics triangles in the part. A high number of faces
or graphics triangles indicates a high level of detail.

The warning does not prevent you from inserting the component. The warning includes
a link to the Performance Evaluation tool for further analysis.

The warning appears when an inserted part meets one of the following conditions:

e Over 3,500 faces and over 150,000 graphics triangles
e Over 300,000 graphics triangles
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This chapter includes the following topics:

e Assign Default Strategies to Machine Types

e CNC Compensation for Curve Features

e Corner Slowdown and Arc Feed Rate

e Improved Chamfer Machining

e Improved Toolpath Editing

e Improvements to Tolerance-based Machining
e More Parameters for Tapered Shanks

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Assign Default Strategies to Machine Types

You can create schemes of default feature strategies and assign them to machine types.

CNC Compensation for Curve Features

CNC compensation is extended to curve features.

Corner Slowdown and Arc Feed Rate

To allow different feed rates for arcs, machining slows down when approaching sharp
corners. Arc feed rates are calculated based on the radiuses.

Improved Chamfer Machining

In the Mill Features tab, you can apply chamfers to curve features. The software
automatically recognizes chamfers. You can create additional chamfer operations with
the Curve [edge break] Feature.

Ball end cutters are also supported.
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Improved Toolpath Editing

Toolpath editing provides better performance and an improved interface.

Improvements to Tolerance-based Machining

When machining a feature, you can move the feature manually based on the tolerance.
The software also calculates the delta based on the tolerances.

The software provides additional options for recognizing a tolerance range, ISO286 limits,
and fits for turning.

More Parameters for Tapered Shanks

You can specify more parameters to tapered shanks. The parameters give you more
control over tapered shanks and make it easier to connect to the Tools catalog.
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This chapter includes the following topics:
e Recognizing Additional SOLIDWORKS Features in CircuitWorks

CircuitWorks is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Recognizing Additional SOLIDWORKS Features
in CircuitWorks

When you export SOLIDWORKS board files to CircuitWorks™ using the CircuitWorks Export
Wizard, the wizard recognizes and translates some SOLIDWORKS features into CircuitWorks

terms.

Table Driven Pattern Extruded Cut, Hole Wizard, Simple hole

Mirror patterns Extruded Cut, Hole Wizard, Simple hole
Linear Pattern, Circular Pattern, Sketch Driven
Pattern, and Curve Driven Pattern

Slot Simple slots in Hole Wizard

The wizard recognizes simple slots in Hole Wizard
features and all sketch slots from extruded cuts.

In the CircuitWorks Export Wizard, when you select Use the Silhouette Edges,
support for defining slots as NPTH and PTH is unavailable.
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This chapter includes the following topics:

e SOLIDWORKS Composer
e SOLIDWORKS Composer Sync

SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical
contents for product communication and technical illustrations.

Animation Library Workshop and Timeline Enhancements

The Animation Library Workshop and the timeline behave more intuitively.

You can create camera keys in animation blocks. This helps define the behavior of the
camera throughout the step. The Auto Centering mode, for example, ensures that
the entire motion remains visible throughout the step. See Composer Help: Animation
Library Workshop > Properties.

When there is empty space between two existing animation steps, the application
automatically creates an empty space. Contextual options and user interface
improvements let you manage empty spaces on the timeline more intuitively and
efficiently. See Composer Help: Creating Pre-defined Animations.

In the Animation Library, if you delete an actor from the model, the application deletes
the corresponding animation keys from the timeline. When this leaves an animation
block empty (devoid of actors), a message informs you that the animation block is no
longer associated with any actor, and prompts you to delete the animation block from
the timeline. See Composer Help: Creating Pre-defined Animations > Creating a Simple
Animation.

In the Animation Library workshop:

e The Animations area is renamed to Templates. The behavior of the drop-down
boxes in the Templates area has improved. When you select several motions in
the timeline, the application empties the drop-down boxes.

e You can update animation blocks using the Update Selection command in the

Animations area. Previously, to update actors in an animation block, you had to
delete the animation block and recreate it with the updated set of actors.

The Update Motion command updates the properties of animation blocks selected
in the timeline.
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See Composer Help: Animation Library Workshop.

Defining Custom Import Profiles

You can define profiles with custom import options to use when importing CAD data.
Import profiles are defined in XML file format.

See Composer Help: Defining Custom Import Profiles.

Importing Assembly Envelopes Option

When you open a SOLIDWORKS assembly that contains envelopes, you have the option
to import the envelopes. Previously, Composer always imported assembly envelopes.

In the Open dialog box, select Import SOLIDWORKS assembly envelopes to import
this data. This option is available for the Open, Merge into the current document,
and Merge into a new document options. This option is selected by default.

You can enable this functionality from the SOLIDWORKS software. Click Tools > Options
> System Options > Export > SMG and select Export SOLIDWORKS assembly
envelope.

You can also batch import assembly envelopes using SOLIDWORKS Composer Sync. In
the Sync Document Properties dialog box, click Advanced Properties. Under INPUT -
IMPORT, select Batch.IOSSWImportAssmblyEnvelopes.

See Composer Help: Input.

Importing PMI Data

SOLIDWORKS Composer can import Product Manufacturing Information (PMI) data from
SOLIDWORKS models.

To import PMI data, in the Open dialog box, click Import and select Import PMI.
Composer can import:

e Dimensions

e Datums

e Tolerances for dimensions
e Geometric tolerances
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e Special symbols such as diameters and degrees
e Surface finishes

To modify the PMI colors during import, select Overwrite color and choose a color,
which is applied to all the imported PMI data.

Composer stores the PMI data in the PMI Data (SOLIDWORKS) folder under a root
node on the Assembly tab. Select or clear check boxes to hide or show the PMI data.

Composer imports view-based data such as annotation views from SOLIDWORKS and 3D
views from SOLIDWORKS MBD. Composer stores these views in the PMI Views
(SOLIDWORKS) folder under a root node on the Assembly tab in Composer. The 3D
Views and Annotation Views subfolders contain these categories of imported views.

After you import the PMI data into a . smqg file, the PMI data is visible in Composer Player.
Composer Sync also imports PMI data from SOLIDWORKS models into . smg files.

To enable this functionality from the SOLIDWORKS software, click Tools > Options >
System Options > Export > SMG and select Export PMI.

See Composer Help: Input.

Markup Properties

You can control linear arrows with Fixed Size Arrow and Fixed Length in the Properties
pane for markups.

Fixed Size Arrow —* ensures that a linear arrow always remains visible by specifying
that its size must remain fixed, regardless of the zoom factor. Fixed Length =* specifies
the required length of the fixed size arrow.

See Composer Help: Markup Properties.

Measurement Properties

You can use additional properties in the Properties pane to manage the display of
measurements:

¢ The General section contains the Show planes property. It also contains two updated
properties, Show red lines and Show Axis Vertices, which are also available for
distance between centers, and for distance between two axes. The Show Construction
Lines property displays all construction lines in measurements.

P
e In the Label section, the Shape property contains the Rounded Rectangle kJ
value.
e The Attach section contains the Show end points, End point size, and End point
color properties.

See Composer Help: Measurement Properties.
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Number of Selected Actors Appears in the Status Bar

The status bar displays the number of selected actors. If no actor is selected, it displays
the total number of actors in the model.

Click this number on the status bar to display the statistics for the current selection or
for the current model.

See Composer Help: Status Bar.

Search for Collaborative Actors

You can search for collaborative actors using the Include command in the Search pane
(accessed from the Assembly pane) or from the Collaboration pane.

Previously, only geometry actors were taken into account when searching for actors from
these panes.

See Composer Help: Search Pane.

Search for Commands in the Ribbon

The Search command is available on the ribbon. Previously, it was located in the File
menu.

You can directly access Search to search for commands in the ribbon and recently used
documents.

See Composer Help: Working with the Ribbon > Search for Commands in the Ribbon.

Select Adjacent Parts

You can use the Select Adjacent Parts command, under Navigate in the Home ribbon,
to select all parts that contact or intersect the selected part.

This command is available when you select at least one part (geometry actor).
See Composer Help: Home Tab > Navigate Commands.

SOLIDWORKS PDM Integration

You can use the integrated SOLIDWORKS PDM ribbon tab to perform vault commands
and view file information when the file is open in Composer. You must have SOLIDWORKS
PDM Professional installed.

H -

. p
“ FHigmg Renger Author Sties Transform Geometry Workshops Wndow [ S PFDM Debug

i Show Card Q search Local Version: 1 /1| Checked Out By: A
m celect in Windows: Explorer Local Rewnision hecked Out In

¥} Undo Chedk Ol Workflow State

You can access these SOLIDWORKS PDM functions from Composer:
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e Change State

e Check In, Check Out, Undo Check Out
e Get Latest Version, Get Version

e Search and Select in Windows Explorer
e Show Card

o Information section. Displays details about the Local Version, Local Revision,
Checked Out By, Checked Out In, and Workflow State.

If no file is open in Composer, only Search is available. If you open a file that is saved
outside the PDM vault, Search and Select in Windows Explorer are available. Once
you save an active Composer file in the PDM vault, the other PDM commands are available.

See Composer Help: SOLIDWORKS PDM Tab and SOLIDWORKS PDM Help: SOLIDWORKS
PDM Ribbon.

Undefined Color Properties in Animation Library

You can specify the color parameter of the predefined Flash and SetColor motions
properties to Undefined.

This parameter lets you avoid changing the color of the selected actor during this step
of the animation.

See Composer Help: Animation Library Workshop and Composer Help: Custom Animation
XML Example.

User Experience Enhancements for SOLIDWORKS
Composer

e The user interface has new command icons, particularly in the ribbon.

e New samples and 3D tools (arc welding gun, bearing puller, drill, and oil) are in the
Composer <install dir>\Samples folder. You can access samples and 3D tools
through the Model Browser Workshop.

See Composer Help: Model Browser Workshop.

e The user interface has been translated in five more languages: Czech, Polish, Portuguese
(Brazilian), Spanish, and Turkish.

The documentation is not translated in these languages.

See Composer Help: General.

73



SOLIDWORKS Composer

Versioning of Backup Files

When you use the AutoSave advanced setting, which automatically backs up the open

Composer files, you can use the AutoSaveVersioning setting to create versions of the
backup versions.

Use the AutoSaveVersioningMaxNumberOfFiles setting to specify the maximum
number of backup files to keep.

See Composer Help: Advanced Settings.

Working with Views

You can lock and unlock views.

Locked views [ prevent you from updating them by mistake.
See Composer Help: Working with Views > Lock a View.

SOLIDWORKS Composer Sync

Conversion Properties - Occlusion Options

You can configure occlusion options to use when importing native CAD files.

Occlusion removes parts from the model based on size or whether the parts are internal
and therefore not visible.

See Composer Help: Repair/Refinement > Occlusion.

Internal parts detected Occlusion completed

Occlusion options are also available through the command-line interface.

See the Composer Programming Guide for more information.
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Importing Assembly Envelopes Option

When you open a SOLIDWORKS assembly that contains envelopes, you have the option
to import the envelopes. Previously, Composer always imported assembly envelopes.

In the Open dialog box, select Import SOLIDWORKS assembly envelopes to import
this data. This option is available for the Open, Merge into the current document,
and Merge into a new document options. This option is selected by default.

You can enable this functionality from the SOLIDWORKS software. Click Tools > Options
> System Options > Export > SMG and select Export SOLIDWORKS assembly
envelope.

You can also batch import assembly envelopes using SOLIDWORKS Composer Sync. In
the Sync Document Properties dialog box, click Advanced Properties. Under INPUT -
IMPORT, select Batch.IOSSWImportAssmblyEnvelopes.

See Composer Help: Input.

Importing PMI Data

SOLIDWORKS Composer can import Product Manufacturing Information (PMI) data from
SOLIDWORKS models.

To import PMI data, in the Open dialog box, click Import and select Import PMI.
Composer can import:

e Dimensions

e Datums

¢ Tolerances for dimensions

e Geometric tolerances

e Special symbols such as diameters and degrees
e Surface finishes

To modify the PMI colors during import, select Overwrite color and choose a color,
which is applied to all the imported PMI data.

Composer stores the PMI data in the PMI Data (SOLIDWORKS) folder under a root
node on the Assembly tab. Select or clear check boxes to hide or show the PMI data.

Composer imports view-based data such as annotation views from SOLIDWORKS and 3D
views from SOLIDWORKS MBD. Composer stores these views in the PMI Views
(SOLIDWORKS) folder under a root node on the Assembly tab in Composer. The 3D
Views and Annotation Views subfolders contain these categories of imported views.

75



SOLIDWORKS Composer

After you import the PMI data into a . smg file, the PMI data is visible in Composer Player.
Composer Sync also imports PMI data from SOLIDWORKS models into . smg files.

To enable this functionality from the SOLIDWORKS software, click Tools > Options >
System Options > Export > SMG and select Export PMI.

See Composer Help: Input.

Remove Empty Groups After Occlusion
You can use the IORemoveEmptyGroupsAfterOcclusion advanced property to remove
empty groups at import.

This advanced property removes empty groups from the assembly tree if empty groups
exist as a result of the occlusion process at import. This option is selected by default.

See Composer Help: Advanced Properties.
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This chapter includes the following topics:

e Copying DimXpert Schemes to Derived Parts
e DimXpert Features

e DimXpert for Assemblies

e MBD Dimension

Copying DimXpert Schemes to Derived Parts

When you create a derived part, you can include DimXpert annotations and features from
the original part by selecting DimXpert scheme in the Insert Part PropertyManager.

DimXpert Features

You can define torus and surface of revolution features in DimXpert.

DimXpert for Assemblies

DimXpert tools within assembly documents are available in core SOLIDWORKS and no
longer require SOLIDWORKS MBD.

MBD Dimension

The DimXpert CommandManager and toolbars in part and assembly documents are now
named MBD Dimension.
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This chapter includes the following topics:

e Automatic View Updates and Exclusions

e Configuring the Precision of Dimensions and Tolerances
e Displaying Scrollbars

e Drawing Open Progress Indicator

e ISO Tolerance-Modifying Symbols

e Performance Improvements - Detailing and Drawings

¢ Removed Section Views

e Tables

Automatic View Updates and Exclusions

Automatic View Updates

The Automatic view update option, which controls whether views are updated when
the model changes, is how a document property that is saved within the drawing.

To change the update option in the current drawing, right-click the icon at the top of the
FeatureManager design tree and select or clear Automatic view update. When you save
the drawing, the option is saved within the drawing and remembered from one session
to the next. Previously, it applied only in the current session.

Excluding Drawing Views from Automatic Updates

You can exclude selected views from automatic updates that occur when the model
changes.

In the Drawing View PropertyManager, under Automatic View Update, select Exclude
from automatic update.
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Configuring the Precision of Dimensions and
Tolerances

In the Dimension PropertyManager, you can configure the precision of dimensions and
tolerances. In design tables, you can configure the precision of tolerances.

To configure precision of dimensions and tolerances:

1. Inthe Dimension PropertyManager, under Tolerance/Precision, specify a tolerance
type and maximum and minimum variations.

2. For Unit Precision, specify the number of decimal places for the dimension value.

3. For Tolerance Precision, specify the number of decimal places for the tolerance
value.

4. Click Configurations.

5. In the dialog box, select This configuration, All configurations, or Specify
configurations.

Configuring the Precision of Tolerances in Design Tables

In design tables, tol precision is a new keyword for the existing column header
STOLERANCE@Dimension.

Tol precision specifies the number of decimal places for the tolerance value. Valid
values: integers from 1 through 8 and NOM. Using NOM makes the value match the
dimension precision, and is the same as selecting Same as nominal in the
PropertyManager. To use the value specified in Document Properties, omit the parameter.

Example of a design table that controls a tolerance, including the precision of the tolerance
(highlighted in yellow):

A B
1 |Design Table for: Part3

STOLERANCE® D1@Sketchl

2

3 |small SYMMETRIC;0.050000;4

4 'medium  BILATERAL;0.150000;-0.050000;3
large LIMIT;0.150000;-0.050000;2

Ln

79



Detailing and Drawings

Displaying Scrollbars

You can turn on scrollbars in drawing documents without turning them on in part and
assembly documents.

Previously, the system option Display scrollbars in graphics view applied to all
document types (parts, assemblies, and drawings). In SOLIDWORKS® 2019, that option
is replaced by two new options (one for drawings and one for parts and assemblies).

You cannot change these options while any documents are open.

To display scrollbars in SOLIDWORKS documents:

1. Close all SOLIDWORKS documents.
2. Click Tools > Options > System Options > Display.
3. Select or clear these options:

¢ Display scrollbars in graphics view for parts and assemblies
o Display scrollbars in graphics view for drawings

Drawing Open Progress Indicator

The Drawing Open Progress indicator provides information on the status of operations
while you open a drawing.

o @ o
Loaded 4653 Sheets Graphics
Components Updated Generated

This file took 1 minutes and 3 seconds to open

Far more information, view: &? Performance Evaluation

This file was last opened in 1 minutes and 7 seconds

|:| Do not show again

~~

For drawings that take longer than 60 seconds to open, the indicator remains open after
the drawing opens.

The indicator provides information on the following operations:

Load Components Loads the part or the top-level assembly and referenced
documents. Shows the nhumber of components opened
and the total number of files in the model.
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Update Drawing

Updates models including mates, assembly features,
patterns, and in-context models. If the drawing has
multiple sheets, shows the total number of sheets and
which sheet is being updated. Click Skip remaining to
interrupt loading of sheets after the current sheet.

Update Graphics

Generates graphics.

Elapsed time

Shows the amount of time required to open the drawing.

Previous time to open

Shows the amount of time required to open the drawing
the last time the drawing was opened.

For assembly drawings, the Previous time to open
operation is specific to the assembly mode. This
information is saved for Large Assembly mode, Lightweight
mode, and Resolved mode.

After opening the drawing, click Performance Evaluation in the indicator dialog box to
view performance information specific to opening the drawing. To view the performance
information at a later time, click Tools > Evaluate > Performance Evaluation.

You can suppress the Drawing Open Progress indicator by selecting Do not show again.
To restore the progress indicator, click Tools > Options > System Options >
Messages/Errors/Warnings, and select Drawing Open Progress Indicator.

ISO Tolerance-Modifying Symbols

You can add symbols and other text directly to ISO dimensions and their tolerances from
the Tolerance Modifier section in the Dimensions PropertyManager.

215 %1 (GG )SCS

]

applied to each limit

Bilateral tolerance with symbols Symmetric tolerance with symbols applied to the

entire dimension

Symbols from the following specifications are available in the Symbol Library, in the new

ISO Tolerancing category:

ISO 14405-1:2016

ISO 8015
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ISO 1101:2017

To add ISO tolerance-modifying symbols:
1. In the Dimensions PropertyManager, select Tolerance Modifier.

Tolerance Modifier is not available if Tolerance Type is None or Basic.

2. Specify options:

Option Description

General Applies symbols and text to the dimension, regardless of
tolerance limits.

Specified limits Applies symbols and text to the upper or lower limit. (Available
only when Tolerance Type is Bilateral, Limit, Fit, Fit with
tolerance, or Fit (tolerance only).

Click in the text box and click More Symbols &> More Symbols.

In the Symbol Library dialog box, under Categories, select ISO Tolerancing.
Select one or more symbols.

Click OK.

oA W

Available Symbols

Symbol Tag Description

LP <ITOL-LP> Two-point size

S <ITOL-LS> Spherical size

"'.GG“ : <ITOL-GG> Least-squares

'Gx"n <ITOL-GX> Maximum Inscribed
f"-GN.." <ITOL-GN> Minimum Circumscribed
( GC <ITOL-GC> Minimax

Y < -CC> ircumference Diameter
; CC' . ITOL-CC Ci f Di t
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Symbol Tag Description

C P-. <ITOL-CA> Area Diameter

f\:CV..'_.' <ITOL-CV> Volume Diameter

.;_".. SX <ITOL-SX> Maximum Size

f:SN <ITOL-SN> Minimum Size

S A_._.JS <ITOL-SA> Average Size

ff;SM <ITOL-SM> Median Size

f\._SD . <ITOL-SD> Midrange Size

':-J... SR <ITOL-SR> Range of Sizes

SQ <ITOL-SQ> Standard Deviation of Sizes

C <ITOL-C> Minimax Toleranced Feature

E <ITOL-E> Envelope Requirement

F <ITOL-F> Free State

A <ITOL-A> ISO 8015 Rule

G <ITOL-G> Least Squares Toleranced Feature
i:/.l\-ll;i <ITOL-N> Minimum Circumscribed Tolerance Feature
{ T <ITOL-T> Tangent Tolerance Feature
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Symbol Tag Description

( X <ITOL-X> Maximum Inscribed Tolerance Feature
ACS <ITOL-ACS> Any Cross Section

SCS <ITOL-SCS> Specified Cross Section

ALS <ITOL-ALS> Any Longitudinal Section

CT <ITOL-CT> Common Tolerance

UF <ITOL-UF> United Feature

- <ITOL-IBETW> Between

Performance Improvements - Detailing and
Drawings

e Performance when creating, opening, and editing hole tables has improved for large
numbers of holes and for the combination of circular and noncircular holes.

e The time it takes to switch from a model to its drawing under the following conditions
is improved:
e Both the model and its drawing are open.
e You make changes in the model that do not change geometry.
e The drawing has multiple sheets.
¢ Automatic view update is selected.
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Removed Section Views

Removed section views show slices of the model at selected locations along a drawing
view.

Creating Removed Section Views

You use the Removed Section tool to create views of slices along a drawing view.

To create a removed section view:

1.

2.
3.

In a drawing, select a view.

Click Removed Section +2 (View Layout CommandManager tab or Drawing toolbar).

In the PropertyManager, for Edge and Opposed Edge, select two edges from the
same drawing view.

The edges must be opposed or partially opposed geometry between which a solid
body can be cut.

Select a cutting line placement method:

Option Description

Automatic Shows a preview of the cutting line within
the area between the opposing model
edges. Move the pointer and click to place
the cutting line.

Manual Positions the cutting line between two
points that you select on each of the
opposing model edges.

Hover near one end of the cutting line and
click to place it. Repeat for the other end
of the line.

Move the pointer and click to place the view.
In the PropertyManager, specify other options.
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7. Click ¥.

Tables

Changing Cell Border Thickness

In tables, you can change the border thickness of individual cells, selected groups of cells,
and entire tables. You can also remove cell borders.

To change the cell border thickness:

1. Select one or more cells.

¥ B B [
TEA NO. Partio QY.
- 1 P108-24 1
=F 2 P102-16 1
- 3 P119-08 1 |

To select cells, you can:

e Click, Ctrl + click, or Shift + click in cells.
e Click a column letter or a row number.

e Click E’I to select the entire table.
2. On the pop-up toolbar, click Border Edit =4

(%
The pointer changes to .

3. Move the pointer over a border of the selected cells.

The pointer changes to % when it is over a valid border.

¥ A B C
TEAA NO. ParMo QY.
1l 1 P108-26 [3| 1
=F 2 P103-16 1
. 3 P119-084 1 |
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4. Click one or more borders of the selected cells and select a new border thickness.

¥ A B C
TEM WO, PartMo V] I
o= 1 P10&-24 Mone
1 2 P103-74& 0.18mm
. 3 P11%-0& 0.25mm
0.353mm
0.7mm
I | 1y
N |
I 0
You can:

e Continue clicking and changing other borders of the selected cells.
e Select None to remove the cell border.

5. To turn off Border Edit -f%, click it on the toolbar or click in a blank region of the
graphics area.

TERA M. Partho =Ty
1 F10&8-2& 1
2 F103-1& 1
2 F11%8-08 1

6. Repeat steps 1 through 4 to change borders on other cells.

ITEM MO, Partho QTY.
1 P10&-2& 1
2 F103-1& 1
3 F113-0& ]

Custom Properties in Lightweight BOMs

When you open a drawing in lightweight mode, notes and tables linked to custom
properties show up-to-date values. Previously, the values did not always update if the
models changed after the drawing was last saved. To achieve this new behavior, the
models must be saved in SOLIDWORKS 2019 or later.

In addition, the precision and units of custom properties in lightweight drawings and
assemblies are supported. Tables and notes reflect the Document Properties Units settings
of the active drawing or assembly without having to resolve the components first. To
achieve this new behavior, the models must be created in SOLIDWORKS 2018 or later.
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Customizing Quantity Column Headers in BOMs

In the header of the quantity column in a BOM, you can show or hide custom text and
the configuration name independently.

Document properties are provided to define the header independently for each BOM type
(Top-level only, Parts only, and Indented).

You can specify the document properties:

e In the document template, before you create the drawing or assembly document
e In the drawing or assembly document, before you create the BOM

To customize headers of quantity columns:

1. Open a drawing or assembly template or document.

2. Click Tools > Options > Document Properties.

3. Under Drafting Standard, expand Tables and click Bill of Materials.

4. For each type of BOM (Top-level only, Parts only, and Indented), specify these

properties:
Option Description
Show custom text in BOM header Replaces the default text in the header

with text that you enter in Custom text.
For a blank header, select this option and
leave Custom text empty.

Show configuration in BOM header Adds the configuration name to the
header.

5. Click OK.

When you create the BOM, the header of the quantity column is defined by the
document properties that you specified.

After you create a BOM, you can edit the header of the quantity column:

e Right-click the header and click Show all configurations to show or hide the
configuration name.

e Double-click the header to edit the default or custom quantity text.

The following document properties are no longer available:

e Do not add "QTY" next to configuration name
e Do not copy QTY column name from template
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Hole Table Tags - Prefixes, Numbers, and Order

In hole tables, you can create custom tag prefixes, edit tag numbers, and use several
methods for defining the tag order.

Defining Custom Tag Prefixes

You can define multiple custom tag prefixes. In hole tables, you can apply the prefixes
to holes you select.

To define custom tag prefixes:

e In the Hole Table PropertyManager, under Tag Type, select Manual, and enter custom
tag prefixes.

To apply custom tag prefixes:

e In the hole table, right-click a tag cell and click Assign Tag Prefix. Then select a tag
prefix in the dialog box.

Editing Tag Numbers in Hole Tables

You can directly edit the tag number for any hole in a hole table.

Double-click in the tag cell in the hole table or double-click the hole label annotation in
the drawing view.

Controlling the Order of Tags in Hole Tables

When you create a new hole table, you can specify the method for defining the order in
which the holes are tagged.

Previously, only the XY method was available.

In the Hole Table PropertyManager, under Tag Order, select a method:

XY Uses the X-Y coordinates to order the tags closest to the
selected datum.

Reduced tool path Uses the shortest length between all holes of the same size
and orders the tags along that path.

Radial Orders the tags radially for turned or lathe parts.

Including Thumbnails in BOMs Exported to Microsoft Excel

You can include a thumbnail of each component when you export a table-based BOM to
Microsoft® Excel® in the .x1s or .x1sx format.
To include thumbnails in a BOM:

1. Right-click a BOM and click Save As.
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2. In the dialog box:
a) For Save as type, select one of the following:

e Excel 2007 (*.xIsx)
e Excel (*.xls)

b) Select Thumbnails.
c) Browse to a folder, enter a file name, and click Save.

When you open the file in Excel, thumbnails are included.

& E C [u]
DOCUMENT  ITEM
PartNo | QTY.

' | PREVEW = No, oMo @
1 | PlOBI5 | 1

2
2 PIOZIE | 1

3
P119-08 1
4 PIO705 1

5 P118-15 1

& P11&-02 1

e @ @\ 2 &
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This chapter includes the following topics:

e Configurations in SOLIDWORKS Parts

e Configurations in SOLIDWORKS Assemblies
e eDrawings Performance

e eDrawings Professional Features

e Perspective Views

e Using Ambient Occlusion

e Save As Web HTML

e Supported File Types in eDrawings

eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Configurations in SOLIDWORKS Parts

You can specify configurations of a SOLIDWORKS part to be available when you open the
part in eDrawings®.

In the SOLIDWORKS software, set configurations with Add Display Data Mark to view
the configurations in eDrawings.

See SOLIDWORKS Online Help: Opening Part Configurations in Quick View Mode.

Configurations in SOLIDWORKS Assemblies

When you open SOLIDWORKS assemblies in eDrawings, you can access all of the assembly
configurations that were saved in Large Design Review mode.

eDrawings Performance

View manipulations and assembly component selections are faster in eDrawings.

To improve performance, click Tools > Options > General and select Graphics boost
and Fastest speed.
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eDrawings Professional Features

All eDrawings Professional features from eDrawings 2018 and older are available in the
free eDrawings Viewer. This applies to eDrawings for Windows® only (not mobile).

For example, you can measure any file in the eDrawings Viewer, whereas the Measure
tool used to be available in eDrawings Professional only.

In the SOLIDWORKS software, when you save a file as an eDrawings file, you can still
clear the Okay to measure this eDrawings file option to prevent measurement of the
file in eDrawings. In eDrawings, when you save a file, you can clear Enable measure.

All new functionality in eDrawings Professional 2019 and later will be available in eDrawings
Professional only.

Perspective Views

The Perspective tool has moved to the View Settings tool on the Heads-up View toolbar.

To use perspective views, click View Settings '_—J > Perspective m

Using Ambient Occlusion

You can view models with ambient occlusion in eDrawings. Ambient occlusion is a global
lighting method that adds realism to models by controlling the attenuation of ambient
light due to occluded areas. It also provides clarity between components.

Ambient occlusion can affect performance.

To use ambient occlusion:

1. Click Options E or Tools > Options.

In the dialog box, on the General tab, under Performance, select Graphics Boost
and Fastest speed and click OK.

3. Click View Settings '_—J > Ambient Occlusion (Heads-up View toolbar)
or View > Ambient Occlusion.

Save As Web HTML

You can save files as Web HTML files in eDrawings.
Available in eDrawings Professional.

In eDrawings Professional, click File > Save As. In the dialog box, in Save as type,
select eDrawings Web HTML Files (*.html).

92



eDrawings

Supported File Types in eDrawings

You can open the following file types in eDrawings.

File Type (Version) Description

ACIS (Up to 2018.1 (R28)) o .sat

e _sab
AutoCAD® (Up to AutoCAD e .dxf files
2018) e .dwg files
Autodesk® Inventor® (Upto e .ipt
2018) e .iam
CATIA VS5 (Up to V5-6 R2018 e CATPart
(R28)) e CATProduct

CATIA V5 [3DXML] (Up to . 3DXML
V5-6 R2018 (R28))

eDrawings (Up to eDrawings ¢ .eprt
2019) .

.easm

e _edrw

JT (Up to v10.0) jt
. JT data format files do not support Product Manufacturing
Information (PMI).

Parasolid (Up to v30.1) e .x b
e .x t
e _xmt

e _xmt txt

Solid Edge (V19-20, ST - e .par
ST10) e .psm

® .asm

Solid Edge files do not support PMI.

SOLIDWORKS (Up to e .sldprt
SOLIDWORKS 2019) e .sldasm

e _slddrw
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File Type (Version) Description

Unigraphics-NX (11.0 to .prt
12.0)
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SOLIDWORKS Electrical

This chapter includes the following topics:

e Black Box Terminals

e Cable Cores

e Connector Graphical Representation

e Conversion to Mixed Scheme Drawing
e End Terminations

e Input/Output Symbol

e Links in Report Drawings

e Macro Tool

e Option for Dimension Units

e Reach a Drawing Dialog Box

¢ Renumber Components Feature

e Revisions Management

e Saving Symbols as Palettes

e Wire Cabling Order Dialog Box

e Improved Performance in SOLIDWORKS Electrical 3D

SOLIDWORKS Electrical is available as a separately purchased product.
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Black Box Terminals

You can represent the black box terminals using a hew configuration parameter for specific
connection points and attributes.

Cable Cores

You can switch two cable cores with the Switch Cable Cores tool in the shortcut menu
of the Terminal Strip Editor.

Connector Graphical Representation

You can use new parameters in the connector configuration files that improve the process
of inserting dynamic connectors in schematic drawings.

Use the parameters to:

Manage a wipeout under the connector

Add a zig-zag line if the connector representation is incomplete
Display cross references

Choose pin sides. Provisions for D-connectors include:

e Right

o Left

e Right and left

o Left and right

Conversion to Mixed Scheme Drawing

In the Drawing Properties dialog box, you can change the type of drawing from Schematic
or Line diagram to Mixed Scheme.

The ability to change the drawing type is only available in the Admin mode.

End Terminations

You can define and manage End Terminations at the terminal level of manufacturer
components through the Termination Type Manager.

You can use new variables and attributes to display information in reports and schematic
drawings about End Terminations that are used for components. You can use symbols
and manufacturer parts to represent End Terminations in schematic drawings. The end
wire connected to a component can be different for each type of End Termination.
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Input/Output Symbol

From the context menu of the Input/Output List, you can open the drawing that contains
the Input/Output symbol.

Links in Report Drawings

The Go to tool automatically generates links to reports in report drawings.

You can also export PDF files with Go to links in report components. The links connect
to the generated PDF drawings.
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Macro Tool

You can insert a macro as you insert a new symbol, using the Insert Macro tool in the
Schematic and Line diagram menus.

Option for Dimension Units

In the properties of wires, cables, and manufacturer parts, you can choose to display the
dimensions in millimeters or inches, using new options in the Project Configuration dialog
box.

Reach a Drawing Dialog Box

In the Search Document dialog box, you can filter searches by Book, Function, and
Location.

Renumber Components Feature

When you renumber components, you can select the type of symbols to use in the project
configuration. The symbols determine where the numbering starts.

Revisions Management

You can manage the revision index through an improved interface that includes ribbon
bars and a dialog box that lists the index properties.

Saving Symbols as Palettes

You can drag symbols from the graphics area to the palette and save them as favorites.

Wire Cabling Order Dialog Box

You can open the drawing containing the component through the Go To tool on the
context menu of the component.

Improved Performance in SOLIDWORKS
Electrical 3D

The performance is improved for Route Cables and Route Harness tools. The
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performance is faster when you use the Route Wires tool for routing a large number of
wires in an assembly.

When you click Tools > SOLIDWORKS Electrical > Electrical Component Wizard
the Route Library Manager launches quickly and you can define components faster for

SOLIDWORKS Electrical 3D.
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SOLIDWORKS Flow Simulation

This chapter includes the following topics:

e Associated Goals

e Customized Visualization Parameters

e Edit a Two-resistor from Component Explorer
¢ Flux Measure on Semitransparent Surfaces

e Flux Plot

e Project Parameters

e Surface Parameters in Sections

SOLIDWORKS Flow Simulation is available as a separately purchased product that can be used
with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Associated Goals

From the Boundary Condition dialog box, you can select a goal that automatically applies
to the boundary condition’s reference face or body.

This goal is linked to the boundary condition. Updates to the boundary condition's reference
propagate to the associated goal. Removing a boundary condition also removes the goal
associated with it.

Customized Visualization Parameters

You can apply mathematical functions (such as Integral, Min, Max, and Average) and
logical expressions (such as IF, More, and Less) to customize visualization parameters.

With customized visualization parameters, you can get more information from the
calculated field. For example, you can calculate an area where a required parameter is
greater than a specified value.
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Edit a Two-resistor from Component Explorer

You can edit a Two-resistor directly from the Component Explorer table.

Flux Measure on Semitransparent Surfaces

You can measure incoming radiant flux on surfaces of semitransparent bodies.

Flux Plot

You can display how much heat transfers from one component to another (by conduction)
with a Flux plot.

You can also visualize the heat that flows out of the fluid through convection or radiation.
You can group components so that the calculated heat is the total heat flowing in and

out of all components. The Pie chart plot for incoming and outgoing heat helps to visualize
the balance of heat.

Project Parameters

A project parameter is a user-defined constant or variable that you can use to define
boundary conditions throughout the project.

Use project parameters in dependencies and as custom visualization parameters. You
can edit the project parameters in a parametric study.

Surface Parameters in Sections

You can calculate surface parameters in a section plane.

If a section plane divides a model into several closed contours, you can calculate
parameters separately for each contour. This eliminates the need to create a dummy

body to measure a fluid's integral parameters (for example, calculate the mass flow rate
through a pipe’s arm).
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This chapter includes the following topics:

e Exporting to the PLY File Format
e Exporting Using Extended Reality
e Reading Tessellation Data from Foreign CAD Files

Exporting to the PLY File Format

You can export SOLIDWORKS part and assembly files to the Polygon® file format (.ply).

Exporting Using Extended Reality

The Extended Reality Exporter exports content that powers rich AR, VR, and web
experiences.

You can export SOLIDWORKS CAD files to .glb or .glTF file formats. The files contain
information such as geometry, appearances, textures, animations, motion studies,
configurations, display states, exploded views, lights, and metadata.

You can:

o Import these files into platforms such as Unity or Unreal to create experiences.
e Drag .glb files into Microsoft® Office 365° products like PowerPoint to have interactive
3D model viewing experiences.

e Contact an approved technology provider to create a custom AR, VR, or web experience
that suits your needs. For more information or to learn about approved providers, see
the SOLIDWORKS Corporate Blog.

Only Approved Provider Viewers support the advanced capabilities of the XR Exported
file. These capabilities include Animations, Motion Studies, Exploded views, Display
States, Configurations, Decals, and Metadata.

The Extended Reality Exporter:

e Improves collaborative internal and external design reviews.
e Sells designs more effectively with immersive experiences.

e Trains your staff about how to immersively assemble and interact with your products.
For example, you can create an Augmented Reality training walkthrough to teach
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mechanics how to service an MRI machine when a part breaks, all from the original
SOLIDWORKS CAD file.

To export to the gITF file format:

1. With a file open, click File > Save As.

2. Inthe Save As dialog box, select Extended Reality (*.GLTF) or Extended Reality
(*.GLB).

3. Select Options and specify the settings for exporting Extended Reality files:

Scene Export Views Exports SOLIDWORKS views.
Export Cameras Exports SOLIDWORKS cameras.
Export Lights Exports lights to a Khronos Light

Extension (.KHR Light) file.

Animations Export Motion Studies Exports timeline animations as gITF
keyframe sequences.
Export Exploded Exports exploded views as gITF
Views keyframe sequences.

4. Click OK.

Reading Tessellation Data from Foreign CAD
Files

SOLIDWORKS 3D Interconnect reads tessellated data from third-party CAD files.

The As Graphical Body option appears in the Open and Insert Component dialog boxes.
This option imports files as graphical 3D meshes instead of solid or surface bodies. You
can also load BREP data from the imported part and assembly files.
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This chapter includes the following topics:

e SOLIDWORKS Inspection Add-in
e SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection is available as a separately purchased product that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a
completely separate application (see SOLIDWORKS Inspection Standalone).

SOLIDWORKS Inspection Add-in

Bill of Characteristics

The Bill of Characteristics is reorganized from a tree to a grid. This condenses the view
and simplifies grouping, ungrouping, sorting, and ordering. You also have the ability to
personalize and change report formatting.

You can select multiple characteristics using keyboard shortcuts (Ctrl + click or Shift +
click) to reorder characteristics.

New columns support the group/ungroup feature. The columns indicate the ID # (balloon
number) and Char # (characteristic number). This is important because a report could
have two characteristics (such as 18.1 and 18.2) but only one balloon (18) in the drawing
to save space.

With grouping and ungrouping, you can:

e Group similar characteristics.
¢ Have multiple characteristics share a unique balloon.
e Mark a unique characteristic as "key".
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Custom Properties

You can add an unlimited number of custom properties or choose them from a predefined
list (such as CheckedBy and CheckedByDate).

You often need custom properties to create inspection reports. To save time and
standardize processes, define more custom properties at the project level and save them
in a template.

You can export the custom properties to a Microsoft® Excel® inspection report or save
them in a project template.

Hole Table Extraction

You can extract all information from hole tables. You can capture all information available
in drawings, including complex hole tables.

Balloons appear at the side of hole tables. You can adjust their locations with the options
in the Add/Edit Balloons menu. You can also hide the balloons.

All information in hole tables is included in the characteristic tree, including the X and Y
positions of the holes.
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Zone Support

If you define a zone in a SOLIDWORKS drawing, the balloon zone is automatically
calculated for each characteristic. A new field displays the zone in the characteristic's
properties.

You can add the zone to a custom Microsoft Excel inspection report using the Template
Editor.

Inspection drawings can have hundreds of balloons and it can be difficult to find balloons
referenced in the report. Adding the zone to inspection reports helps you find the balloons.

SOLIDWORKS Inspection Standalone

SOLIDWORKS PDM Integration

SOLIDWORKS PDM integration is part of SOLIDWORKS Inspection Standalone starting
with release 2018 Service Pack 2.0. It helps users include quality management as part
of the product development process.

You can access SOLIDWORKS PDM tools such as Check Out, Check In, Search, and
Get Latest Version using the SOLIDWORKS PDM tab in the CommandManager.

This integration helps quality engineers manage and centralize the storage of inspection
projects including the files and reports related to the projects. Version control helps
prevent data loss and the Search tool reduces the time to search for inspection projects.
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This chapter includes the following topics:

e Adding a References Folder Structure

e Alternate Options for Mapping Properties

¢ Bill of Materials Performance

e BOM Tab Content Indicator

e Changing the SOLIDWORKS PDM State Through a Process Output
e Configuration File Utility

e Copying Custom Values in BOM Items

e Document Templates

e Duplicate BOM Line Items

e Export Template Configuration

e Field Group Selection

e Full Web Client

e Hours for Working Days in Projects

e Importing BOM Data from a Microsoft Excel File
e Inactive Configuration Handling in Processes

e Item Detail Pane for BOM View

e Linked Record Objects

e List of Recent Documents

e Manual Quantity Synchronization

e Object Type Hyperlinks

e Performance Improvement in Synchronization
e Rich Text in Memo Fields

e SOLIDWORKS PDM Records in Where Used Tab
e Splitting an Auto Number

e Splitting Projects into Stages

e Support for Internal Components

e Thumbnail Images of SOLIDWORKS PDM Files
e Updating SOLIDWORKS PDM Variables

SOLIDWORKS Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Adding a References Folder Structure

You can add a folder structure to organize references similar to the existing folder structure
for related files.

To add a references folder structure:

1. In the Administration tool, edit an object, and click the Related Files tab.
In the References section, click New Folder.

Enter a name for the new folder.

Optional: Define the required access rights.

Repeat steps 2 to 4 to add more folders.

You can drag the folders to arrange them.

A WwN

Alternate Options for Mapping Properties

SOLIDWORKS Manage lets you provide alternate options to map part humbers and
description values from SOLIDWORKS PDM files.

The application uses other mapping options when the initial mapping options are not
available.

Bill of Materials Performance

The administrator can specify the number of BOM levels to load when users click the BOM
tab of a record for the first time.

This improves BOM display performance for BOMs with thousands of line items.

Setting the System Display Levels

To set the system display levels:

1. Open the Administration tool and select Advanced.
2. In the General tab, set the number of BOM levels to display.

Changing the Level Preference

To change the level preference:

1. In the BOM tab, click Tools and select Number of levels to display.
2. Select the mode to change.
3. Select the number of levels.

This setting is used for all BOM views for that user. Additional levels are loaded when
the user expands the level.
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BOM Tab Content Indicator

The empty BOM variants are displayed as E. The BOM variants have any line items are
displayed as .

Configuration Part Number Option

When you create virtual configurations or make the inactive configurations active, the
Use Root Part Number + Configuration Name option combines the parent record’s
part number with a user-entered string. This option associates the configuration records
with their parent records.

Changing the SOLIDWORKS PDM State Through
a Process Output

You can change the state of a promoted SOLIDWORKS PDM file through a process output.

This gives you control of the SOLIDWORKS PDM files that are attached as affected items
to a SOLIDWORKS Manage process. This also initiates SOLIDWORKS PDM file tasks from
SOLIDWORKS Manage.

To change the SOLIDWORKS PDM state through a process output:

1. In the Process Management wizard, navigate to the Properties page.

2. In the diagram area, select a stage, and then an output node.

3. Click New and select Change PDM status from the list.

4. Inthe Change State Output dialog box, click LI, and select PDM Object, Workflow,
From State, and Transition from the lists.

Click Save and Close.

Optional: Add any additional state changes as required for this stage output and click
Close in the Change State Output dialog box.

o wu

Configuration File Utility

You can use swm.configwizard.exe to test the license server connection and reset the
Admin password for SOLIDWORKS Manage.

Testing the Connection to the SolidNetWork License
Manager

To test the connection to the SolidNetWork License Manager:

1. In the Configuration File Wizard, click Open, and select an . swmc format file.
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2. In SWM License Server, enter the license server name, and click Test Connection.

If the connection is successful, a success message appears. Otherwise, ensure that
the license server name and part are correct and the license server is running.

Resetting the SOLIDWORKS Manage Admin Password

To reset the SOLIDWORKS Manage Admin password:

1. In the Configuration File Wizard, click Reset Admin account password.
2. Enter the old SQL database password.

3. Enter a new password.

4. Click OK.

Technical Support can use this feature to troubleshoot customer databases.

Copying Custom Values in BOM Items

You can use the Copy From dialog box to copy custom field values when you copy BOM
items from one BOM variant to another.

If the BOM items already exist, the application copies only the custom field values.

The source and target BOM variants must have the same field names and must have
compatible data type.

Document Templates

When you create a new document record, you can select the source file from a
SOLIDWORKS Manage document object or a SOLIDWORKS PDM file.

The administrator can control which users can select an existing file.

Duplicate BOM Line Items

You can add a duplicate row to a BOM. You can assign alternate values to the custom
BOM field properties in the new line.

For example, a CAD BOM requires four generic bolts and two of them must have a different
finish. Create a single-line item for a bolt and duplicate it. Use custom BOM fields to add
the extra information. Use the Manual Quantity column to ensure that the total number
remains the same.
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Enabling Duplicate Line ltem Functionality

You can enable duplicate line item functionality for each BOM variant.
To enable the duplicate line item functionality:

1. Open the Administration tool or right-click an object in the window and click Tools
> Administration.

2. Inthe Bill of Materials section of the object, select an existing BOM variant or create
a new one.

3. In the Other Options tab, select Allow duplicate part numbers.
4. Click Save and Close.

Adding a Duplicate Line ltem

To add a duplicate line item:

1. Edit a BOM variant.
2. Right-click the line item and click Duplicate line.

Export Template Configuration

The export template configuration has new options to handle more specialized instances.

¢ Fixed length output fields

e Name output files based on a numbering scheme

e Adding all BOM items to a single file

¢ Line item conditions

e Exporting multilevel BOMs into parent child files for each level
o Setting the templates to be used from other referenced objects
e Latest version or as built BOM option

Field Group Selection

You can hide certain field groups when you create a new SOLIDWORKS PDM file from
SOLIDWORKS Manage.

You can display additional field groups that were added to a SOLIDWORKS PDM object
and hide SOLIDWORKS PDM data cards. This lets you use several field groups for a single
data card.
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Full Web Client

SOLIDWORKS Manage has a full web client that has the look and feel of the desktop
client.

With the full web client, internal users can create and edit product structures through the
Item functionality.

The existing web client, which is more suitable for external users, is still available.

The full web client is available as a separate download and is not included in the
SOLIDWORKS Installation Manager.

Hours for Working Days in Projects

You can set the working hours of each day including Saturdays and Sundays. You can
use this in calculating the time required to complete a stage based on the time required
from all tasks within it.

For example, if you enter 4 working hours for Saturday and 8 hours for Monday-Friday,
then you can complete 44 hours of tasks each week. You can set the working hours at
the system level and modify them for each project.

Previously, you could select only the working days and each day was set to 8 hours.

Setting the Default Working Hours

To set the default working hours:

1. Open the Administration tool or right-click Projects in the main user interface.
2. Click Tools > Administration.
3. Click in the Structures pane and select Projects.
4. In the Working hours page, set the hours.
If you change the system working hours, existing projects are unaffected.

Changing the Working Hours

To change the working hours:

1. Open and check out an existing project.
2. Select Planning to display a Gantt chart.
3. On the toolbar, click Options.

4. Set the hours and click Save.
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Importing BOM Data from a Microsoft Excel File

You can import bill of materials (BOM) data from a Microsoft® Excel® file. The file must
be based on the template defined for the BOM type.

The application only searches for existing records in the same object. If a record does
not exist, then the application adds a text line to the BOM. It does not create a new
record. When you edit a BOM, use Replace to replace a text line with a record.

The import functionality does not support multilevel BOM import.

Inactive Configuration Handling in Processes

When you add a parent record to a process, the inactive configurations are automatically
hidden.

Previously, all configurations, including the inactive ones, were added to the process.

ltem Detail Pane for BOM View

You can view additional BOM details in the item detail pane in the Property Card.

The pane displays the following information about the selected BOM line item:

Properties. Displays references, thumbnails, record status information, and properties.
If you select a reference, the reference properties appear.

Preview. Displays a preview of the selected BOM item or a selected reference document
of the selected BOM item.

Preview is not available for record objects.

Search. Enables searching for items that you can add to the BOM while in BOM edit
mode.

Viewing BOM Details in the Item Detail Pane

To view BOM details in the item detail pane:

1.

Open the Property Card of a record that has the BOM tab enabled and has a BOM
variant defined.

In the Property Card of the record, select BOM on the left pane.

Click the left-pointing arrow at the upper right of the Property Card window to expand
the pane.

Select a line item in the BOM variant.
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Linked Record Objects

Linked record objects let you use separate but connected items to represent product
structures.

The application saves linked records in a separate record object that has a primary

reference link to a document record. Primary references are similar to standard references
but can also drive field values, thumbnail images, BOMs, related files, and other references.
You can check out and edit linked references without checking out the primary reference.

Linked records allow companies to have file data stored in SOLIDWORKS PDM that is
controlled by one group but available to other groups with read-only access. For example,
an engineering department controls the file data and a manufacturing department has
read-only access to it.

You can create a linked record from a document record or independently before a document
record exists or is approved. In the latter, a primary reference would not exist but you
can add it later.

Configuring Linked Records

You can configure the linked record in the document object that has the primary reference.
Rules for configuring linked records:

e You need at least one document object and one record object.

e You can link a document object to only a single record object.

e You can link multiple document objects to a single record object.

For SOLIDWORKS PDM Document objects, you access the configuration through a page

in the wizard. For standard document objects, a new tab appears at the end of the existing
tabs.

Steps to configure:

1. Select a linked record object.
2. Optional: Define the field mapping.

3. Optional: Define the document record's related files or references to link to the linked
record.

4. Optional: Map the BOM variants between the document object and linked record
object.

5. Optional: Map the field groups to the linked record object.
6. Specify the numbering scheme.

You can also configure a standard document object.

Selecting a Linked Record Object

To select a linked record object:

1. In the SOLIDWORKS PDM Configuration Wizard, under Linked Record Object, click
Configure.
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2. In the Link Record Object wizard, on the Linked Record Object page, under Linked
Record Object, select an object.

3. Under Initial Record Status, select a lifecycle status, which is mandatory for newly
created records.

Defining the Field Mapping
You can use the Fields Mapping page to define the mapping of fields between a document
objects and the linked record objects.
To define the field mapping:

1. In the Fields Mapping page, click the cell in the second column that corresponds to
the document object's field in the first column.

2. Click the cell in the third column and select an update method:

Option Description

Blank Makes no update.

Default if empty Uses the default value if the document
object field is empty.

Always Always uses the value from the document
object field even if it is empty.

3. Optional: Select other available options, as required:

Option Description

Auto Map Searches for identical names in the
document and record objects and
automatically selects the matching record

object field.

Update Always Sets the update method of all the rows to
Always.

Use Default if empty Sets the update method of all the rows to

Use Default if empty.

o The field types of the document object and the record object must be compatible.

e If you change a field value in the document record after you initially create the
linked record, the application does not automatically reflect the updates. Do the
updates manually.
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Defining Related and Reference File Mapping

In the Related and Reference Files mapping page, you can define the document record’s
related files or references that you can link to the linked record.

You can define this mapping only once when you create a linked record from the document
record. If you make subsequent changes to the Related Files or References, the
document record does not automatically update.

Do not copy the primary file from the document record. This creates a copy
of the file, which is not updated, in the linked record.

To define related or reference file mapping:

Under Related Files or Reference Files, click the cell in the second column that
corresponds to the document object's folder in the first column.

BOM Mapping Options
The BOM Mapping Options page maps the BOM variants between the document object
and the linked record object.

You can copy the contents of the primary file's BOM variants to the linked records BOM
variants. The field names can be different but the field types must be similar.

Copying BOM Variants

To copy BOM variants:

1. Click the cell in the second column next to the document object’s BOM variant in the
first column.

2. Select the linked record object’'s BOM variant to receive the data.

Selecting the Custom BOM Field Name

You can select the custom BOM field name for a linked record object.
To select the custom BOM field name:

1. On the left side of the page, select the BOM variant.

2. On the right side of the page, click the cell in the second column next to the document
object’s custom field name.

Mapping the Field Groups to the Linked Record Object
You can use the Field Group options page to map the Field Groups from the document
object to the linked record object.

To map the field groups to the linked record object:

Click the cell in the second column that corresponds to the document object's field group
in the first column.
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Numbering Scheme Options

Below are options for the part number assigned to a new linked object record created

from a document record.

For new records that you create in the linked object without a primary reference, use the

numbering scheme defined for that object.

Numbering Scheme Option

Description

Create New Record Number

Uses the numbering scheme defined for the
record object and does not use any value
from the document object record.

Use Document Number

Uses a part number from the document
object record and has secondary options for
replacing existing strings with predefined
strings.

Combine Numbering Schemes

Combines the part humber from the
document object record and the numbering
scheme from the linked record object.
Secondary options specify which number
comes first in the value and whether a
delimiter between the values is required.

Creating Linked Records

You can create linked records directly from the document record or create them
independently, and link them to a document record.

Creating Single Linked Records

To create single linked records:

1. Click the main grid of a document object that has been configured for linked records.
2. Right-click a record and click Records > Create Linked Records.

The application creates a new linked record in the linked record object.

The linked record number appears in the Linked Records column. This is an object
type field and allows you to double-click the value to access the linked record’s
property card. When you view the linked record object, the Primary Reference
column displays the primary reference as an object type field.

Creating Linked Records from the Wizard

To create linked records from the wizard:

1. Click the main grid of a document object that has been configured for linked records.
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2. Right-click a record and click Records > Create Linked Records with Wizard.

The Create Linked Record wizard appears and provides additional options for creating
linked records.

The linked record number appears in the Linked Records column. This is an object
type field. You can double-click the value to access the linked record’s property card.
When you view the linked record object, the Primary Reference column displays
the primary reference as an object type field.

The Create Link Records page displays the selected document object record and any
children from the selected BOM variant.

3. Optional: Select a row on the left side of the page to display the field values to use
for the linked record on the right side.

If a linked record already exists for a document object, its part number appears in
the Linked Records column.

4. Make all required selections, and enter the inputs.
5. Click Create Linked Record(s).

The linked records are created. Closing the wizard does not delete the records.

The status of each linked record appears in the Status column. For the successfully
created records, the status is Done. For any failures, the status is Failed.

Creating BOM Structures of Linked Records

The Create BOM structures of Linked Records page lets you create a BOM that consists
of the newly created linked records.

To create BOM structures of linked records:

1. On the left side of the page, select a record.
2. Click Create BOMs.

3. Optional: To see the records in the BOM variant on the right side of the page, reselect
the record on the left side.

4. Optional: To edit the BOM variants of the linked record, click Edit.
The editing tools appear in the context menu.

Creating Linked Records Through a Process Output

This method creates the linked record for document objects attached to the process and
uses the automated creation method. If an attached document record does not have a
linked record object configured, no record is created but the process continues.

Primary References

Using the create record first method, you can create the linked record and attach a primary
file as a reference later.

This method lets you build a product structure using a top-down approach and does not
require files. Some records may never have a primary reference.
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Adding a Document Record as a Primary Reference

You can add a document record as a primary reference to an existing record using the
standard process.

To add a document record as a primary reference:

1. Right-click a record and click Add Reference.

2. Right-click the reference and click Set/Remove as Primary Reference to set or
remove a document record as the primary reference.

Primary references appear in bold and the Primary column displays Yes.

List of Recent Documents

The My Dashboard and Shortcuts panel on the right window pane list recently accessed
documents.

Manual Quantity Synchronization

The manual quantity column is synchronized with SOLIDWORKS PDM BOM manual edits.
Enhancements include:

e Bidirectional update of manual quantities from SOLIDWORKS PDM computed BOMs
e Additional synchronization abilities for:

e Single or selected line items
e Single or selected line items with children

e Improved highlights:

¢ Yellow background indicates edits made before saving the BOM
e Orange background indicates manual edits
¢ Bold text indicates that the manual edits match the actual value

Object Type Hyperlinks

You can select a particular record to view its details from the multiple values in an object
type field.

Double-click an object type field with multiple values to display the Linked Records dialog
box, and then select the records to open.
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Performance Improvement in Synchronization

Performance is improved when you synchronize SOLIDWORKS PDM objects with a large
number of files and folders. The Synchronization details dialog box displays the
synchronization steps.

To open the Synchronization details dialog box:

1. Edit a SOLIDWORKS PDM object.

2. In the dialog box, navigate to the Connection page.
3. Select Show synchronization steps.

4. Click OK.

Rich Text in Memo Fields

The Memo field types are more flexible and can save rich text into a field value. This lets
you display content such as images and formatted text.

Enabling a Memo Field to Save Rich Text

To enable a memo field to save rich text:

1. In the Administration tool, edit the field.
2. In the Options tab, select Use Rich Text Format.

When you switch from rich text to plain text, the application deletes the images or
text formatting.

Adding Rich Text to an Enabled Memo Field

To add rich text to an enabled memo field:

1. Check out and open a file.

2. Copy an image file or rich text from the file system and paste it into the memo field.
You can also copy the image from a word-processing program.

Right-click in the memo field to access text formatting tools.

SOLIDWORKS PDM Records in Where Used
Tab

In the Microsoft® Windows® Explorer view of SOLIDWORKS Manage, in the Where Used
tab, you can view SOLIDWORKS PDM records that are attached as deliverables to a
project.
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Splitting an Auto Number

You can split auto numbers and add a delimiter if required. Splitting changes only what
the users see. The number in the system remains unchanged.

To split an auto number:

1. Open the Administration tool and select Advanced.
2. Select Numbering schemes.
3. Do one of the following:

e Create a new numbering scheme and add an auto number.
e Edit an existing numbering scheme.

Edit the auto number.
Select Split AutoNumber.
Click Configure.

Click & and enter the delimiter in the first column.
Enter the position of the split from the left of the auto number.
Optional: Add additional splits.

When you change an existing nhumbering scheme, the change applies to new records
only. The existing records remain unchanged.

© XN U0k

Disabling Auto Increment on Copy From

When you create a new record from an existing one using the Copy From option, you
can disable the Auto Number increment when you use another field. This makes the
part number unique.

To disable auto increment on copy from:

Open the Administration tool.

On the Structures pane, select Documents and Records.

Edit the object.

In the Fields section of the object, select the Field Groups.

Edit an existing field group or create a new one.

In the Other Options tab, select Do not increment AutoNumber by default.
Click Save and Close.

NouhkwbhH=

Splitting Projects into Stages

You can split the stages of a project to add nonworking time. This can provide a better
view of the amount of work required to complete a stage, the start date, and the
completion date.

For example, a stage requires 40 hours of work to complete and has a two-week gap
when work will not be done. You can split the stage into two 20-hour sections with an
80-hour (two-week) split. Without a split, this stage would cover 3 weeks, and would
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appear to have a completion percentage of 17% if 20 hours of work was completed. With
the split, the completion percentage would be 50%.

To split projects into stages:

1. Open and check out a project or create a new project.
2. In the Planning tab, select a stage where you want to insert the split.
3. Do one of the following:

e Right-click the stage and select Split Stage.
¢ In the Move/Indent section, on the toolbar, select Split Stage.

4. In the Split Stage dialog box, click & and enter a value (in hours) in the Position
column from where the stage begins to split.

5. Enter the duration of the split in the Length column.
Click Apply.

Optional: Click & to insert multiple splits or click & to remove the splits.

Support for Internal Components

SOLIDWORKS Manage recognizes internal components that are saved in SOLIDWORKS
assemblies and checked into a SOLIDWORKS PDM object. These components appear in
the BOM views.

Thumbnail Images of SOLIDWORKS PDM Files

Thumbnail images of SOLIDWORKS PDM files are available in SOLIDWORKS Manage, for
example, in the main grid and in BOM views. The application creates these images on
check-in from SOLIDWORKS.

SOLIDWORKS Manage creates configuration-specific thumbnails for configurations that
you activate during the SOLIDWORKS session and are stored as active records.

Updating SOLIDWORKS PDM Variables

You can update SOLIDWORKS PDM data card variables with field values from SOLIDWORKS
Manage. The field types in SOLIDWORKS Manage can drive data into SOLIDWORKS PDM.

To update SOLIDWORKS PDM variables:

1. In the SOLIDWORKS Manage Administration tool, navigate to the Fields Page.
2. Select a variable and click Edit.
3. In the Field Properties - ‘Description’ dialog box, in the Field Type tab:

a) Select Updates PDM Variable.

b) Select the Field Type and define the parameters.

The SOLIDWORKS Manage field type and SOLIDWORKS PDM variable must be
compatible data types.

¢) Click Finish.
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This chapter includes the following topics:

e 3D PDF Files

e CommandManager Tab Renamed

e Copying DimXpert Schemes Across Documents
e Display of Cosmetic Threads and Weld Beads

e Displaying General Tolerances

e Support for Sheet Metal in MBD

e Text Size in 3D Views

SOLIDWORKS MBD is available as a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

3D PDF Files

Publishing to 3D PDF Files

Updates to the user interface for Publish to 3D PDF help you to better visualize the
impact that your selections have on the final output.

The new Template Selection dialog box provides large previews of available templates,
including previews of each page of multipage templates.
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After you select a template, as you make selections in the PropertyManager, a large
preview of the PDF document lets you see the effects of your selections.
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A

Adding Security for 3D PDF Files

In SOLIDWORKS MBD, when you publish 3D PDF files you can secure your data.
You can:

e Specify a password and a master password.

e Disable printing, editing, and copying.

e Publish only the graphical data.

To specify security options:

1. Click Publish to 3D PDF 2 (MBD toolbar).

2. Near the top of the PropertyManager, click Security Settings EE
3. Specify options in the dialog box, and then click OK.

Option to Edit 3D PDF Templates

You can set an option to edit the templates that you use when you create 3D PDF files
for MBD.

To set this option, click Tools > Options > System Options > MBD and select Allow
editing of templates for 3D PDF files.
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CommandManager Tab Renamed

The SOLIDWORKS MBD CommandManager and toolbars in parts and assembly documents
are now named MBD. The name of the product is still SOLIDWORKS MBD.

Copying DimXpert Schemes Across Documents

In SOLIDWORKS MBD, you can copy DimXpert schemes from one document to another.

1. Open the target document and select the configuration to which you want to copy
the DimXpert scheme.

The selected configuration must not have an existing DimXpert scheme.

2. Click Import Scheme B (MBD toolbar).

3. In the dialog box, select a similar document and a configuration that contains the
DimXpert scheme to copy.

4. Click Open.

The DimXpert annotations are copied from the selected document to the open
document.

Display of Cosmetic Threads and Weld Beads

When you publish to 3D PDF files, shaded cosmetic threads and shaded weld beads display
correctly.
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1| Cosmetic thread, partial depth

2 | Cosmetic thread, through all

3| Weld bead

Displaying General Tolerances

When you use a general tolerance, you can display a symmetrical tolerance within the
dimension text.

The displayed tolerance is based on the tolerance class specified in parts and assemblies,
in Tools > Options > Document Properties > DimXpert, under General tolerance.

To display general tolerances:

W

1. Click Location Dimension % or Size Dimension o] (MBD Dimension toolbar).

2. In the PropertyManager, under Tolerance/Precision, for Tolerance Type, select
General with tolerance.

Support for Sheet Metal in MBD

SOLIDWORKS MBD supports sheet metal bend notes, bend tables, bend lines, and
bounding box lines.

Bend Notes
You can add and edit bend notes in the flat pattern of a sheet metal part.

In the FeatureManager® design tree, right-click the Flat-Pattern < feature and click one
of these:

o Insert bend notes
¢ Reinsert bend notes

Bend Tables

You can add bend tables for a flat pattern of a sheet metal part.

Click Bend Table % (Table toolbar) or Insert > Tables > Bend Table.

The bend table is created and tags are placed on the bend lines of the sheet metal flat
pattern to identify their bend specifications.

Bend and Bounding Box Lines

In the Sheet Metal MBD section of the Document Properties dialog box, you can specify
the color and line type for various sheet metal items.
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Click Tools > Options > Document Properties > Sheet Metal MBD.
You can specify the color and line type for:

¢ Bend lines
e Bounding box lines
e Sheet metal sketch entities

Text Size in 3D Views

You can control the text size in 3D Views.

In Tools > Options > Document Properties > Detailing, these properties are now
supported:

Always display text at the Displays all annotations and dimensions at the same
same size size, regardless of zoom.

Text scale Specifies the scale for the default size of annotation
text. If you specify Text scale in a 3D View, the text
size applies to the 3D View in published 3D PDF files.
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This chapter includes the following topics:

e Animation Output File Types

e Model Display Performance Improvements

e Rendering Performance Improvements

e Transforming Textural Appearances with the 3D Texture Tool

Animation Output File Types

You can save animation outputs to new file formats.

New Animation Output Formats Notes

.tiff, .png, Or .jpg For still images, you create in the
MotionManager.

¢ Microsoft AVI file (*.avi) For MotionManager Timeline > Save
e MP4 Video File (*.mp4) Animation.
* Flash Video File (*.flv)
e Matroska Video File (*.mkv)
o Series of JPEG (*.jpg)
e Series of Windows Bitmaps (*.bmp)
e Series of Truevision Targas (*.tga)
e Series of Portable Network Graphics
(*.png)
e Series of Tagged Image File Format
(*.tiff)
¢ Luxology Scene (*.1x0)

You can select SOLIDWORKS screen or PhotoView 360 as the renderer while saving
the output file formats.
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Model Display Performance Improvements

Render Pipeline

SOLIDWORKS 2019 uses a new graphics architecture for parts and assemblies. This
architecture provides a more responsive, real-time display especially for large models. It
takes advantage of modern OpenGL (4.5) and hardware-accelerated rendering to maintain
a high level of detail and frame rate when you pan, zoom, or rotate large models. These
performance improvements scale up with the higher-end graphics cards not fully supported
in previous versions of SOLIDWORKS. These changes do not apply to drawings.

To turn on the new architecture in SOLIDWORKS 2019, select Tools > Options > System
Options > Performance and select Enable graphics performance (Beta feature,
requires SOLIDWORKS restart).

Rendering Performance Improvements

Rendering performance is improved because the adaptive sampling value for lower-quality
settings (Good, Better, Best) has been modified.

Transforming Textural Appearances with the 3D
Texture Tool

The 3D Texture < tool transforms textural appearances on parts into geometry. You
can use the resulting graphics body for manufacturing, especially 3D printing, or you can
manipulate the geometry further by converting it into a mesh BREP body.

Unless a part already has a textural appearance, the process has two steps. First, you
map a textural appearance to a model using texture mapping functionality. Second, you

use the 3D Texture = tool to define the geometry for the textural appearance and
create the 3D Texture feature.

In this example, you start with a sample model of a spray gun. You apply a textural
appearance to the spray gun's handle, map the textural appearance for fit, then use the

3D Texture = tool to create and configure grip bumps on the handle. You can then 3D
print the model with the bumps.

Applying a Textural Appearance
A model must have a textural appearance applied to it before you can create 3D Texture
features.

You can use any type of image or mapped textural appearance to create 3D Texture
features. Grayscale heightmap images are preferred. You cannot use decals to create 3D
Texture features.

To apply a textural appearance:
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1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\model display\spray gun.sldprt.

2. In the DisplayManager 9, click View Appearances Q.

3. On the View Appearance tab, drag grayscale. jpg from
system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\model display onto the handle's face.

4. Under Sort order, right-click grayscale.jpg and click Edit Appearance.

5. In the PropertyManager, click Advanced.
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6. On the Mapping tab, specify the options for Mapping and Size/Orientation to adjust
the fit of the appearance and click ¥ .

Try to fit the textural appearance so all the circles are within the handle boundary
and do not intersect the surrounding edge. You do this to create a closed, watertight
model that you can 3D print.

These are the approximate values to use:

Mapping type Projection
= Horizontal location 0.01640001mm
Vertical location 0.13710199%mm
Fixed aspect ratio Selected
ﬁ Width 10.15549321mm
IO Height 10.15549321mm
Yo Rotation 12.00deg

Creating 3D Textures

After you add a textural appearance to the model, you use the 3D Texture tool to
transform the textural appearance into grip bumps. You can then manufacture the model
and bumps with a 3D printer or other manufacturing methods.

To create 3D textures:

1. Makes sure you opened system dir:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS 2019\samples\whatsnew\model
display\spray gun.sldprt and that you applied the textural appearance.
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2.

In the FeatureManager® design tree, in the Solid Bodies folder, right-click
Imported1 ﬁ and click 3D Texture <.

In the 3D Texture PropertyManager, under Body to texturize, Imported1 appears.
You can apply 3D Texture features to only one body at a time. The entire body
displays as a mesh. The textural appearance mesh displays its initial shape.

Under Texture Settings, note the default values for Refinement and Distance.

Clear Dynamic Help, which are expanded tooltips.

Under Texture Settings, in the table, select grayscale.jpg in the first row for
Texture.

Convert this texture to 3D and White up Black down are selected.

Clear White up Black down to use the black colors from the appearance to create
the maximum offset distance of the 3D texture feature.

The icon in the table changes to v, indicating that black is up. Specify this option
based on the grayscale heightmap you use and the displayed results.

Move the slider for Texture Offset Distance so the Distance value in the table is
approximately 12mm.

This value controls the maximum offset distance for the 3D texture from the body.
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7. Move the slider for Maximum Element Size so the value is approximately 6.10mm.

The 3D texture becomes more defined.

This value controls the maximum element size for the entire mesh.

8. Move the slider for Texture Refinement so the Refinement value is approximately
0.14.

This value controls the local mesh refinement in the area of the 3D texturized
feature. Refinement adds facets to better match contours within the grayscale
image. When you increase this value, the model display quality increases but the
processing time increases too.

9. The height seems too tall, so move the Texture Offset Distance slider to the left
to reduce the Distance value to 6mm.

The 3D texture mesh becomes smoother.

10. Click ¥

Recommendation: Because the 3D Texture feature converts the body to a graphics
body, you should add the 3D Texture feature as the last feature in your part.

The 3D Texture & feature with a graphics body appears in the FeatureManager

design tree. In the Graphic Bodies folder, Graphic (Closed) % indicates that
the generated model is watertight and that you can 3D print it.
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You can then convert the graphics body into a mesh BREP body to use for manufacturing
purposes. Select the graphics body and click Insert > Features > Convert to Mesh

Body By,
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Parts and Features

This chapter includes the following topics:

e Bounding Boxes

e Cosmetic Threads Improvements

e Creating Partial Chamfers and Fillets

e Deleting Holes from Surfaces

e FeatureWorks Maintains References in Drawing Views
e Inserting a Part with a Specific Configuration

e Mesh BREP Bodies

e Specifying Tolerances for Hole Wizard Holes

e Thumbnail Preview for Blocks in Design Library

e Using Interference Detection for Multibody Parts

Bounding Boxes

Performance is improved when you use bounding boxes. When you suppress or hide the
Bounding Box feature, it does not rebuild.

Cosmetic Threads Improvements

Many issues have been resolved related to how cosmetic threads are created, updated,
and displayed when there are child references in downstream features.

The cosmetic threads feature has a more robust architecture so that they behave more
consistently. The improved behavior provides more stable references for edges and faces,
along with correct parameters for assemblies, drawings, and graphics. Improvements
include support for tapered threads, mirrored and patterned geometry, better mapping
to nonplanar surfaces, and standards for tapered shafts.

For example::

¢ When you use the Split Line tool to split a face where shaded cosmetic threads display,
then rebuild the part, the shaded cosmetic threads and diameter are retained at the
correct location.

e Cosmetic threads created from instances of pattern and mirror features display correctly
when you hide and show model geometry.

e Cosmetic threads in derived and mirrored parts display in the correct position when
you create derived parts using the Mirror Part, Insert Part, Saved Body, and Split
Body tools.
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e Cosmetic threads behave as expected when you copy bodies using the Move Body
and Copy Body tools.

¢ You have more control when you add features such as chamfers on edges and cosmetic
threads are selected, and when you use Hole Wizard to create a hole with cosmetic
threads on a reference plane. Also, when you suppress a hole with Hole Wizard, child
cosmetic threads are suppressed.

e When you use a design table to assign different values for thread length to each
configuration, cosmetic threads update accordingly.

Enhancements include:

e Standards for tapered shafts and holes are supported in cosmetic threads. Also, thread
classes are supported when you create cosmetic threads using Insert > Annotation
> Cosmetic Threads.

e You can input an equation to configure the major or minor diameter of cosmetic threads
directly in the Cosmetic Thread PropertyManager.

Upgrading Legacy Cosmetic Threads

For a part, assembly or drawing that uses legacy cosmetic threads, you must upgrade
the model to use the improved cosmetic threads feature. The upgrade requires you to
set a system option first, and then you can enable the upgrade for each model.

You can upgrade all cosmetic threads features that are available in components for the
top-level assembly and the subassembly.

If you have many files to upgrade, you can use an API method to convert the files
(IModelDocExtension: :UpgradeLegacyCThreads). For information, see the
SOLIDWORKS API Help. You can also contact SOLIDWORKS Technical Support.

When you upgrade a legacy part, you may need to adjust the assemblies and drawings
where the part is used. For example, drawings might have dangling annotations and
dimensions.

To upgrade legacy cosmetic threads in a part, assembly, or drawing:

1. In Tools > Options > System Options > General, select Allow cosmetic threads
for upgrade and click OK.

If you are an administrator, you can use the Settings Administrator Tool to propagate
this option among your users.

2. Open the model and right-click the top item in the FeatureManager design tree, and
click Upgrade cosmetic thread features.

After you upgrade, the command, Upgrade cosmetic thread features, is no longer
available for that model.

Creating Partial Chamfers and Fillets

You can create partial chamfers and fillets with specified lengths along model edges.

The Manual tab of the Fillet PropertyManager and the Chamfer PropertyManager contains
a group box where you can specify Partial Edge Parameters. When you select an edge
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in Items To Fillet or Items To Chamfer, expand Partial Edge Parameters to define
the start and end position of the partial feature.

This enhancement is available only for constant size fillets and offset face chamfers.
To create partial chamfers:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\chamfer.sldprt.

2. Click Chamfer @ (Features toolbar) or Insert > Features > Chamfer.
3. Right-click the edge shown and click Select Tangency.

4. In the PropertyManager:

a) Under Chamfer Type, click Offset Face
b) Select Full preview.

c) Select Partial Edge Parameters.

d) In Start condition, select Distance offset.

e) Set Offset distance from start point to 20mm.
f) In End condition, select Distance offset.

5. Drag the handles approximately as shown.

Distance:
i

137



Parts and Features

6. Click ¥ .

Deleting Holes from Surfaces

You can delete holes more easily from surface bodies with the Delete Hole tool.
To access the tool, do one of the following:

¢ Click Insert > Surface > Delete Hole .

e In the graphics area, select an edge of a surface hole, right-click, and click Delete
Hole.

The Delete Hole PropertyManager lists all the edges you select in the Selections box.

Delete Hole does not support mesh BREP bodies.

Previously, you could only delete a surface hole by pressing Delete.

FeatureWorks Maintains References in Drawing
Views

In SOLIDWORKS drawings of imported parts, references are maintained when you change
an imported part and FeatureWorks® is enabled.

References are maintained in the following views:

e Model

e Section

e Detail

¢ Broken-out Section
e Break
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Inserting a Part with a Specific Configuration

The Insert Part &° tool lets you insert a specific configuration of the part. This workflow
is the same as when you insert a component into an assembly.

To specify a configuration when inserting a part:

1. In any part, click Insert Part (Features toolbar) or Insert > Part B
2. In the Open dialog box:

a) Select the file to insert.

b) Select a configuration of the base part.

c) Click Open.

3. In the Insert Part PropertyManager, under Part to Insert, click Browse to select
another part.

Part to Insert L

Open documents:

Configuration:

Default ~

Browse..,

Click ™ to pin the PropertyManager to insert multiple parts without reopening the
PropertyManager.

When you edit a part, the Edit Feature PropertyManager displays the file path and
configurations of the part.

Mesh BREP Bodies

More Tools for Preparing Meshes

Mesh files can help you in solid or surface modeling to create sketches or visual references.
This release provides more tools to help you prepare and modify mesh files for such cases.

You can access these tools from the Mesh Modeling tab in the CommandManager. The
Mesh Modeling tab contains mesh features and standard features that work with mesh
BREP bodies.
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For example, you can use the Paint Select tool to select facets. Then to remove facets,

press Delete or use the Cut with Surface B tool. The software retessellates the graphics
body at the cut boundary.

You can also change the entire size of a graphics body by using the Scale & tool.

When you use the Cut With Surface or Scale tool on a graphics body, the software

does not add a feature to the FeatureManager® design tree. This is because these tools
modify the original mesh. If you have not saved the graphics body, you can undo the
changes but not edit them.

Segment Imported Mesh Body Tool

You can use the Segment Imported Mesh Body tool to group facets of a mesh BREP
body into faces bounded by sharp corners, planar faces, and cylindrical faces.

The Segment Imported Mesh Body ® tool identifies:

e Groups of facets that form planar or cylindrical faces.
e Faces that are separated by a sharp angle or crease angle.

¢ Planar faces in a mesh BREP body so that you can use them as sketch planes, extrude
references, and in other models with planar references.

This tool is most useful for CAD files that you export to mesh and then import into the
SOLIDWORKS software and convert to mesh BREP bodies. Although the tool can work
with scanned files and bodies with mesh-based sculpting and artistic geometry, these
often have very irregular geometry that the software cannot segment.

When you import a mesh file and convert it into a mesh BREP body, each body is
represented by a single face. The facets are not grouped or segmented into groups of
facets that form faces.

Converting a mesh body to mesh BREP is not like converting standard SOLIDWORKS
BREP to mesh BREP, where face definition in the standard SOLIDWORKS BREP is preserved
in the mesh BREP.

In the example that follows you set system options and import a mesh .STL file. Then
you divide the mesh BREP body into crease angle, planar, and cylindrical segments.
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Options for Importing and Viewing Meshes

1. Before you import this mesh file, specify these system options in Tools > Options

> Import:
a) For File Format, select STL/OBlJ/OFF/PLY/PLY2 and click Import as Solid
Body.

b) For Mesh body options, click Create mesh bodies bounded by single faces
and for Unit, select Centimeters.

c) Click OK.

2. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\segmentmesh.STL.

3. In the Heads-Up View toolbar:

e For Apply Scene ﬁ, click Plain White.
e For Display Style &], click Shaded With Edges B.

e For View Orientation @, click Isometric ﬁ.

These options help you to better visualize the previews. Now the facet lines in the mesh
are visible.

Next, you start segmenting for crease angles.

Grouping Crease Angle Segments

1. Inthe FeatureManager tree, right-click Imported1 and click Segmented Imported
Mesh Body B

2. Click Pin ™ at the top of the PropertyManager.

Dynamic Help displays pop-up tooltips when you move the pointer over controls.
Clear it if you do not want to display detailed help.

3. In Segmenting, click Crease Angle @ and select Bodies ﬁ In the graphics area,
select the mesh BREP body.

Imported1 displays in the selection box.
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4. Click Show Preview.

5. For Crease Angle Tolerance, move the slider to 76 degrees. Then lower the tolerance
to 30 and even lower to 6 degrees.

As you decrease the tolerance, the preview detects more angular faces on the top of
the mesh model. If you decrease the tolerance too far, the software detects the facets
on the cylinders that are located at the bottom of the model.

Enter 30 to reset the Crease Angle Tolerance.

Y 4
2

6. Click ¥.

Next, you group planar and cylindrical segments.

Planar faces on the sides and bottom of the mesh BREP body are not detected when
you segment crease angles, because the faces are filleted and have no sharp angles.

Grouping Planar and Cylindrical Segments

1. In Segmenting, click Planar Segments and Select Body .
2. In the graphics area, select the mesh BREP body.

Segment Mesh1l displays in the selection box.

3. Click Show Preview.
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4. For Tolerance, type 6 and click Recognize Planar Faces.

Click ¥ .

In Segmenting, click Cylindrical Segments and Select Body .
In the graphics area, select the mesh BREP body again.
For Tolerance, type 20.

N WU

Rotate the model to view the cylindrical segments more clearly.

9. Click ™ to unpin the PropertyManager and click ¥ .

The FeatureManager design tree lists the angular, planar, and cylindrical segments
respectively as Segment Mesh1, Segment Mesh2, and Segment Mesh3. You can
modify the segments by right-clicking any of the features in the FeatureManager design

tree and select Edit Feature ﬁ.

Specifying Tolerances for Hole Wizard Holes

You can set values for tolerance and precision when creating Hole Wizard features.

The Type tab in the Hole Wizard PropertyManager includes Tolerance/Precision.
Depending on the hole type, the PropertyManager displays options for tolerances that

143



Parts and Features

apply to the hole specification. This section is also available for Hole Wizard features in
assemblies.

Tolerance values automatically propagate to hole callouts in drawings. If you change
values in the hole callout, the values update in the part. You can also vary tolerance
values for configurations.

Previously, you could only add parameters for tolerance and precision to Hole Wizard
holes by manually modifying hole callouts in drawings.

To specify tolerances for Hole Wizard holes:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\tolerance.sldprt.

2. In the FeatureManager design tree, right-click CBORE and click Edit Feature.

In the PropertyManager, on the Type tab, expand Tolerance/Precision.

4. Under Tolerance/Precision, in Callout Value, select Thru Hole Diameter.
a) For Tolerance Type, select Bilateral.

b) For Maximum Variation, type 0.05mm.
c¢) For Minimum Variation, type -0.02mm.

w

5. Under Tolerance/Precision, in Callout Value, select CounterBore Diameter.
a) For Tolerance Type, select Symmetric.
b) For Maximum Variation, type 0.05mm.
c) For Unit Precision, select .12 (Document).

6. Click ¥ .

If you make a drawing from the part, the tolerance values display in the hole callout.

+0.05
7% -002 THRU ALL

@
LI 11 914005 F 3.58
o @ 706 W P0%, Far Side
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Thumbnail Preview for Blocks in Design Library

When you open the Design Library, blocks appear as thumbnail images. Previously, all
blocks had the same icon. Previews only appeared if you hovered over the icon.

NS

check valve  check valve check vakve check vabee
pilot opera... pilct cpera...
N A7
flow control  flow control flow contral  flow control
vahve fixed.. valve fixed... wabve fooed...  valve ficed...
SOLIDWORKS 2019 SOLIDWORKS 2018

These formats are supported:

e .sldnotestl e .dwg files

e .sldsffvt o .dxf files

e _.sldsfstl e .sldblk

e _sldsym e _sldnotefvt

e _.sldweldfvt e .sldgtolfvt

e .sldweldstl e .sldgtolstl
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Using Interference Detection for Multibody Parts

You can use interference detection between bodies in multibody parts. This is helpful
when checking that weldments are trimmed properly and before using Simulation tools.
To use interference detection for multibody parts:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\Main.sldprt.

2. Click Interference Detection 2] (Tools toolbar) or Tools > Evaluate >
Interference Detection.

In the PropertyManager, the Main.sldprt is listed under Selected Bodies.
3. In the PropertyManager, click in Excluded Bodies.
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4. 1In the flyout FeatureManager design tree, select RH %

RH G was inserted with the Insert Part tool. Interference Detection can check
or ignore parts and bodies that you inserted with the Insert Part tool. This saves
time if you inserted a part containing several bodies.

In this case, RH @ will be excluded from the calculation.

5. In the PropertyManager, under Options, select:

¢ Treat coincidence as interference. Includes bodies that share coincident faces
as interferences.

¢ Make interfering bodies transparent. Displays interfering bodies as transparent.
6. Under Selected Bodies, click Calculate.
Ten interferences are listed under Results with the interference value displayed.

Interfering bodies are transparent, and Interferencel 2] is highlighted in the graphics
area.
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7. Under Results:

a) Expand Interferencel % and click the first instance of Square tube to highlight
the interference body in the graphics area.

b) Double-click Interferencel % again to clear the Square tube selection and
collapse Interferencel T8,

c) Press SHIFT and click Interferencel % and Interference4 % to select all of
the interfering sections of bodies.

All of the interfering sections of bodies are highlighted.

8. Click .
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This chapter includes the following topics:

e Free PCB Viewer

e Mechanical Oriented Workflow

e PCB Connector/ECAD-MCAD Collaboration

e SOLIDWORKS PCB Miscellaneous Enhancements

SOLIDWORKS PCB is available as a separately purchased product.

Free PCB Viewer

SOLIDWORKS PCB Viewer 2019 is available from the SOLIDWORKS Customer Portal Free
CAD Tools download. This free viewer allows views and reviews of native SOLIDWORKS
PCB designs and projects for review and collaboration with all the members of your
electronics design team.

You cannot install the PCB Viewer on the same computer as SOLIDWORKS PCB.

Mechanical Oriented Workflow

SOLIDWORKS PCB includes enhancements to ECAD-MCAD collaboration that improve
mechanical-oriented workflow between mechanical designers and electrical engineers.

Features included in this release are:

e Support of component placement and height barriers from MCAD to ECAD. Mechanical
engineers can define and collaborate through PCB Connector any required PCB
placement constraints for the surface of the board and the height in the SOLIDWORKS
software.

e Support of component locking collaboration between ECAD and MCAD. Mechanical
engineers can collaborate through PCB Connector the "fixing" of ECAD components in
SOLIDWORKS to protect placement of critical components in the PCB design.
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PCB Connector/ECAD-MCAD Collaboration

ECAD-MCAD collaboration in SOLIDWORKS PCB and SOLIDWORKS PCB Connector includes
enhancements that improve mechanical designers' experience with creating and interacting
with ECAD data.

Board Thickness

There is accurate board thickness between ECAD and MCAD.
Board thickness matches the SOLIDWORKS PCB layer stack and a SOLIDWORKS assembly.

Copper Support

Copper is supported - traces, pads, and polygons — from ECAD to MCAD.
There are two options:

e Decal imagery for reference/visualization.
e Solid modeled copper for all layers.

.....

Flipping Components

You can flip components from MCAD to ECAD.

The SOLIDWORKS software automates the process of reversing an ECAD component on
the PCB assembly and changes its location from one surface of the board to the other.
Any surface (layer) changes for ECAD components are communicated/collaborated through
PCB Connector.

In SOLIDWORKS, right-click a component and click Flip Component.
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Multi-contour Hole Sketches

Multi-contour hole sketches are supported between ECAD and MCAD.

SOLIDWORKS ECAD-MCAD collaboration supports any type and method of hole creation
for use in PCB design. These methods include patterning, mirroring, Hole Wizard, and so

on.

Silkscreen, Solder Mask, and Solder Paste Support

PCB silkscreen, solder mask, and solder paste are supported as 3D CAD decal imagery
for reference and visualization from ECAD to MCAD.

SOLIDWORKS PCB Miscellaneous
Enhancements

Additional enhancements include:

e Redesigned Project Open dialog box in the SOLIDWORKS software features the ability
sort and search project lists.

e Added export of DXF/DWG files from SOLIDWORKS PCB layout.

e Documentation workflow capabilities for PCB design using SOLIDWORKS drawings.

e Improved ability to search ECAD parts in the SOLIDWORKS FeatureManager design
tree filter.
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This chapter includes the following topics:

e Changing Default License Type in SOLIDWORKS PDM Web2
e Conditional Notifications

e Default Search Variable in Search Cards

e Default Values Generation for New Sheets in Drawings

e Displaying History in SOLIDWORKS PDM Task Pane

e Editing History Comments

e File Shortcut Menu

e Getting Automatic Updates with Data Card Edits

e Graphics Device Interface Enhancements

e Integrated Installation of Web API Server

e Mixed Authentication Support

¢ Naming Files with Serial Numbers

e Opening a Parent File Without Referenced Files

e Opening Multiple SOLIDWORKS Files

e Performance Improvements - SOLIDWORKS PDM

e Responsive Redesign in Web2

e Selection of Referenced Drawing Nodes During Change State
e SOLIDWORKS Inspection Integration

e SOLIDWORKS PDM Support for Design Library

e Support for Configurations of Weldment Cut Lists

e Support for DXF/DWG File Format in Convert Task

e Support for eDrawings Functionality

e Upload and Check in File Structure and Download with References
e User Comments

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small humber of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased product.
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Changing Default License Type in SOLIDWORKS
PDM Web?2

In SOLIDWORKS PDM Web?2, if AllowLicenseChange is set to True, you can change the
license type to use either Web or Viewer license. If set to False, you can use only the
license type specified by the DefaultLicenseType setting.

DefaultLicenseType sets the default license type for all users on the login page of Web?2.
This lets you set the license type as Web or Viewer.

Conditional Notifications

In SOLIDWORKS PDM Professional, you can define conditional notifications for transitions.

With the Add Conditional Notification option, you can:

Add predefined conditions to send transition notifications to users and groups.
Send notifications dynamically to users based on the value of data card variables.

Defining Conditional Notifications

To define conditional notifications:

1.
2.

In the Administration tool, click a workflow transition.

In the transition's Properties dialog box, in the Notifications tab, click Add Conditional
Notification.

In the Conditional Notification dialog box, in the Recipients tab:

a)
b)

c)
d)

Click Add Users/Groups.

In the Add Users/Groups dialog box, select the users or groups to receive the
notification, and click OK.

Click Add Variable to select variables to use their values as notification recipients.
In the Add Variable dialog box, select the variables, and click OK.

In the Notification Conditions tab:

a)
b)

)

d)

Select <Click here to add a condition>.

In the conditions list, select a variable or a condition.

Under Comparison, expand the list and select a comparison operator.

The list of operators depends on the selection you made in the previous step.

Under Value, enter the value to compare with the variable value.

If you selected User or Group as Variable, select the value from the list.

If you selected a variable as the condition, specify the data card configuration to
search for the variable.

If you want to search for all configurations, leave Configuration blank.

Click OK twice and save the workflow.
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Conditional Naotification Dialog Box

You can use the Conditional Notification dialog box to define conditional notifications for
workflow transitions.

To display the Conditional Notification dialog box:

1. Open the transition's Properties dialog box.
2. In the Notifications tab, click Add Conditional Notification.

Notification Properties Tab

The Notification Properties tab displays the state fields of the transition. These fields are

read-only.

Source state Displays the initial state of the folder.

Destination state Displays the final state of the folder after transition.
State change Displays the transition used to trigger the state change.
Recipients Tab

Use the Recipients tab to define which users and groups receive notification when the
condition is met.

Add Users/Groups Opens the Add Users/Groups dialog box. You can select users
and groups to receive the notification.

Add Variable Opens the Add Variable dialog box. You can select variables to
use their values as notification recipients.

The value of selected variable is taken from the data card
and is compared with the full name, login name, or group
name value in the database vault.

You can filter the list to include only variables whose values
contain the filter string.

Remove Removes selected recipients.

Notification Conditions Tab

Use the Notification Conditions tab to create the conditions for users to receive automatic
notifications.
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conditions.

The conditional notifications apply on the vault root and all folders by default. To define
them for specific file types or file name, you need to define the file path-based

Variable

Lists the conditions and variables. You can select a variable or
one of the following:

Or

Creates an OR container. By default, all conditions must be true
(AND). Use OR containers to group conditions where only one
condition must be true.

Category
Compares the category of the file with the Value.

Filepath
Compares the file name, extension, or path with the input Value.

The file path replaces " *.* " in the folder path with the input
Value.

Object type
Compares the object type (BOM, File, or Item) with the Value.

Revision
Compares the revision humber of files with the Value.

User
Compares the name of the user who runs the transition with the
Value.

Group
Compares the group of the user who runs the transition with
the Value.

Remove
Removes the selected condition or variable.
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Comparison Lists the comparison operators for each condition.

Expand the list to choose a text, numeric, or date comparison
operator.

For example:

E Text Does Not E Date Not Equal To
Contain
Number Less Than E] Yes or No Equal To

The comparison operators that are available depend on the
variable type selected.

Value Lets you enter the value to compare with the value of the
variable.
Configuration Specifies the data card Configuration tab to search for the value.

This option is available only when the condition is a variable.

Leave Configuration blank to search for all configurations.

Default Search Variable in Search Cards

You can define a logged-in user name as the default value on search cards.

Previously, you had to define the logged-in user name as the default value using a search
favorite.

Configuring the Default Value in Search Card

You can configure the default value in search card to define the default search variable.

To configure the default value in search card:

1. Inthe Administration tool, expand Cards > Search Cards and double-click a search
card.

2. In Card Properties, click Default Values.

3. In the dialog box, select a variable and enter a value.

If you select a variable such as Checked Out by User, Label - by User, Version
Created by User, Workflow - Transitions by User, Author, enter the value as
Fusers.
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4. Click OK and save the changes to the Card Editor.

In the File Explorer, when you run the Search tool, the logged-in user name appears
as the default search value. For example, in step 3, if you select Checked Out by
User, the logged-in user name appears on the Checked in/out tab in the Search tool.

In the Administration tool, in the Settings - Admin dialog box, if you select Show full
user names and if the full name is available, it appears in the Search tool.

Default Values Generation for New Sheets in
Drawings

When you add new sheets to a checked-out SOLIDWORKS drawing file, SOLIDWORKS
PDM generates default values for the newly added sheets and updates the values in the
drawing data card.

Previously, you had to manually update the values of mandatory variables in the drawing
data card before check-in.

You must enable the SOLIDWORKS PDM add-in before adding the new sheets.

In the Administration tool, in the SOLIDWORKS Drawing Card, if you select Updates all
configurations, the variables that use the $PRPSHEET type variable mapping are updated
on the tabs for all sheets. Previously, only the values on the as-built (@) configuration

tab updated automatically and you had to manually update the active configuration tabs.

Displaying History in SOLIDWORKS PDM Task
Pane

In the SOLIDWORKS PDM Task Pane, the toolbar displays the History. From the History
dialog box, you can only:

e Save a version and specify a file name.

o Update (rename or delete) labels and modify comments for state changes and
check-ins.

¢ Print the history of the selected file.

Editing History Comments

You can edit your own history comments only if you have the administrative permission,
Can update history comments.

Previously, you could edit your own history comments without any permission.

Set/Delete Labels Permission

The administrative permission, Can set/delete labels, is separated into two permissions.
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Permission Description

Can set labels Lets users add labels.

Can delete labels Lets users delete any user's labels.

e A user cannot edit other user's labels.

e To make the history read-only for a user, the administrator must clear Can update
history comments and Can delete labels.

Deleting Labels

You can delete labels with the administrative permission, Can delete labels.
To delete labels:

1. Select the file or folder and click Display > History or History (Microsoft® Windows®
Explorer toolbar).

2. In the dialog box, under Event, select labels to delete.

3. Click Delete Labels.

4. Click Yes to confirm deletion.

File Shortcut Menu

The file shortcut menu for a user appears in the Where Used, Contains, and Bill of Materials
tabs.

You can more easily perform file operations on parent and child references, multiple
references, or references that are spread across different folders within the vault.

Previously, this menu was only available for Windows Explorer File View. To perform the
file operations in these tabs, you had to manually browse or search the files.

The file shortcut menu on the Contains, Where Used, and Bill Of Materials tabs is available
in the:

File Explorer

Complete Search and Search tool

SOLIDWORKS PDM File Viewer interface

Open and Save dialog boxes where access to these tabs exists.

You must have the required permissions to perform the file operations.

The file shortcut menu is:

¢ Available for computed BOMs, CAD BOMs, and checked-in named BOMs.
¢ Not available for checked-out named BOMs, weldment BOMs, and cut lists.
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Getting Automatic Updates with Data Card Edits

The SOLIDWORKS PDM Office add-in option Update Linked Fields lets you refresh linked
fields automatically when you update a value (custom property) via the data card or a
transition.

Graphics Device Interface Enhancements

SOLIDWORKS PDM works with increased stability.

The Graphics Device Interface (GDI) resource monitor monitors the performance of File
Explorer, File Viewer, Search processes, Item Explorer, and Card Editor. A warning
message appears when the available GDI resources are low or very low for any of the
above-mentioned processes.

To modify the predefined threshold values, in the registry setting,
HKEY CURRENT USER\Software\Solidworks\Applications\PDMWorks
Enterprise\Vaults\ -Global\Settings, change the values of the following variables:

e GDI _Warning_Threshold
e GDI _Danger_Threshold
e MonitorGDIFrequency(sec)

Integrated Installation of Web APl Server

EXALEAD® OnePart users can install and configure the Web API server during installation
of the SOLIDWORKS PDM Professional server.

Previously, you had to install the Web API server components separately.

EXALEAD OnePart uses Web APIs to access SOLIDWORKS PDM data. With the integrated
installation, you can:

e Install the Web API server
e Configure Microsoft Internet Information Services (IIS)
e Add and configure vaults

You can install the Web API server on the same computer with other SOLIDWORKS PDM
server components or separately on another computer.

Mixed Authentication Support

An administrator of a vault can set the option to allow users to log in as Microsoft Windows
users and SOLIDWORKS PDM users. Previously, the administrator had to select a single
login type for all vault users.

This lets you have a mix of login types per vault. The administrator can have users that
are not in the Microsoft Windows domain but need to connect to a vault.
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Authenticating Users with Mixed Logins

To authenticate users with mixed logins:

1.

iAW

Click Start > All Programs > SOLIDWORKS PDM > Archive Server
Configuration.

Click Default Settings % .

Select Windows login.

Select Allow SOLIDWORKS PDM login.

Click Apply and OK.

In the Administration tool, when adding a new user in the Add Users dialog box:

e The new option, New SOLIDWORKS PDM User, adds a SOLIDWORKS PDM user.

e The renamed option, New Windows User, adds a Microsoft Windows user.
e The renamed option, List Windows Users, lists the Microsoft Windows users.

Naming Files with Serial Numbers

The SOLIDWORKS PDM Add-in Options let you use serial numbers to name a new internal
or virtual component, or a weldment part.

To name the file with serial numbers:

1.
2.
3.

Start SOLIDWORKS.
Click Tools > SOLIDWORKS PDM > Options.

In the Server tab, select Automatically name new files with serial number and
Automatically name files on save as with serial number.

Opening a Parent File Without Referenced Files

You have the option to select to open the latest version of user-defined or large reference
trees while you open a parent non-CAD file.

To open a parent file without referenced files:

1.
2.

In the Administration tool, expand File Types and double-click a file type.

In the File Type Properties dialog box, select View file command does not need
referenced files.

SOLIDWORKS PDM does not cache reference files and the parent file opens faster.

Opening Multiple SOLIDWORKS Files

You can open multiple noncached files simultaneously with or without SOLIDWORKS
running.

For example, you can open multiple files in SOLIDWORKS via File > Open command, in
SOLIDWORKS PDM File Explorer, and in Contains tab.
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Performance Improvements - SOLIDWORKS
PDM

SOLIDWORKS PDM has improved performance of loads for large assemblies and complex
reference structures in the Contains and Where Used tabs.

You can more quickly complete operations such as moving, dragging, browsing, renaming
files, and adding a large number of files to a folder that has many files. You can also
check in assemblies with virtual components much faster.

Browsing speed has improved while working on integrated search results.

The elimination of unnecessary interface refreshes speeds up your browsing experience,
including folders with many locally cached files.

Responsive Redesign in Web2

The redesign of SOLIDWORKS PDM Web2 makes the website responsive to various device
sizes and browser window sizes. The user interface has improved controls plus enhanced
support for touch-enabled devices.

Enhancement Description

Responsive Log In The Log In screen resizes to fit your device and when you resize
screen the browser window.

Responsive and The file list and file properties also resize with your device. The
enhanced file list file list is a continuous scrolling list that lets users browse the

vault directory content. Previously, the file list was paginated
so users had to navigate through multiple pages.

Navigation bar The navigation bar lets you:
* Navigate to different folders in a vault using breadcrumbs.
e See the alerts with information on the top bar for file actions
such as Change State.

Action bar The Check Out, Undo Check Out, Delete, Change State,
and Download options are available on the action bar.

Choose column Select or clear the columns to appear in the file list. When you
add a column, its width adjusts automatically.

Resize and sort column Resize the columns on pages with a column view including the
Where Used and Contains tabs.

Upload and Check-In Drag and drop files to upload and check them in.

Search bar Designate the search location to Current Folder, Current &
Subfolders, or All Folders.
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Enhancement Description

File preview The file preview resizes to fit your device.

Selection of Referenced Drawing Nodes During
Change State

You can choose to select the referenced drawing nodes associated with a file when
changing the file state.

Previously, you could choose to select or clear all referenced files during the change state
operation. You could not specify just the referenced drawing nodes.

The new option, Select references that are defined as drawing nodes during change
state, is cleared by default.

To access this option:

1. In the Administration tool, right-click a user or group and click Settings.
2. In the left pane of the user's Settings dialog box, click Reference Dialog.

When you change the state of the parent file, the software performs as follows:

Option Description

Selected Referenced drawing nodes are selected (the check boxes in
the Change State column are selected) and are included in
the change state operation.

Cleared (default) Referenced drawing nodes are not selected and are excluded
from the change state operation.

If multiple files are selected for the change state operation, the option selects or clears
the check boxes for their referenced drawing nodes in the Change State column.

SOLIDWORKS Inspection Integration

SOLIDWORKS Inspection integrates with SOLIDWORKS PDM. The integration covers the
SOLIDWORKS Inspection add-in to SOLIDWORKS and the SOLIDWORKS Inspection
standalone application.

SOLIDWORKS Inspection standalone supports:
e Variable mapping for inspection project files
SOLIDWORKS PDM lets you map block attributes for the following properties:

e SWIPrjProperty defines mapping for Inspection Project Properties.
e SWICustomProperty defines mapping for Inspection Custom Properties.

The attribute names available for SWIPrjProperty for Project Properties are:
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e Part Name

e Part Number

e Part Revision

e Document Name

e Document Number
e Document Revision

File reference handling

SOLIDWORKS PDM creates references between the inspection project files (.ixprj)
and output deliverables (. x1sx, .pdf). In SOLIDWORKS PDM, the Contains tab displays
inspection project files as parent files and output deliverables as child references.

In the SOLIDWORKS Inspection add-in, references are created between a drawing
file and output deliverables files or between the inspection project file and output
files.

SOLIDWORKS PDM ribbon

SOLIDWORKS Inspection standalone includes the SOLIDWORKS PDM ribbon. You can
access SOLIDWORKS PDM features such as Check-Out, Check-In, Search, Get Version,
and Get Latest Version using the SOLIDWORKS PDM tab in the CommandManager.
This integration helps you manage and centralize the storage of inspection projects
plus the files and reports related to them.

SOLIDWORKS PDM Support for Design Library

The Design Library Task Pane lists the files that you have added to the SOLIDWORKS
PDM vault.

Caching of the files works correctly and you do not have to manage the local cache
manually.

Support for Configurations of Weldment Cut Lists

SOLIDWORKS PDM extracts and displays weldment cut list properties for all configurations.
Previously, you could view the cut list properties for the active configuration only.

You can view configurations of weldment cut list properties in:

Data cards of cut list items
Weldment BOMs
Weldment cut lists

This functionality is supported for parts that you create or save in SOLIDWORKS 2019
or later. You must also add Rebuild on Save Mark for all configurations.
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Support for DXF/DWG File Format in Convert
Task

The Convert task in SOLIDWORKS PDM Professional converts sheet metal flat patterns
to the DXF/DWG file format.

SOLIDWORKS 2018 or later supports the conversion.

Advanced Conversion Options (DWG Format/DXF Format)

You can use the Advanced Conversion Options dialog box to set options when exporting
sheet metal patterns to the DXF or the DWG file format.

To display the Advanced Conversion Options dialog box:

e When configuring a conversion task, on the Conversions Settings page of the Convert
- Properties dialog box, for Output file format, select DWG Format or DXF Format
and click Conversion Options.

¢ When initiating a conversion task, in the Convert dialog box, for Output file format,
select DWG Format or DXF Format and click Conversion Options.

The following options are applied when converting DXF/DWG format files:

Geometry Exports flat pattern geometry.

Hidden edges Includes hidden edges (only available if you select Geometry).

Library features Exports library features (only available if you select Geometry).

Forming tools Includes forming tools.

Bend lines Exports bend lines.

Sketches Includes sketches.

Bounding box Exports bounding boxes.

Multibody export options

Single file Converts all flat patterns into a single DXF/DWG format file.
Separate files Converts each flat pattern into a separate DXF/DWG format file.

The flat pattern name is a suffix on the primary output path.
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Enable Map File Enables the map file and lets you select the location of the map
file under Vault Root Folder Path. The file must be accessible on
the task host during the task execution.

Reset All Resets the options to defaults.

Support for eDrawings Functionality

SOLIDWORKS PDM supports the following eDrawings® functionality:

e Ambient occlusion
e Selection of configuration and sheet

Ambient Occlusion

SOLIDWORKS PDM supports ambient occlusion for the 3D file formats supported in
eDrawings.

To display the eDrawings toolbar on the Preview tab, on the SOLIDWORKS PDM menu
bar, click Display, and select Options > Show full UI in SOLIDWORKS preview. Click

. to see ambient occlusion applied to files.

To enable ambient occlusion in files, in eDrawings, click Tools > Options, and select
Fastest speed.

Selection of Configuration and Sheet

SOLIDWORKS PDM lets you select a configuration and sheet on the Preview tab.
In the Preview tab, on the eDrawings toolbar, you can select:

e Configurations from the Configurations list for the .EPRT, .EASM, .SLDPRT, and
.SLDASM files.

e Sheets from the list for the .EDRW, .SLDDRW, .DXF, and .DWG files.

Upload and Check in File Structure and Download
with References

The SOLIDWORKS PDM Web?2 client provides a faster and easier way to upload and
download files and folders with their references.

You can:

e Upload a folder and its contents including files and folders to a specific location.
e Download the files and folders with their references.
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Previously, to upload or download a file with its references, you had to perform the
operation for each file separately.

The supported browsers for Check In File Structure functionality are Google® Chrome,
Mozilla® Firefox, and Microsoft® Edge.

User Comments

SOLIDWORKS PDM lets you control mandatory comments with more granularity during
the check-in or change state operations.

With the improved control, the administrator mandates that users add the check-in or
state change comments for specific states and transitions in the workflow. These
mandatory comments create a reliable document history.

The enhanced permissions are: Must enter version comments for each state in workflow
and Must enter state change comments for each transition.

Scenario Must enter version Must enter state change
comments comments
Administrative permission is Enter comments during: Enter comments when you
selected and state or e Initial check-in. change the state of a file
transition permission is e Check in through Copy regardless of the transition.
selected or cleared. Tree and Branch
operations.

e Merge by using the option
Merge as new file for at
least one file in the
reference tree.

e Set Revision action when
Update Variable is
selected.

Administrative permission is Enter comments when you Enter comments when you

cleared and state or check in a file that is in a change the state of a file via
transition permission is specific state. a specific transition.
selected.
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This chapter includes the following topics:

Clear Study

Enhanced Cooling Channel Design
Geometry-based Boundary Conditions
Mesh Enhancements

SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics
Premium are available as separately purchased products that can be used with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Clear Study

You can use the Clear Study feature to reset a SOLIDWORKS Plastics study to its default
state.

To delete the features from an active Plastics study, do one of the following:

e Click CommandManager > Clear Study.
e In the PlasticsManager tree, right-click the top node and click Clear Study.

The Clear Study feature deletes all boundary conditions, mesh, material, process
parameters, and results associated with the active Plastics configuration.

Enhanced Cooling Channel Design

With the enhanced Cooling Channel creation algorithm, you can build complicated Cooling
Channels from the sketch lines with greater precision.

The new algorithm uses the defined Cooling Channel parameters and SOLIDWORKS APIs
to build accurate channel geometry. The new algorithm supports the creation of regular
cooling channels only. The software applies the algorithm used in 2018 and prior releases
for the design of baffles and bubblers.

The advanced settings for solid mesh for the Cooling Channel design generate a hexahedral
mesh across the whole cross section. This eliminates any convergence issues encountered
in previous releases associated with tetrahedral mesh of the Cooling Channel core. The
new meshing algorithm results in a slightly higher number of elements. However, the
accuracy of the cooling simulation results is more accurate.
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Meshed Cooling Channel (SOLIDWORKS Plastics 2018)

Enhanced mesh for Cooling Channel (SOLIDWORKS Plastics 2019)

Geometry-based Boundary Conditions

You can assign boundary conditions such as Injection Locations, Control Valves, and Mold
Wall Temperatures directly on geometry entities.

In the PlasticsManager tree, expand Boundary Conditions (Geometry Based).

In addition to the mesh-based assignment of boundary conditions (applied to elemental
nodes or elemental faces), you can assign boundary conditions directly on geometry. This
enhancement lets you position Injection Locations or Control Valves more accurately, and
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associate the boundary condition assignments directly to geometry when changes to the
part geometry occur.

The software saves the boundary conditions you create directly on a part's geometry in
the .sldprt file. You need to share only the .sldprt file so that your team members

can view the geometry-based boundary conditions on the model. Configuration-specific
study features are also saved.

Geometry-based boundary conditions have limited support for shell meshes.

Injection Locations on Geometry

You can assign Injection Locations directly to a part's geometry before creating a mesh.

In the PlasticsManager tree, right-click Boundary Conditions (Geometry Based), and
click Injection Location (Geometry Based).

Use sketch points or geometry faces that represent the gate cross-section (gate or injection
area) to precisely position the Injection Locations.

Control Valves on Geometry

You can define Control Valve locations using geometry features before meshing.

In the PlasticsManager tree, right-click Boundary Conditions (Geometry Based), and
click Control Valve (Geometry Based).

In the Control Valve (Geometry Based) PropertyManager, click one of the two options
under Valve:

Manually select the control valve Select the locations to add the Control Valves.
locations

Automatically find intersecting Select to automatically detect all potential Control
surfaces Valve locations at the intersecting surfaces between
cavity and runner bodies.

Mold Wall Temperature on Geometry
You can assign Mold Wall Temperature boundary condition directly to geometry faces
before creating a mesh.

In the PlasticsManager tree, right-click Boundary Conditions (Geometry Based) and
click Mold Wall Temperature (Geometry Based).

Pin the Mold Wall Temperature PropertyManager to create multiple Mold Wall Temperature
definitions on several geometry faces.
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Mesh Enhancements

Several mesh enhancements are implemented in the SOLIDWORKS Plastics 2019 release.

Create Mesh Before Saving a Part

You can create a mesh before saving a new SOLIDWORKS part file.

The plastics study data are stored in a local temporary folder. When you save the
SOLIDWORKS part file, the plastics study features are copied to the folder where the
SOLIDWORKS part model is saved.

Geometry-based Mesh Control

Similar to geometry-based boundary conditions, you can assign local mesh controls over
faces, edges, and vertices before the creation of the mesh.

In the PlasticsManager tree, right-click Mesh and click Geometry Based Mesh Control.
Add mesh controls in key areas of interest such as injection locations, gate regions,
thickness transition regions, and curved surfaces. You can view/edit the Mesh control
definitions under Mesh.

When you have both solid and shell mesh in a study, the inactive mesh node is unavailable.
The inactive mesh node is highlighted in gray.
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Mesh Details

After creating a mesh, you can view information about the mesh statistics.

In the plastics tree, right-click Mesh and click Details. The Mesh Details dialog box
displays information about the mesh type, number of shell and solid elements or nodes,
and mesh quality data such as maximum aspect ratio and number of bad elements.

Simplified Mesh Hierarchy

Upon generating the mesh, the selected type of mesh approach appears as a subnode
under the Mesh node.

In the PlasticsManager tree, right-click Mesh to select the required meshing approach.

Switching Between Mesh Types

You can detect the active and inactive mesh types under the Mesh node.

When you have both solid and shell mesh in a plastics study, the inactive mesh node is
highlighted in gray color. Right-click the inactive mesh node to activate it.
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This chapter includes the following topics:

e Configuring Routing Components

e Creating Fixed Length Coverings

¢ Fixed Length Covering PropertyManager

e Improved Performance with Routing Library Manager
e Inline Components

Routing is available in SOLIDWORKS Premium.

Configuring Routing Components

You can use the Configure Component tool for Routing components with route properties
in assemblies when the Routing add-in is enabled.

You must include a component or assembly that has its parameters defined through the
Configuration Publisher. For more information, refer to Configuration Publisher.

To configure routing components:

1.

2.

Enable the Routing add-in by clicking Tools > Add-Ins > Routing and selecting the
option.

Click Tools > Options > System Options > Routing and select Use configure
components to select configuration.

In an existing assembly, do one of the following:
e C(Click Insert Components B (Assembly toolbar).
e Drag a component from the Design Library.

The Configure Component PropertyManager is displayed.

In the Configure Component PropertyManager:
a) Specify the parameters.

b) Click ¥.

In the message box, click Yes to save the assembly.
In the Route Properties PropertyManager:
a) Specify the route properties.

b) Click ¥ to complete the configuration.
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Creating Fixed Length Coverings

You can create partial or fixed length coverings for various locations and elements on the
route segments.

To create fixed length coverings:
1. Do one of the following:

e Click Fixed Length Covering (Electrical, Piping, Tubing, and Routing Tools
toolbars).

¢ Right-click a route segment and click Fixed Length Covering.
2. Set the options in the PropertyManager.
3. Click ¥.

Fixed Length Covering PropertyManager

Fixed Length Covering

Options Description

Segments Lists selected segments in the graphics area.
Covering start point Lists the covering start point on the route segment.
Offset Distances Lists the route offset distances between the covering

start and endpoints.

Covering distance Lists the covering length.

Covering parameters

Use Covering Library Uses the existing Covering Library.

Create custom covering Creates a custom covering based on your inputs.
Covering type Specifies the type.

Covering Specifies the covering.

Thickness Sets a value for the covering thickness.

Outer Diameter Sets a value for the covering outer diameter.
Material appearance Sets the appearance of the material.
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Name Lists the default name for the material you specified. You
can edit the name for the covering instance that you
create.

Covering Layers

Spinner control Lists the segments and their associated layers. Moves
the position of the covering layers inwards or outwards.

Layer Properties Lists the properties of the selected covering instance.

Improved Performance with Routing Library

Manager
Improved Feature Description
Routing Component Wizard When you use the Routing Component Wizard of the

Routing Library Manager, the creation of routing library
components is more efficient. The wizard displays only
the essential tabs that you use to create routing
components for different types of routes. The wizard
responds faster when you switch tabs.

In the Routing Library Manager > Routing
Component Wizard > Design Table Check tab, all
component-specific column headers are displayed. The
design table information is locked. You can edit column
headers in the wizard and click Next to apply the
changes to the design table.

In the Routing Library Manager > Routing
Component Wizard > Component Attributes tab,
components with multiple configurations load only the
active configuration parameters. Other configuration
data is loaded only when you select the configuration
in the tab, which accelerates the tab's performance.
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Improved Feature Description

Piping and Tubing Database Removing To remove components from the
Components database, in Select Components,
select Remove Components and click
Save.

Scanning To list components not present in the

Components database, in Scan for library
components which are not in the
database, click Scan. To include
scanned components in the database,
select Add Components and click
Save.

The saving and scanning operations are faster. In
Routing Library Manager > Piping and Tubing
Database > Select Components > Scan for library
components which are not in the database, select
Scan excluded folders, and click Scan to scan
components in the excluded folders. After the scanning
process completes, the table displays components that
are not in the database. In the table, you can edit and
save Type and Sub Type for components.

When you click Save, the SOLIDWORKS software opens
and saves only selected components with modified
Type or Sub Type, and adds them to the database.

Import Data Dialog Box In the Routing Library Manager > Piping and
Tubing Database > Import Data, Start and
Synchronize are not available simultaneously, to
improve the workflow.

Select Route and Component In the Route Component Wizard, the Select Route Type
Type and Select Component Type tabs are combined to
improve access.

Design Table Check In the Routing Component Wizard, when no Design
Library exists for a part, the Design Table Check node
is available. A message prompts you to create a new
design table.

Previously, if no design table existed for a part, the
Design Table Check node was unavailable and there
was no option to create a new design table.

Images for Connectors in the The Routing Library Manager includes images in Route

Routing Library Manager and Component Types, Routing Geometry, and Routing
Functionality Points nodes of the Routing Component
Wizard tab.

The images help you identify the components.
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Inline Components

Inline components do not require routing specific features. Any components having axes
can be added to a route.

Add a route point and axis to a component for adding the component to the junction of
a route. The route point associates the components with the junction of the route while

the axis aligns the routes.
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Boot

Y Junction

Tag

Adding Inline Components to Routes

You can add inline components, such as shrink wraps and boots, to a route assembly and
align them to the route.

To add inline components to routes:

177



Routing
1. Drag an inline component from the Routing Design Library.

The Select a Configuration dialog box or Configure Component PropertyManager
appears, depending on the options selected in the Route Properties PropertyManager.

The name of the inserted component appears in the Parts input box.

2. In the Align Components PropertyManager, click in Current Selections.
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3. In the graphics area, select:
a) A route spline.
b) An edge, axis, or point of the component to align.
c) Click Apply.
The applied selections appear in the Route Alignments input box.

You can right-click any input box and click Delete or Remove Selection to
clear the selections.

Assembly without inline components
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Assembly with inline components

Align Components PropertyManager

The Align Components PropertyManager aligns components with route segments.
To open this PropertyManager, do one of the following:

e Add the component by dragging it to the route segment or the junction point of the
route, in the graphics area.

e Right-click the component and click Align Components.

Manage the alignment of components to routes.

Options Description

Parts

Adds a component for alignment.

Current Selections

Adds a route spline and an edge, axis, or point of the
component to align.

Apply

Applies the selections made for Parts and Current Selections.
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Options Description

Route Alighments Displays the alignment routes and the aligned components.

Drawing Options

Add component in BOM Adds components to the bill of materials.
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This chapter includes the following topics:

e Linking Materials and Sheet Metal Parameters
e Tab and Slot

Linking Materials and Sheet Metal Parameters

When you assign a custom material to a sheet metal part, you can link the sheet metal
parameters to the material. If you change the material, the sheet metal parameters also
update.

To link materials and sheet metal parameters:
1. Open a sheet metal part.

2. Inthe FeatureManager® design tree, right-click Material 8% and click Edit Material.
3. In the dialog box:

a) Right-click Custom Materials and click New Category.

b) Right-click New Category and click New Material.
c) Set the custom material properties on each tab as required.
d) Click the Sheet Metal tab.

Options on this tab are available for custom materials only.
e) Select Thickness Range.
f) Click Add twice.
g) For each row in the table, set the following:

Bend Value
Allowance
1 0 < <= 3 millimeters  K-Factor 0.375
2 3 < <= 6 millimeters  K-Factor 0.4

Thickness ranges must be continuous; there cannot be a gap in the range. For
example, you cannot define a range from 0 to 3 and define the next range from
4 to 6 because the range between 3 and 4 is not covered.

h) Click Apply and Close.
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Tab and Slot

Enhancements to the Tab and Slot tool include group linking, the use of nonlinear edges,
slot corner shapes, and through all cuts.

Linking Groups

You can link groups of tab and slot features together so that all parameters apply uniformly
to the features. If you edit a parameter for a linked group, all of the tab and slot features
in the group update accordingly.

To link groups, in the Tab and Slot PropertyManager, under Selection, select entities in
Group List and select Link Groups Together.

Nonlinear Edges

You can select nonlinear edges when creating a tab and slot feature.

Slot Corners

You can set the type of corners for slots. In the Tab and Slot PropertyManager, under
Slot, you can set Corner Type to:

Slot sharp corner
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Slot fillet corner

Slot chamfer
corner

Slot circular
corner

Slot Length and Width

You can specify the offset values for the length and width of slots. In the Tab and Slot
PropertyManager, under Slot, you can set:

« Slot Length Offset

« Slot Width Offset
o Equal offset. Sets equal values for Slot Length Offset and Slot Width Offset.

Through All Cuts

Slots are always created as through all cuts unless the cuts are impractical. If you do not
want a through all cut, select No Through Cut under Slot in the Tab and Slot
PropertyManager. If a through cut is impractical for the model (for example, models with
a single body), No Through Cut is unavailable.
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No Through Cut cleared

No Through Cut selected
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SOLIDWORKS Simulation

This chapter includes the following topics:

e Customized Numerical Format

e Enhanced Remote Load/Mass PropertyManager
e Distributed Coupling for Remote Load and Mass
e Pin Connector

e Simulation Performance Improvements

e Stress Averaging at Mid-side Nodes

e Topology Study

SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are available as separately purchased products that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Customized Numerical Format

The Microsoft® Windows® system options you define for formatting numerical values
propagate to post processing of simulation results.

You can control the formatting of humerical values (symbols for thousand and decimal
separators) when displaying or listing results.

From the Control Panel, select Region and Language > Formats > Additional
settings. On the Formats tab, specify the required symbols for Decimal symbol and
Digit grouping symbol (thousand separator).

These Microsoft Windows system options apply to the numerical format when probing
and listing simulation results, and also when displaying callouts in plots (including plots
in reports).
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Enhanced Remote Load/Mass PropertyManager

The Remote Load/Mass PropertyManager is redesigned to improve the user experience
and enhanced with the introduction of distributed coupling for linear static, nonlinear

static, and topology studies.

To access the Remote Load/Mass PropertyManager:

From a linear static, nonlinear static, or topology simulation study tree, right-click External

3,
Loads, and click Remote Load/Mass .

Legacy Options (Remote

Load/Mass)

Load (Direct Transfer)

New Options (Remote Load/Mass)

Connection Type is Distributed with Weighting
factor set to Default (constant).

Enter force values (X-, Y-, or Z -direction) in
Translational Components > Force i.

Enter moment values (X-, Y-, or Z-direction) in

Rotational Components > Moment gs.
Select Mass, to enter the remote mass properties.

Load/Mass (Rigid
connection)

Connection Type is Rigid.

Enter force values (X-, Y-, or Z -direction) in
Translational Components > Force 4.

Enter moment values (X-, Y-, or Z-direction) in

Rotational Components > Moment &,
Select Mass, to enter the remote mass properties.

Displacement (Rigid
connection)

Connection Type is Rigid.

Enter translation values (X-, Y-, or Z -direction) in
Translational Components > Translation B:L

Enter rotation values (X-, Y-, or Z-direction) in

Rotational Components > Rotation éﬁ
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Legacy Options (Remote New Options (Remote Load/Mass)
Load/Mass)

Displacement (Direct Connection Type is Distributed with Weighting
transfer) factor set to Default (constant).

e Enter translation values (X-, Y-, or Z -direction) in
Translational Components > Translation B:L

e Enter rotation values (X-, Y-, or Z-direction) in

Rotational Components > Rotation @‘;’i.

Distributed Coupling for Remote Load and Mass

Distributed coupling constrains the motion of the coupling nodes to the translation and
rotation of the reference node.

The distributed coupling constraint is enforced in an average sense in a way that enables
control of the transmission of loads and displacements through weight factors at the
coupling nodes. Distributed coupling allows the coupling nodes of the selected geometry
(face or edge) to move relative to each other.
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3

Example of a Distributed Coupling Constraint

1 |Reference node

2 | Prescribed rotation

3 | Face that defines the coupling nodes

4 | Coupling nodes

5 |Warping (out of plane deformation) permitted by the distributed coupling constraint

Forces and moments at the reference node are distributed either as a coupling node-force
distribution only (default) or as a coupling node-force and moment distribution. This
constraint distributes loads such that the resultants of the forces (and moments) at the
coupling nodes are equivalent to the forces and moments at the reference node.

For cases of more than a few coupling nodes, the distribution of remote forces/moments
and mass is not determined by equilibrium alone, and distributing weight factors scale
the distribution. These weighting factors are available when Connection Type is
Distributed:

Default Uniform weight distribution. All weight factors w; are equal to 1.
(constant)
Linear Weight factors decrease linearly with distance from the reference node.
r,
1-'1r'r- - 1 -
To
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Quadratic

Cubic

w; is the weight factor at coupling node i, r; is the coupling node radial
distance from the reference node, and ry is the distance to the furthest
coupling node.

Weight factors decrease with distance from the reference node following
a quadratic polynomial formulation.

w=1- ()

Weight factors decrease with distance from the reference node following
a cubic polynomial formulation.

wp=1- 3(:—;)2+2(:—;)3

When Connection Type is Rigid, the coupling nodes do not move relative to each
other. Rigid bars connect the attachment point to the coupling nodes, and high stresses
can develop as a result. The faces where remote loads or displacements are applied
behave like rigid bodies.

The remote load and mass combinations supported for the Distributed and Rigid
connections are listed below (Linear static and Nonlinear static studies).

Remote Load Combinations Distributed Rigid Connection

Connection

Force and Moment Supported Supported
Translation and Rotation Supported Supported
Force, Moment, Translation, and Supported Not supported
Rotation

Force, Moment, and Mass Supported Supported
Translation, Rotation, and Mass Supported Not supported
Force, Moment, Translation, Rotation, = Supported Not supported
and Mass

For Mass, you need to define Gravity (and perhaps Centrifugal load).
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Pin Connector

The improved pin connector is extended to nonlinear static and nonlinear dynamic studies.
You can define a pin connector through more than two cylindrical surfaces in one definition.

You can define a single pin connector attached to multiple coaxial cylindrical faces
(maximum ten).

In the Connector-Pin PropertyManager, for Cylindrical Faces/Edges @, select all coaxial
cylindrical faces (or edges) that are attached to the pin (maximum of ten). The selected
cylindrical faces or circular edges can belong to one body or to several bodies.

For example, for the two models below, you can define two pins (one for each model) to
connect the two rotating parts and the six cylinders of a hinged plate. You can then run
a nonlinear static or nonlinear dynamic study.

The solver calculates the pin connector forces at two pin joints per pin segment (a pin
segment attaches to two cylindrical faces.) The safety factor for each pin connector is
calculated based on the least FOS at the pin joints for the selected pin connector. The
total axial and rotational stiffness you define for a pin connector is distributed according
to each pin segment's geometric characteristics such as: cross sectional area, length,
and polar moment of inertia.

For example, for a single pin definition connecting four cylinders of a hinged plate, the
solver calculates the pin forces at four pin joints. Each pin joint is located at the centroid
of each cylindrical face attached to the pin.
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When viewing pin connector results, in the Result Force PropertyManager, click a table
cell under Connector Force to highlight the location of the selected pin joint. A callout
lists the pin forces at the selected joint. The directions of the pin resultant forces with
respect to the pin's local coordinate system are also displayed: shear force resultant,
axial force resultant, bending moment resultant, and torque resultant.

Connector Force

Shear Farce Res [5Fr):
Axial Farce Res [&Fr):
Bending morent Res [BML:

Torque Res [Tor):

1.5344e-06 M
1,000 M
4,5956e-05 MN.m

-1.004e-08 M.m

Type Resultant | Connector

Click List X,Y,Z components to list the X, Y, and Z components of the pin forces with

respect to the global coordinate system.
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Simulation Performance Improvements

There are improvements in overall stability and performance while solving a simulation,
especially for linear static studies with multiple load cases.

A major driver of the performance improvements is based on the fact that the solution
formulation is restructured for optimized performance. The optimized reconfiguration is
limited to the Intel Direct Sparse solver only. Noticeable improvements in solution time
are observed for linear static studies with up to 25 load cases. Note the following:

e The optimized performance of the Intel Direct Sparse solver is realized for Pressure,
Force, and Torque load types. All other load types, connectors, and non-zero prescribed
displacements cannot vary from one load case to another, or else you will not observe
any performance benefit during the solution.

e There are not any performance improvements for these cases: linear static studies
with load cases defined with no-penetration contacts, virtual wall contacts, distributed
beam loads which vary across load cases, loads on beam vertices, and extension only
or compression only springs.

e For linear static studies with multiple load cases, the performance benefit comes from
the factorization of the global stiffness matrix. The global stiffness matrix factorization
(which consumes the majority of the total solution time) is done only once, as the
stiffness matrix is exactly the same for every load case.

Stress Averaging at Mid-side Nodes

An improved stress averaging algorithm yields better stress results for the mid-side nodes
of high-quality solid elements.

In the Default Options > Results dialog box, under Advanced Options, select
Average stresses at mid-nodes (high-quality solid mesh only).

The new mid-side node stress averaging algorithm yields better stress results when
irregular high stresses occur at mid-side nodes that are located at areas with steep
curvatures. The improved stress averaging algorithm does not modify the stress results
calculated at the corner nodes of elements.

For a high-quality solid element, the stresses at the mid-side nodes are calculated by
averaging the stress values of the nearest corner nodes. The new stress averaging
algorithm improves the high stresses that can occur at mid-side nodes of tetrahedral
elements located at areas with steep curvatures. An example of the stress averaging is
shown.

e Stresses at corner nodes (1, 2, 3, and 4) globally
averaged over the shared elements.

e Stresses at mid-side nodes (5, 6, 7, 8, 9, and 10)
averaged over the associated corner nodes. For
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example, stress (node 5) = (stress (node 1) + stress
(node 2)) / 2

The improved stress-averaging algorithm at mid-side nodes is available for all stress-based
results across all studies, except for Linear Dynamic studies.

Topology Study

Topology Study enhancements include: addition of stress (factor of safety) and frequency
values as design constraints, export of an optimized shape as a mesh body, and an option
to save intermediate results.

Topology Constraints

You can define stress (factor of safety) and frequency values as design constraints for a
Topology study.

For example, run a Topology study to find the optimal shape of a model with the largest
stiffness for a 50% weight reduction and a maximum permissible stress condition. A
stress constraint enforces the condition that a model after optimization cannot experience
stresses larger than a percentage factor of the material's yield strength.

To specify a stress constraint, in the Goals and Constraints PropertyManager, select
Stress/Factor of Safety Constraint. For Type, select either Stress Constraint, or
Factor of Safety Constraint.

Stress Constraint Specified value Enter the maximum permissible von Mises
stress value for the optimized geometry.

Specified factor Enter the maximum permissible von Mises
stress value as a percentage of the
material's yield strength.

Factor of Safety Enter the minimum acceptable factor of safety for the

Constraint optimized geometry. The maximum permissible von Mises
stress is calculated from the material's yield strength divided
by the user-defined factor of safety. The maximum von Mises
stress is the default FOS criterion used in this case.

To specify a frequency constraint, in the Goals and Constraints PropertyManager, select
Frequency Constraint. Enter a lower or upper, frequency limit, or range of permissible
frequencies for the selected mode shapes.

Run a frequency study with the original model (maximum design space), before you
run a topology study with frequency constraints, to evaluate the range of permissible
natural frequencies.
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Select Mode tracking to instruct the optimization solver to track the order of the selected
mode shapes derived from the original geometry (throughout the optimization iterations)
when enforcing frequency constraints.

When Mode tracking is cleared, the solver tracks the current order of mode shapes as
derived for each optimization iteration. For example, it is possible for an optimization
goal of a 50% mass reduction and a frequency constraint on the first mode shape. The
first mode shape of the original geometry becomes the second or third mode shape of
the optimized geometry.

For example, you add a frequency constraint on a distinct mode shape of a plate (the
first mode in the original plate geometry). As the model shape changes during iterations,
this mode may move down in the frequency list. By selecting Mode tracking, the
solver keeps track of the same mode as it moves positions in the list of frequencies,
and enforces the constraint on the same mode shape. When you clear Mode tracking,
another mode shape replaces the original first mode in the course of iterations. The
solver then applies the frequency constraint on this new mode that replaces the old
mode.

For a Topology study with a specified frequency constraint only:

e Applied loads or prescribed displacements (including remote loads, translations, and
rotations) are not considered in the calculation of the resonant frequencies.

e In the Remote Load/Mass PropertyManager, select Connection Type > Rigid to apply
a remote mass. Any remote mass you apply with option Connection Type >
Distributed is ignored by the solver.

Export to Mesh Body

After you run a Topology Study, you can export the optimized shape (as shown in a
Material Mass plot with smoothed mesh) to a mesh BREP body.

In the Export Smoothed Mesh PropertyManager, under Advanced Export, select Solid
body or Surface body. Click Create mesh bodies bounded by single faces.

The mesh bodies (also known as mesh boundary representation or mesh BREP bodies)

are made up of mesh facets (triangles). For solid bodies, the mesh facets form a closed
boundary surface (also known as watertight mesh). For surface bodies, the mesh forms
an open surface BREP.

Click Group facets into faces to collect the mesh facets into selectable faces. These
mesh faces are defined as a collection of facets and do not have a parametric
representation, so you cannot modify their dimensions.

You can save a mesh body in the current configuration (saved as imported body in the
FeatureManager® design tree), in a new configuration, or in a new SOLIDWORKS part file
(*.sldprt).

The mesh BREP body is independent of the mesh representing the finite element model
of the geometry in Simulation.

195



SOLIDWORKS Simulation

Save Intermediate Topology Results

You can stop the analysis of a topology study before the final iteration completes and
view intermediate results.

In a Topology study's progress dialog box, click Stop and Save Results before the solver
completes the final iteration of the optimization.

The SOLIDWORKS Simulation software saves the results of the last running iteration. A
warning message alerts you that the results may not be valid because the solver stopped

before it reached convergence. You can view intermediate optimization results in a
Material Mass Plot.
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This chapter includes the following topics:

e Editing Generic Splines

e Generic Spline PropertyManager

e Geodesic Entities

e Pen Tool Sketching Enhancements
e Projected Curve Enhancements

e Slicing Tool

e Trim Entities Enhancements

Editing Generic Splines

When you apply Convert Entities, Offset Entities, or Intersection Curve on a spline,
the result is a Generic Spline. Generic splines replace splines.

Previously, it was difficult to control the shape of the spline. It is much easier to control
the shape of the generic splines with the help of options in the Generic Spline
PropertyManager.

To edit Generic Splines:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\sketching\SplinePart.sldprt.

Click Sketch > Convert Entities ©.
Click the spline in Sketchl.

In the Convert Entities PropertyManager, click ¥ .

In the Generic Spline PropertyManager, in Existing Relations, right-click On Edge
0 and click Delete.

A W
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6. Edit the generic spline with the following alternatives:

Option Description

Right-click the generic spline and Use the control polygon to shape the
click Show Control Polygon. curve.

Right-click the generic spline and
click Convert to spline * or Convert
to Style Spline t,

In the Generic Spline The Control Vertex Weight option is
PropertyManager, under Parameters, selected to let you adjust the curve shape.
click Rational.

7. Click ¥.

Generic Spline PropertyManager

The Generic Spline PropertyManager controls the geometry of the generic spline.
To open the Generic Spline PropertyManager:

1. Apply the Convert Entities ED, Offset Entities @, or the Intersect Curve © tools
on a spline by creating a reference plane.

2. Click the resultant spline.

Existing Relations

kL Relations Displays relations inferenced automatically during
sketching or created manually with Add Relations.

® Information Displays the status of the selected sketch entity (Fully
Defined or Under Defined.

Add Relations

Fix Adds relations to the selected entity. The list includes only relations
that are relevant for the selected entity.

Options

For construction Converts the entities to construction geometry.
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Show curvature

Adjusts the style spline curvature.

Show Control Polygon

Displays control polygons on the spline.
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Control Vertices

Displays the total number of control vertices on the
spline when you select Show Control Polygon.

Parameters

Non-rational Spline

Creates nonrational splines on which you cannot control
the vertices.

Rational Spline

Creates rational splines that you can control using the
Control Vertex Weight option.

Spline Point Number

Edits the selection of the spline control vertex when
you enter a value or use the toggle button.

Ry

X Coordinate

R

Y Coordinate
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Control Vertex Weight

(Rational splines only) Shapes the spline by increasing
or decreasing the weight of the control vertex.
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Geodesic Entities

You can create geodesic 3D sketch offsets entities with the Offset on Surface @ tool.

Click Offset on Surface @ (Sketch toolbar) or Tools > Sketch Tools > Offset on
Surface to open the Offset on Surface PropertyManager.

Previously, you were able to create only Euclidean offsets on surfaces.

The Offset on Surface PropertyManager has the following offset options:

Geodesic offset

Creates an offset distance that is the shortest possible

distance between the selected edge and the resultant offset
entity, taking the support curvature into account.

Euclidean offset

Creates a linear offset distance between the selected edge

and the offset entity that does not include the curvature
of surface.
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1 | Offset sketch entity

2 | Euclidean offset distance (measured as a linear distance)

3 | Geodesic offset distance (measured along the surface)

4 | Selected edge for offset

Pen Tool Sketching Enhancements
&

You can use the Pen = tool to create splines, slots, ellipses, and dimensions.
The Pen tool is available on touch-enabled devices.

Sketch Ink CommandManager enhancements:

&) Convert to Ellipse Converts ink strokes into slot sketch entities when you
sketch ellipses or slots. Click Convert to Ellipse on
the context toolbar to toggle the shape from a slot to

an ellipse.
2N Convert to composite Approximates ink strokes as lines and arcs.
shape
"y Convert to spline Converts the lines and arcs of ink strokes into splines.
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Ruler and Protractor Helps you create straight lines. When you sketch
& strokes close to the straight edge, they snap to the
- edge of the ruler. You can also access these tools from
e the Sketch Ink flyout menu.

le Select tool Click the button on the barrel of the pen to toggle
between Pen and Select modes. This helps you quickly
drag and make selections.

Dimensions Write dimensions with the Pen tool near entities and
the application recognizes your handwriting as numbers
that are applied to the entities as dimensions. To
dimension a previously sketched line, select it and
write the dimension.

Projected Curve Enhancements

You can create multiple closed or open contour projected curves in a single sketch. You
can also use 3D sketches as input for the Projected Curve tool.

Previously, you had to create a separate sketch for each entity and then use the Projected
Curve tool.

The Bi-directional option in the Projected Curve PropertyManager projects sketches in
two opposite directions. You can also set a custom direction for projected curves, using
a planar or linear reference such as an edge, sketch, plane, or a face.

The Projected Curve tool does not support projections of intersecting curves.

Sketch on Sketch PropertyManager Enhancements

You can project sketches bidirectionally in the Sketch on Sketch PropertyManager.

Sketch on Faces Projections

You can input the direction of the projected curve as a plane, edge, sketch, or a face,
with the Direction of Projection option in the Projected Curve PropertyManager.

When using the Projected Curve tool for the Sketch on faces option, for Direction of
Projection, you must select one of the following:

e AXis

e Linear sketch entity
e Linear edge

e Plane

e Planar face
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Slicing Tool

You can use the Slicing tool to create 2D sketch sections that are at the intersection of
the source geometry and a reference plane.

The Slicing @ tool creates 2D sketches and sketch planes at the intersection of a
reference plane and standard SOLIDWORKS BREP geometry, mesh BREP geometry, and
graphics bodies. You can use the 2D sketches to create solid or surface geometry and for
reverse engineering or to create references for features based on a sliced section of the
model.

For more information, refer to SOLIDWORKS Help > Parts and Features > Mesh BREP
Bodies.

To access this tool, click Insert > Slicing.

Slicing Mesh BREP Bodies Using Planar Entities

To slice mesh BREP bodies using planar entities:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\sketching\wing.sldprt.

2. Save a copy of the part as wing mesh.sldprt and open the copy.

3. Inthe FeatureManager® design tree, expand Solid Bodies(1), right-click Loft2, and
click Convert to Mesh Body By.

4. 1In the PropertyManager, click ¥ to convert the solid body to a mesh BREP body.

5. Click Insert > Slicing %
6. Select a facet in the center of the planar face as shown.

203



Sketching

7. In the PropertyManager:

a) Click Reverse Direction 4 so the slices form toward the model.

b) For Number of planes to create, enter 8.
c) For Offset, enter 25.001in.

8. Click .

The software creates line segments wherever there are mesh intersections.

A slicel folder appears in the FeatureManager design tree that stores the slicing
planes and sketches.

Slicing PropertyManager
The Slicing PropertyManager creates 2D sketch sections.
Slicing Planes

To access this tool, click Insert > Slicing :@ Select a planar entity or a combination of
a linear entity and a point entity.
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Number of planes to create Sets the number of slicing planes to create. Planar
entities produce a linear pattern of parallel planes,
while the combination of a linear entity and a point
produces a circular pattern of reference planes whose
axis is the linear entity.

Reverse Direction %

Reverses the direction of the planes.

Offset Sets the linear or angular spacing between planes.

Options

Add slicing planes and Adds slicing planes and sketches to a folder in the

sketches to a folder FeatureManager design tree for an organized view. After you
create sketches and reference planes with the Slicing tool,
you can edit them individually only, not as a group.

Preview slices Shows a preview of the slices in the graphics area.
(slower)
Slices to generate Intersection When selected:

Exact

Circle

Rectangle

e For classic BREP geometry, the slice is
identical to what is generated with the
Intersection Curve tool.

e For mesh BREP and graphics bodies, sketches
generated by using the Slicing tool cannot
be modified.

Creates an exact intersection of the mesh BREP
body and graphics body that results in a series
of line segments called polyline. A polyline is a
continuous line composed of one or more lines.
Selected by default when you select a graphics
mesh body or a BREP mesh body.

Creates a circle. The diameter equals the
average of the length and width of the rectangle
that encloses all the sketch entities. The circle
is located at the intersection of the source
geometry and the slicing plane.

Creates a rectangle that encloses all the sketch
entities and is located at the intersection of the
source geometry and the slicing plane.
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Bounding Box

Each color arrow corresponds to the color of an extendable drag handle of the bounding
box in the graphics area.

Slicing Standard SOLIDWORKS BREP Bodies Using Linear
and Point Entities

To slice standard SOLIDWORKS BREP bodies using linear and point entities:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\sketching\circular part.sldprt.

2. In the graphics area, Ctrl + select Linel@3DSketchl1 and the vertex as shown.

3. Click Insert > Slicing @
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4. In the PropertyManager:

a) Click Reverse Direction 4 so the slices form toward the model.

b) For Number of planes to create, enter 10.

5. Drag the orange handle to enclose the whole model with the bounding box.

Use Top view to make sure that the bounding box covers the whole model.
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6. In the PropertyManager, select Preview Slices (slower) to preview each individual
slice per slicing plane.

@

=
1L}/ y

7. Click .

Trim Entities Enhancements

You can convert trimmed entities into construction geometry or ignore construction
geometry when trimming. This improves the handling of construction geometry for 2D
and 3D sketches.

Previously, the Trim Entities LS tool trimmed all entities, which often caused sketches
to become under defined.

Click Tools > Sketch Tools > Trim to open the Trim Entities PropertyManager.

Keep trimmed entities as construction Converts the trimmed entities into

geometry construction geometry.
Ignore trimming of construction Leaves construction geometry unaffected
geometry when you trim entities.
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These options maintain dimensional relations to the trimmed entities. They might maintain
geometric relations, depending on the trimming conditions.

If you select both options, solid entities are converted to construction geometry and
existing construction geometry is unaffected.
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This chapter includes the following topics:

e Automatic Data Recovery

e Customizing Keyboard Shortcuts
e Denoiser

e Importing Files

e Importing MDL Materials

e Model Tree Behavior

e Modifying Decal Mapping

e PBR Materials

e Physics Simulations

e Render Options

e Rendering Solid-Transparent Appearances
e Video Textures

SOLIDWORKS Visualize is available as a separately purchased product that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a
completely separate application.

Automatic Data Recovery

If your session ends unexpectedly, you can recover automatically saved data the next
time you start a session. You can specify the frequency and folder for saving auto-recovery
data.

To specify automatic data recovery options:

1. Click Tools > Options > Auto-Recover.
2. In the dialog box, set options:

Enable auto-recover Automatically saves unsaved data at the specified interval so
you can recover it if your session terminates unexpectedly.

Auto-recover interval Specifies the number of minutes before an auto-recover file is
(minutes) created, and how often it is updated after that. The file is closed
and deleted when you save your work.
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Auto-recover folder Specifies the folder in which the auto-recover file is saved. The
auto-recover folder must be a folder on your local system. You
cannot use a network location or a mapped network drive.

Customizing Keyboard Shortcuts

You can customize keyboard shortcuts for tools in SOLIDWORKS Visualize.

With the Hot Keys editor, you can create, manage, search, and filter keyboard shortcuts.
You can back up and share the keyboard shortcut definitions across multiple installations.

Click Tools > Hot Keys.

Denoiser

With the Denoiser, you can achieve significant reductions in render time for
production-quality images.

The Denoiser is available in SOLIDWORKS Visualize 2018 Service Pack 3.0 and later.

The Denoiser uses a post-processing technique based on machine learning to filter out
noise from unfinished and noisy images produced with Fast and Accurate render modes.

To achieve increased performance from using the Denoiser, you need to reduce the
number of render passes. For example, if a scene routinely needs 500 passes without
the Denoiser, specifying 50 passes when the Denoiser is on may achieve the same
rendering quality. You may be able to achieve the same rendering quality with even fewer
passes using the Denoiser depending on your goal for the image. Actual reductions in
the number of passes, and therefore render time, depends on the computer’s hardware
and the scene rendered.

To use the Denoiser, you must have this hardware:

e NVIDIA® GPU (Kepler™ architecture or newer) with CUDA® 9.0 support
e At least 4 GB of video RAM

The following image shows typical results with Denoiser off (left) and on (right).
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Denoiser Example

In this example, you render a SOLIDWORKS Visualize project, first with the Denoiser
turned off and then with it turned on. Then you examine the resulting images and compare
the number of render passes, the render time, and the image quality.
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Creating the Baseline

First, you specify the options for offline rendering. Then, with the Denoiser turned off,
you render the project to create a baseline . jpg image.

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\visualize\Food Processor.svpj.

2. Click Output Tools % (main toolbar).

3. In the dialog box, on the Render % tab, under Output File:

e For Image format, select JPEG (*.jpg).
e For Output Mode, select Render.

4. Under Resolution:
e For Size, select 800 x 800 pixels.
e For Resolution, specify 96.00 pixels/in.

5. Under Render Settings:

e For Renderer Selection, select: Accurate
e For Render Mode, select Quality.
e For Render Passes, specify 500.
6. For Render Device:
e Select Hybrid.
e Select Show Progress.
7. Click Start Render.

A Render tab opens.

Click * to dismiss the message about closing Visualize if it appears.

The offline rendering operation will take several minutes to finish.

8. When the render is finished, note the Elapsed Time reported at the top of the window.

The baseline image Food Processor.jpg is automatically saved to your output
folder.

Using the Denoiser

Now render the same project using the Denoiser.

First, you need to initialize the Denoiser to make it available for use. When the Denoiser
is initialized, it requires a certain amount of video RAM even if it is not currently being
used. To use it for a particular rendering, you need to turn it on in a later step.

1. In the upper left of the window, click the Food Processor tab.

2. Click Tools > Options.

3. In the dialog box, click 3DViewport.
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4.

10.

Under Denoiser, select both options:

Option Description

Initialize Denoiser Makes the Denoiser available for use.

Show Button in Main Toolbar
Adds Toggle Denoiser “¥i& to the main

toolbar, where you can click it to switch
the Denoiser on and off.

Click OK.

Click Toggle Denoiser <¥i&¥ (main toolbar) to turn on the Denoiser.
Denoiser is on for real-time rendering in the 3D Viewport.

Now you need to enable it for offline rendering. Also, to achieve increased performance
from the Denoiser, you need to reduce the number of render passes.

Click Output Tools @ (main toolbar).

In the dialog box, on the Render @ tab, set these options:

e Under Render Settings, reduce the value for Render Passes to 50.
e Select Enable Denoiser.

Click Start Render.

A new Render tab opens. The icon &3 in the heads-up display indicates that the
Denoiser is on.

Click * to dismiss the message about closing Visualize if it appears.

When the render is complete, note the Elapsed Time reported at the top of the
window.

The image rendered with the Denoiser on, Food Processor 1.7jpg, is automatically
saved to your output folder.
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11. Click the link to your output folder.

You can open both images of the food processor in your favorite image viewing
application. You can zoom in and compare the amount of noise in various areas. For

example, zoom to the area around the blade shaft:

Denoiser Off Denoiser On
500 passes 50 passes

Using the Denoiser, you may be able to achieve the same rendering quality with even
fewer passes, depending on your goal for the image.

Actual reductions in the number of passes, and therefore render time, depends on
the computer’s hardware and the scene rendered.

Importing Files

FBX Files

The .FBX importer is updated to version 2018.1.1.

IFC (Industry Foundation Classes) Files

You can import IFC files into SOLIDWORKS Visualize. Click File > Import and browse to
the file. In the Files of type list, you can select Industry Foundation Classes (IFC)

(*.ifc; *.ifczip) to show only files of those types.

Importing MDL Materials

You can import NVIDIA Material Definition Language (MDL) materials.

The material properties are read-only. You cannot create MDL materials in SOLIDWORKS
Visualize.
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In the Palette, on the Appearance tab, click Add + > Import Appearance and
select an MDL material.

Model Tree Behavior

You can change the order of items in the tree. Drag models, parts, and groups and drop
them in new positions in the tree.

You can drag parts into or out of a group.

You can move parts into a group. Right-click a part, click Edit > Move Parts to New
Group, and select the name of an existing group.

Modifying Decal Mapping

You can modify the mapping of any decal, whether imported or applied in SOLIDWORKS
Visualize, to use Cylindrical, Spherical, and Label (UV) mapping modes.

1.

2.

Select a decal.

In the Palette, in the Appearance tab, in the Mapping subtab, select a mapping
mode:

e Cylindrical
e Spherical
e Label (UV)

The mapping controls in the Palette and the manipulator in the viewport correspond
to the mapping mode you select.

You can switch mapping modes, adjust how the decal image appears, and adjust the
definition of the mapping projection.

PBR Materials

You can create appearances using Physically Based Rendering (PBR) materials.

PBR materials natively support sets of PBR texture maps that use the Metallic/Roughness
or the Specular/Glossiness workflow.

1.
2.
3.

In the Palette, in the Appearance tab, click Add _I_ > New Appearance.
For Appearance Type, select PBR Material.

In the Texture subtab, select a texture map such as Color, Metallic, Roughness,
or Bump.
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Physics Simulations

You can assign physical properties to objects and then simulate how those objects interact.
You can record any simulation as a key frame animation and replay or render it.

Simulating Driving a Vehicle

You can perform complex simulations of driving vehicles.

1.

2.

In the Palette, select the Models tab and, in the Model tree, select the model to

simulate.

On the Physics subtab, for Simulation Type, select Vehicle.

Click Vehicle Wizard.

In the Vehicle Setup Wizard, you prepare the vehicle for simple turning and dynamic
driving simulations by specifying which parts to use as wheels and calipers. Wheels
are parts that spin and steer. Calipers are parts that steer but do not spin.

In the Vehicle Setup Wizard, select a setup mode:

Option Description

Automatic Mode

(Recommended.) Automatically splits and
assigns wheel and caliper parts for each
wheel set.

For example, select this mode if the
individual parts that comprise the wheel
define the geometry of all four wheels (for
example, as a result of using Appearance
to group parts during import). Based on
the selected driving direction and the
location of the parts, this mode
automatically splits the parts into four
quadrants and assigns them to the
respective wheels.

Manual Mode

Lets you manually assign wheel and
caliper parts for each wheel set.

For example, select this mode if the
geometry is already separated into
different parts for each wheel (for
example, as a result of using Automatic
or Retain Structure to group parts during
import). You need to manually assign
parts into the corresponding quadrants.

5. Click Next and for Step 1, select the direction of travel of the vehicle (+X, =X, +2Z,
-Z). In manual mode, also select or delete parts to include.
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6. Click Next and for Step 2, check the setup of the wheels.
If you need to make changes, go back and adjust the setup or use Manual Mode.

7. Click Next and for Step 3, check the setup of the calipers.
If you need to make changes, go back and adjust the setup or use Manual Mode.

8. Click Apply.

The caliper and wheel parts are grouped in the model tree.

9. On the Physics subtab, for Driving Behavior, specify a method for driving the vehicle:

Option Description

Controller Uses the keyboard or a gamepad.

For the keyboard, the default key
assignments are:

Key Action
w Throttle
S Brake/Reverse
A Steer Left
D Steer Right
Q Brake
E Handbrake

You can edit the key assignments in
Keyboard Shortcuts.

Straight Moves the vehicle along a straight line.
Turn Moves the vehicle in a circle.
Path Moves the vehicle along a path that you

define. Create waypoints under Path
Properties on the Physics subtab.
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10. On the Physics subtab, under Vehicle Setup:
a) Select a Vehicle Type.

Depending on the type of vehicle you select, different values are assigned for
properties such as mass and acceleration. You can adjust the values.

b) For Drive Wheels, Brake Wheels, and Steer Wheels, select one of the following

e Front
¢ Rear
o All

11. Under Advanced Vehicle Details, adjust properties such as maximum steer angle,
wheel friction, and wheel damping rate.

12. Click View > Show Simulation Manager.

The Simulation Manager appears at the bottom of the screen. The Animation interface
also appears. Optionally, you can record the simulation as a key frame animation and
replay or render it.

13. In the Simulation Manager, click Toggle Physics P.

The simulation starts and the vehicle becomes drivable.

Placing Objects in Natural Arrangements

You can use physics simulations to place objects in a natural-looking arrangement.

For example, suppose that you want to place some pens in a cup in a natural arrangement.
You position the pens above the cup and then simulate gravity to drop them. The pens
bounce against the cup and each other according to the physical properties you define
for them, resulting in a somewhat random arrangement. Then you can use the Shake
tool to reposition the pens into an even more natural-looking arrangement.

Before you begin:

1. On the Main toolbar, for Renderer Selection, click Preview
2. In the Palette, select the Models tab and the Physics subtab.

To place objects in a natural-looking arrangement:

1. Inthe Model tree or the viewport, select an object (part “*, group -, or model ~ ).
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2.

For Simulation Type, to specify whether the object can move during the simulation,
select one of the following:

Option Description

None The object is not included in the
simulation.
Static The object cannot move, but it affects

objects that collide with it.

For example, set the cup to Static.

Dynamic The object can move, and its motion is
determined by the simulation.

For example, set each pen to Dynamic.

For Collider Geometry, to specify the accuracy of the object's geometry to use in
collisions, select one of the following:

Option Description

Bounding Box Provides less accurate but faster results.

For example, set each pen to Bounding
Box because the pen geometry is simple.

Mesh Provides more accurate but slower results.

For example, set the cup to Mesh because
a bounding box would close the top of the
cup and prevent the pens from falling into
the cup.

For Physical Properties, specify properties such as static friction, dynamic friction,
elasticity, and mass.

Leave as is for the first pass. You can adjust the properties later to modify the
simulation behavior.

Repeat steps 1 through 4 for each object to include in the simulation.
Click View > Show Simulation Manager.

The Simulation Manager appears at the bottom of the screen.

221



SOLIDWORKS Visualize

7. In the Simulation Manager, click Toggle Physics P.

The simulation starts and gravity causes the dynamic items to fall into place. For
example, the pens fall into the cup. The higher the drop is, the more intense the
collisions are.

Before After

8. To reposition the dynamic objects into a more natural arrangement:
a) In the Simulation Manager, click and hold Shake.

The longer you hold the click, the more intense the shaking becomes. Shading
on the button indicates the progress to maximum intensity.

The pens shake into a more natural arrangement.

b) Release the click.
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9. Click the blank box under Simulation States.

The state of the simulation is saved.

+ ~

A
You can click the box to return the simulation to that state. During the simulation,
you can save up to 11 simulation states. If you save more, the oldest state is

overwritten with the new state. You can pin a simulation state to prevent it from
being overridden.

10. To stop the simulation, click Stop Physics ¥ .

Render Options

Offline Render Options

In the Output Tools dialog box, for Fast render mode you can specify Render Passes
or Time Limit.

Real Time Render Options

You can control the maximum number of iterations (render passes) directly in the heads-up
display. The values for Fast mode and Accurate mode are managed separately.

Rendering Solid-Transparent Appearances

You can use Refract Background to obtain more plausible results when you render

scenes that use a solid-transparent appearance and have a backplate or background
color.

Refract Background is a project property. If you turn it on or off, the change applies
only to the active project.

Typically, the refractive rays in a scene are computed from the HDR environment, whether
it is visible or not. However, if the HDR environment is hidden by a backplate or

background color, problems can occur when you render objects with solid-transparent
appearances.

For example, this scene shows a glass with a solid-transparent appearance. Because the
HDR environment is visible, the background and lighting come from the same source.
The transparency is plausible.
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If you render the same scene with a backplate or a background color, the HDR environment
is not visible. If Refract Background is off, the transparency effect is broken because
the color from the invisible HDR environment still passes through the transparent glass.

Backplate Background color
Refract Background off Refract Background off

If Refract Background is on, the software computes the refractive rays from the
backplate or the background color. The reflections and illumination are derived from the
HDR environment. The results are much more plausible.
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Backplate Background color
Refract Background on Refract Background on

To turn Refract Background on or off:

1. In the Palette, on the Scenes tab, select an environment in the tree.
On the General subtab, select or clear Refract Background.
o If selected (on), the software computes the refractive rays from the backplate or
the background color.
e If cleared (off), the software computes the refractive rays from the HDR
environment.

The state of the Refract Background property is changed only within the active
project.

Refract Background has no effect if the HDR environment is visible.

Limitations:

e If you place an object that refracts the complete environment, such as a sphere, in
front of a backplate, the 2D information from the backplate is insufficient to compute
all refractive rays. Instead, the software uses clamping (repetition of the texture’s
edge color values) to fill in the missing information.

e In Accurate render mode, Refract Background works only for appearances with
Roughness = 0.00.
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Video Textures

You can use videos and image sequences as decals.
You can control and synchronize the playback of the decals by using the animations that
they automatically create in the timeline.

1. In the Palette, in the Appearance tab, click Add _I_ > Decal.
2. Do one of the following:

e Click Video and select a supported video file.
¢ Click Image Sequence and select a series of images.
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This chapter includes the following topics:

Configuring Cut Lists
Structure System

Configuring Cut Lists

In the Cut-list dialog box, you can configure cut lists by clicking the Configuration list
in the upper left corner of the Cut-list Summary tab.

You can also apply a configuration to a cut-list property. In the Cut-list Summary tab,
click Configuration next to the Value/Text Expression and select one of the following:

e This Configuration
¢ All Configurations
o Specify Configurations

The evaluated value updates.

If a property links to a parent configuration, clear the link before assigning a configuration
to the value/text expression.

Structure System

The structure system feature is an advanced weldments environment that lets you create
and modify structural members of different profiles in one feature. The workflow makes
it easier to create complex structure systems with flexible corner management and
trimming.

The structure system comprises primary and secondary structural members. You build
primary members on a grid you create using 2D and 3D sketch segments, points, edges,
reference planes, and surfaces. Secondary members each run between two primary
members. You define secondary members by selecting a support plane and two primary
members, or by clicking two primary members.

When you finish defining the structural members, the software opens the Corner
Management PropertyManager so you can fine-tune the corner treatments. Corners update
automatically when you make changes to the structure system or member profiles.

These tools make up the structure system feature:
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Create Structure System

Activates the Structure System mode.
(Similar to clicking Sketch to enter Sketch
mode.)

Primary Structural Member

Adds members defined by sketch entities,
points, reference planes, and surfaces.

Secondary Structural Member

Adds members between two primary
members.

Corner Management

Groups corners into simple, two member,
and complex corner types, and applies trim
treatments.

Predefine pierce point in profile

Defines a pierce point in structural member
sketch.

Align Member

Zooms to the profile of the structural
member and shifts the profile to align the
pierce points with the structural member
sketch segment.

Entering Structure System Mode

Structure System mode is the design environment where you create an advanced welded

structure system.

To enter Structure System mode:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\structure system.sldprt

2. Click Insert > Structure System > Structure System [,

CommandManager.

You can also enter Structure System mode from the Structure System tab in the

The Structure System mode icon appears in the Confirmation Corner of the graphics area.
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Primary Members

You can create primary members with these methods:

/ Path Segment Creates a member along a sketch entity. Select one
or more sketch entities (similar to weldments). You
can also select model edges for path segments.

m Reference Plane Creates a member along the intersection of two or
more planes.

E 3 Point and Length Creates a member originating at a point and extending
for a specified length. Select one or more points and
specify a length.

[ﬂﬂj On Face Creates a member along the intersection of a face or

surface, and a plane.

Specifying the Profile
You can apply different profiles to members in a structure system.
To specify the profile:

1. Click Primary Member 5| (Structure System toolbar) or Insert > Structure System
> Primary Member.

2. Click Pin ™ at the top of the PropertyManager.
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3. In the PropertyManager, on the Profile tab, set:

Option Description

Standard Iso
Type Sb beam - Configured
Size 120 x 12

Creating Primary Members Based on Points and Length

To create primary members based on points and length:
1. Expand the flyout FeatureManager® design tree in the graphics area.
2. In the PropertyManager, click the Member tab and in Primary Member Type, click

Point Length Member B
3. In the graphics area, click each point at the corners of the Template sketch.

X

(%)
’ %
&
4. In the PropertyManager, type 2700mm for Length.
5. Click ¥.
/ \
- /}
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Creating Primary Members from Path Segments
To create primary members from path segments:

1. Click Path Segment Member n/ for Primary Member Type.
2. Inthe graphics area, click the four line segments that make up the Overhang sketch.

Creating Primary Members from Reference Planes

To create primary members from reference planes:

1. Click Ref Plane Member ﬁ for Primary Member Type.
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2. For Reference Set, select the following planes by expanding Reference Data in the
flyout FeatureManager design tree.
You can also display planes by clicking View > Hide/Show > Planes.

a) For Start and End Plane, click Base and Third.
These planes are parallel and define the length of the members.

b) For Plane Set 1, click Right Plane.
This plane is perpendicular and intersects with the Start and End Plane.

c) For Plane Set 2, click Front-1 and Back.
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Plane Set 2 intersects with Plane Set 1. They define the location of the two
members that are in the middle of the structure.

3. Unpin ™ the PropertyManager and click ¥.

The primary members of the structural system are complete.
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Secondary Members

You can create secondary members with these methods:

‘CHEH? On Plane Creates a member on a plane between two primary
members. Select a plane and two primary members.

e Between Points Creates a member between two primary members. Click
to position the endpoints of the secondary member. You
can offset the position by specifying a distance from the
primary members.

Creating Secondary Members from Reference Planes

To create secondary members from reference planes:

1. On the Structure System tab, click Secondary Member =],
2. Click Pin ™ at the top of the PropertyManager.

3. Click Support Plane Member H H for Secondary Member Type.

4. For Support Plane, select the Second plane in the flyout FeatureManager design
tree.

5. Click Link® and click in Member Pairs.

Link creates a chain of member pairs. The endpoint of one member pair is used as
the beginning of the next member pair in the chain.
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6. In the graphics area, select the first two members under the Overhang as shown.
The PropertyManager lists this member pair as Memberl, Member9.

L]
. W

7. Select the remaining vertical members.

8. Right-click in Member Pairs and click Delete to remove Memberl, <Select> from

the following list:

e Memberl, Member9

e Member9, Member4

o Member4, Member3

e Member3, Memberl0

e Member2, Memberl

e Memberl,<Select>

The members in the list may vary depending on the order that you select them.

9. In the PropertyManager, click Support Plane.

235



Weldments

10. In the flyout FeatureManager design tree, click the First plane to add another level
of secondary members.

11. Click ¥

Creating Secondary Members Between Points and Changing
Profiles

To create secondary members between points and change profiles:

1. Click Between Points Member #! for Secondary Member Type.

2. Change the orientation of the model by clicking View (Heads-Up) > Left View and
select the secondary members shown.

3. Adjust the position of the secondary member by clicking the Up and Down arrows
for Mem 1 and Mem 2.
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4. Change the profile of the secondary member:
a) Click Profile tab.
b) For Type, select rectangular tube - Configured.
c) For Size, select 70 x 40 x 5.

5. Change the orientation of the model by clicking View (Heads-Up) > Isometric.
6. Unpin ™ the PropertyManager and click ¥ .

7. Click Structure System [ in the Confirmation Corner to exit the structure system
mode.

The Corner Management PropertyManager displays. Simple corners highlight in the model.

Corner Management

When you create a structure system for the first time, the Corner Management
PropertyManager opens automatically.

In the PropertyManager, corners are grouped according to the number of members that
meet at a point and joint type. Corners are also color-coded to make them easier to
identify in the graphics area.

Corner type Description

Simple The position where the ends of two members meet and the
segments are collinear.

Two corner The position where two members intersect.

Complex The position where more than three members intersect.
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Trim options let you modify and adjust joints between structural members. For models
with two corners and complex corners, you can assign a member as a trim tool and use
it to add or remove material from adjacent members.

Editing Simple Corners

There are two methods for trimming:

Body trim. Conforms the intersecting member to the shape of adjacent faces by adding
or removing material.

Planar trim. Cuts the intersecting member with a plane at first contact or full contact.
First contact trims the member when it first comes into contact with adjoining faces.
Full contact is where the member is trimmed flush with adjoining faces.

To edit simple corners:

1.
2.
3.

Change the orientation of the model by clicking View (Heads-Up) > Left View.
On the Simple tab of the PropertyManager, click Simple2.

Zoom to the intersection of the corner.

The secondary member is trimmed at first contact.

For Planar Trim Options, click Full Contact -,
The corner is trimmed flush against the adjacent face.

Click ¥ .
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Trimming Complex Corners

When you assign a member as the trim tool, the member extends as needed in the
graphics area. You use the trim tool as a tool body to add or remove material from adjacent
members.

To trim complex corners:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2019\samples\whatsnew\parts\trim complex corner.sldprt.

2. In the FeatureManager design tree, right-click Corner Managementand click Edit
Feature @.
3. In the PropertyManager, under Corner Treatment:

a) Select Trim Order =1, Member6 and click T to move it to Trim Tool Member.

b) Select Trim Order =1, Member 5 and click 4 to move it to Planar Trim.
c) Click Full Contact # for Planar Trim Type.

4. Zoom to the intersection of the corners in the graphics area.
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5. In the PropertyManager, select Member4 and Member5 to display the trim effect.

A

Body Trim for Member4 Full Contact Planar Trim for Member5

6. Click ¥ .
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